Kunena 7.0.9 & Kunena 6.4.14 – Security Updates Released

The Kunena team has announce the arrival of Kunena 7.0.9 [K 7.0.9] in stable which is now available for download as a native Joomla extension for J! 5.4.x/6.0.x./6.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 / K 6.4 and issues discovered during the last development stages of K 7.0

This section is for questions directly related to the procedure for installing Kunena for the first time or upgrading from an older version of Kunena.

Use this category:
  • to ask how to install or upgrade; or
  • if you encountered problems during the installation or upgrade procedure.

Use a different category to ask questions about problems that you may be having after you successfully installed or upgraded the currently supported version. If you are unsure what is the current supported version of Kunena, please go to the download page.

Solved Kunena upgrade from 1.7 to 5.x with step 3.0.7 breaks

More
9 years 10 months ago #181722 by Smoker_Creep
Hello,

I know I'm late but I need to upgrade a Kunena Forum from 1.7 to an actual version ... so i read the instructions I found here in the forum.
I installed a fresh new Joomla 3.64 system and imported the users around 7500 ... works well
Now I copied all Kunena database tables to my fresh Joomla and changed prefixes of the tables.
I started to install Kunena 3.0.7 and than the installation breaks after Recounting forum statistics


the forum has ≈17700 messages in ≈3500 topics
Hope somebody maybe had the same problem at that installation progress step and can help?

thank you very much!!!

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #181724 by rich

I installed a fresh new Joomla 3.64


Kunena 3.0.7 will not work with Joomla 3.6.4. To skip this step and try it with Kunena 4.0.12, then upgrade to Kunena 5.0
In principle it should also work, directly from Kunena 1.7 to Kunena 5.0

Important! Always create a backup before you make any changes to your website!

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #181736 by Smoker_Creep
okay I tried with 4.0.12 and here I got the same error when I did it with Kunena 5.0 with first try. Error in screenshot below. When I had a look into the access.php can it be a user problem? which IDs are combined here? Thank you very much for helping!!!

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #181737 by 810
are the users id the same as on your old website?

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #181738 by Smoker_Creep
yes I imported with a self written script with user IDs ...
now I checked with a script kunena user table if user exist in joomla user table and deleted a handful if not
I also checked posts if that users had one ...
than checked kunena messages too if there are userid's with no user in kunena user table ...
so made sure that users exist in joomla user and kunena messages tables but no success at the end, same error :-(
are there any other parts in database that will be processed in the function that aborts?
Many many thanks for help!

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #181739 by Smoker_Creep
I tried to proceed if I commend out $read[$id] = array_combine($list, $list);
than the database update runs through 4.0.12 ...
after that I'll get to the same error as with 3.0.7 it breaks at same step like shown in my first post ... :-(

Please Log in or Create an account to join the conversation.

Time to create page: 0.247 seconds