×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Themen, die in diesen Bereich verschoben wurden, gelten allgemein als beendet. Falls es dazu noch zusätzliche Fragen gibt, können diese zwar noch gestellt werden, aber diese alten Themen sollten auf keinen Fall wieder auferstehen, um neue Probleme zu erörtern.
Eröffnet dazu bitte ein eigenes neues Thema.

Question Kunena 1.63 und Fresh Joomla 1.62 deutsch mit massiven Problemen bei Installation.

More
9 years 5 months ago #1 by TeaandTeo
Also ich habe das bestehende Kunena und eine Version aktualisiert von der SVN versucht und bei beiden tritt der gleiche Fehler auf. Ich Installiere Kunena auf einem frischen leeren Joomla 1.62 und es läuft nicht weiter. Erst wenn ich den Weiter Button klicke geht es weiter. Dann wieder klicken und es geht weiter. Also nicht automatisch...!
Irgendwie scheint es bei der Sprachinstallation zu hängen. Dann ist Kunena installiert und ich will Benutzer syncronisieren. Ich klicke auf Syncronisieren und nichts passiert. Auf Mitglieder erscheint niemand. Bei der Deinstallation kann ich die Sprachfiles manuell nicht mehr löschen und muss auf Cache erneuern gehen. Dann gehts.

Hier mal ein paar Screens von der Install: www.erdenwind.de/demo/Joomla1.swf

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago - 9 years 5 months ago #2 by rich
Servus TeaandTeo!

Da hast du dir große Mühe gemacht, um es zu demonstrieren. Danke dafür!
Dieses Problem tritt in Zusamenhang Joomla 1.6.2 und Kunena 1.6.3 auf. Mit Kunena 1.6.4 (welches demnächst rauskommt) tritt dieses Problem bei der Installation nicht mehr auf.

Bei der Deinstallation kann ich die Sprachfiles manuell nicht mehr löschen und muss auf Cache erneuern gehen. Dann gehts.

Ja, das kenne ich auch. Es ist bei den englischen Sprachdateien das selbe, wenn du das Forum auf englisch betreibst. Die Sprachfiles (deren Sprache als Standard definiert ist) lassen sich nicht auf Anhieb entfernen.
Last edit: 9 years 5 months ago by rich.

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #3 by TeaandTeo

rich wrote: Servus TeaandTeo!

Da hast du dir große Mühe gemacht, um es zu demonstrieren. Danke dafür!
Dieses Problem tritt in Zusamenhang Joomla 1.6.2 und Kunena 1.6.3 auf. Mit Kunena 1.6.4 (welches demnächst rauskommt) tritt dieses Problem bei der Installation nicht mehr auf.

Bei der Deinstallation kann ich die Sprachfiles manuell nicht mehr löschen und muss auf Cache erneuern gehen. Dann gehts.

Ja, das kenne ich auch. Es ist bei den englischen Sprachdateien das selbe, wenn du das Forum auf englisch betreibst. Die Sprachfiles (deren Sprache als Standard definiert ist) lassen sich nicht auf Anhieb entfernen.


Das mit dem Cache ist eigentlich nicht weiter tragisch erstmal. Tritt ja nur bei dem Versuch zu deinstallieren auf. Was gravierender ist das die Installroutine nicht automatisiert weiterläuft. Das trat bei Joomla 1.6 und Kunena 1.61/1.62 nicht auf meines Wissens.

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #4 by rich

Was gravierender ist das die Installroutine nicht automatisiert weiterläuft.

Ja, das habe ich getestet und dadurch kann es zu einer inkompletten Installation kommen (siehe hier). Dieser Fehler tritt eigentlich erst seit Joomla 1.6.2 auf. Mit Joomla 1.6.1 gab es in Zusammenhang mit Kunena 1.6.3 meines Wissens diesen Fehler auch noch nicht.

K1.6.3 war ein Sicherheitsupgrade und nicht die vollständige Anpassung an Joomla 1.6. Dieser
Installationsfehler tritt mit K1.6.4 nicht mehr auf.

Das mit dem Cache ist eigentlich nicht weiter tragisch erstmal. Tritt ja nur bei dem Versuch zu deinstallieren auf.

In diesem Zusammenhang bin ich jetzt auf etwas dahinter gekommen, was anscheinend doch gravierend ist. Ob dieser Fehler jetzt auf Kunena, oder den Joomla-Installer zurückzuführen ist, will ich nicht beurteilen.

Und zwar meine Konstellation:
Installiert ist Joomla 1.6.2 mit deutschen Sprachfiles. Ausgewählt habe ich allerdings die englische Sprache, sowohl im Front- als auch im Backend. Wenn ich jetzt Kunena deinstalliere und auch die "Kunena Forum - German" Dateien mit auswähle, dann werden nicht nur die Kunena German Dateien entfernt, sondern die kompletten deutschen Sprachordner, samt Sprachdateien von Joomla und auch Erweiterungen.

Ich werde es jedenfalls an die Entwickler weiter leiten.

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago #5 by TeaandTeo

rich wrote:

Was gravierender ist das die Installroutine nicht automatisiert weiterläuft.

Ja, das habe ich getestet und dadurch kann es zu einer inkompletten Installation kommen (siehe hier). Dieser Fehler tritt eigentlich erst seit Joomla 1.6.2 auf. Mit Joomla 1.6.1 gab es in Zusammenhang mit Kunena 1.6.3 meines Wissens diesen Fehler auch noch nicht.

K1.6.3 war ein Sicherheitsupgrade und nicht die vollständige Anpassung an Joomla 1.6. Dieser
Installationsfehler tritt mit K1.6.4 nicht mehr auf.

Das mit dem Cache ist eigentlich nicht weiter tragisch erstmal. Tritt ja nur bei dem Versuch zu deinstallieren auf.

In diesem Zusammenhang bin ich jetzt auf etwas dahinter gekommen, was anscheinend doch gravierend ist. Ob dieser Fehler jetzt auf Kunena, oder den Joomla-Installer zurückzuführen ist, will ich nicht beurteilen.

Und zwar meine Konstellation:
Installiert ist Joomla 1.6.2 mit deutschen Sprachfiles. Ausgewählt habe ich allerdings die englische Sprache, sowohl im Front- als auch im Backend. Wenn ich jetzt Kunena deinstalliere und auch die "Kunena Forum - German" Dateien mit auswähle, dann werden nicht nur die Kunena German Dateien entfernt, sondern die kompletten deutschen Sprachordner, samt Sprachdateien von Joomla und auch Erweiterungen.

Ich werde es jedenfalls an die Entwickler weiter leiten.


Das wäre fein. Noch etwas kann als Fehler / Bug gemeldet werden in Zusammenhang mit einer Deinstallation von Kunena. Hat man das Framework Template von JYAML 4.0RC1 installiert und will Kunena deinstallieren kommt eine Fehlermeldung irgendwas mit JLIB und erst wenn man JYAML oder Kunena erneut installiert verschwindet dieses dann. Ich tippe hier auf Kunena!!!

Please Log in or Create an account to join the conversation.

More
9 years 5 months ago - 9 years 5 months ago #6 by rich
Da du (wie du mir berichtet hast) zum Joomla Übersetzerteam gehörst, solltest du eigentlich auf dem Laufenden sein. Nicht alle Fehler kann man Kunena zuschreiben. Mach ein Upgrade auf Joomla 1.6.3 und zumindest der Installationsfehler und das Javascriptproblem im Backend sollten danach behoben sein.
Last edit: 9 years 5 months ago by rich.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.126 seconds