×
Kunena 5.2 RC 1 Released (25 Oct 2020)

The Kunena team is thrilled to announce the first public release candidate of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 RC1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Themen, die in diesen Bereich verschoben wurden, gelten allgemein als beendet. Falls es dazu noch zusätzliche Fragen gibt, können diese zwar noch gestellt werden, aber diese alten Themen sollten auf keinen Fall wieder auferstehen, um neue Probleme zu erörtern.
Eröffnet dazu bitte ein eigenes neues Thema.

Question Kunena 1.6.1

More
9 years 11 months ago #1 by christkind
Kunena 1.6.1 was created by christkind
Hallo Kunena-Freunde,

beim Upgrade-Versuch von Kunena 1.5.12 auf 1.6.1 erhalte ich nach dem ersten Schritt folgende Fehlermeldung:

Warning: domdocument::domdocument() expects parameter 2 to be long, string given in C:\apachefriends\xampp\htdocs\Joomla\administrator \components\com_kunena\install\schema.php on line 188

Fatal error: Call to undefined method domdocument::loadXML() in C:\apachefriends\xampp\htdocs\Joomla\administrator \components\com_kunena\install\schema.php on line 191


Dieselbe Fehlermeldung tritt übrigens auch beim Upgrade-Versuch auf Kunena 1.6.0 auf.

Ich verwende PHP 5.2.6, XAMP for Windows 1.6.7. Mootools 1.2.4 ist aktiviert, ohne dass Fehlermeldungen auftreten, ebenso System SEF.

Kann mir jemand einen Tipp geben, woran es liegt und wie ich den Fehler beheben kann? Leider bin ich in Prgrammiersprachen nicht versiert. Deshalb bitte ich, wenn möglich, um eine genaue Anleitung.

Danke im Voraus.

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #2 by rich
Replied by rich on topic Aw: Kunena 1.6.1
Willkommen christkind,

aktuell ist XAMPP 1.7.3. versuche es damit.
The following user(s) said Thank You: christkind

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #3 by haithun
Replied by haithun on topic Re: Aw: Kunena 1.6.1
Mit der aktuellen Version gibt es eher noch mehr Probleme weil die PHP 5.3.x hat und Joomla damit ja nicht läuft (zumindest bei mir).

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #4 by Baer
Replied by Baer on topic Re: Aw: Kunena 1.6.1
Warum läuft Joomla nicht mit PHP 5.3 ? Welche Version hast Du denn da ? Ich kenne bis jetzt nicht eine Installation in der aktuellen Version die mit PHP 5.3 Probleme hat.

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #5 by rich
Replied by rich on topic Aw: Kunena 1.6.1
Kann man bei XAMPP für Windows nicht mehr zwischen den Versionen hin und her switchen? Da gab es doch etwas. Ich kann es leider nicht beurteilen, da ich kein Windows verwende.

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #6 by haithun
Replied by haithun on topic Re: Aw: Kunena 1.6.1
Etwa ein Mac? o.O

Ich habe mal Probleme gehabt, was aber wohl an der PHP-ini lag, da dort wohl anfangs das Strictcoding aktiviert war und es beim JoomlaFramework zu Problemen kam.

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #7 by rich
Replied by rich on topic Aw: Kunena 1.6.1
Nein, kein Mac, sondern Ubuntu. Aber ich muss dir recht geben, bei mir läuft XAMPP 1.7 MIT PHP 5.2
Habe es gestern mit PHP 5.3 versucht und ebenfalls Schwierigkeiten bekommen (aber mich nicht weiter damit befasst, ob diese zu beheben gewesen wären).

Doch ich habe im Joomla Forum einen Beitrag gefunden, wo "christkind" ebenfalls ein Upgrade geraten wurde. Allerdings nur auf 1.7.1.
www.joomlaportal.de/joomla-erweiterungen...-kunena-1-6-1-a.html
Leider gibt es bis jetzt noch keine Rückmeldung von christkind.

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #8 by christkind
Replied by christkind on topic Re: Aw: Kunena 1.6.1
Hallo rich,
ein ganz großes Danke für deine Hilfe. Hat alles wunderbar funktioniert.
Kunena 1.6.1 läuft wunderbar.
Gruß Christkind

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago - 9 years 11 months ago #9 by christkind
Replied by christkind on topic Re: Aw: Kunena 1.6.1
Hallo nochmal,

jetzt habe ich doch ein paar Problemchen mit Kunena 1.6.1, läuft auf Joomla 1.5.22 und Xampp 1.7.3.Die Text-Links "Ankündigungen", "Letzter Beitrag", "Mitgliederliste" und "Mehr Statistiken"funktionieren leider nicht.

Fehlermeldung im Firefox:
"Umleitungsfehler, die aufgerufene Website leitet die Anfrage so um, dass sie nie beendet werden kann.Dieses Problem kann manchmal auftreten, wenn Cookies deaktiviert oder abgelehnt werden."

Fehlermeldung Google Chrome:
"Diese Webseite weist eine Weiterleitung auf.Die Webseite unter https://localhost/joomla/index.php/forum/announcement/show.html?defaultmenu=136 hat zu viele Umleitungen erzeugt. Das Löschen Ihrer Cookies für diese Website oder das Zulassen von Drittanbieter-Cookies könnte das Problem möglicherweise beheben. Sollte sich das Problem damit nicht beheben lassen, liegt eventuell ein Serverkonfigurationsfehler und kein Problem mit Ihrem Computer vor."

Fehlermeldung Internet Explorer:
"Gelbes Warndreieck unten links ....auf https://...wird gewartet."
Das Fenster mit den grünen Ladebalken ist voll. Man merkt aber, dass die Suche endlos weiterläuft.

Kann mir jemand einen Tipp geben?

Viele Grüße
Christkind
Last edit: 9 years 11 months ago by christkind. Reason: Cookies löschen hat nicht geholfen

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago - 9 years 11 months ago #10 by rich
Replied by rich on topic Aw: Kunena 1.6.1
Ja, du kannst einen Tipp haben. :)

Es sind die alten Links zum Forum, die übernommen wurden. Das einfachste ist, wenn du sämtliche Links zum Forum in den Menüs deaktivierst. Danach gehst du in die Kunenaverwaltung und klickst auf "Menü erstellen". Danach müsstest du im Hauptmenü wieder einen neuen Link zum Forum haben. Überprüfe, ob dieser funktioniert, er sollte es.

Wenn du weitere Links benötigst z.B. im Topmenü, dann gehst du wieder im den Menümanager > Hauptmenü und markierst den funktionierenden Link und klickst dann ganz oben auf kopieren. Danach erscheint eine Auswahl, wählst dort wieder z.B. Topmenü und danach noch mal oben auf kopieren und fertig.

Oder die andere Variante, du gehst gleich (nachdem neue Menüs erstellt wurden) ins Topmenü, wählst "Neu > Kunena Menü > Kunena Startseite" und wählst ganz rechts die Startseite aus. Bei dieser Variante muss das Feld "Alias" ausgefüllt werden. Bei weiteren Links nicht mehr die selben Alias-Namen verwenden!

Auf beide Arten kannst du noch weitere Menüs anlegen.
Last edit: 9 years 11 months ago by rich.
The following user(s) said Thank You: christkind

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.141 seconds