×
Blue Eagle 5 v1.5.4 has been Released (13 Sep 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.4 which is now available for download. This version addresses most of the issues that were discovered in development.

× Themen, die in diesen Bereich verschoben wurden, gelten allgemein als beendet. Falls es dazu noch zusätzliche Fragen gibt, können diese zwar noch gestellt werden, aber diese alten Themen sollten auf keinen Fall wieder auferstehen, um neue Probleme zu erörtern.
Eröffnet dazu bitte ein eigenes neues Thema.

Question Kunena 1.6 | Example Template --> CSS-Anpassungen

More
9 years 10 months ago - 9 years 10 months ago #1 by rich
Zitat von Dohlaeh:

Hallo... ich bräuchte Hilfe bei folgendem Problem: Ich habe versucht das Example Template meiner 1.6er Kunena Version farblich an meine Webseite anzupassen (via relevante CSS-Files), allerdings bekomme ich das BABYBLAU in der Hauptansicht nicht weg (obwohl der Farbcode in allen CSS-Files nicht mehr vorkommt) - siehe Screenshot... was kann/muss ich tun, um das hinzubekommen?


Hallo Dohlaeh,
ich habe einen Teil deines Beitrages (den man in der Vorschau sehen konnte), wieder hergestellt. Bitte ergänze den fehlenden Rest.

Danke, rich
Last edit: 9 years 10 months ago by rich.
The following user(s) said Thank You: Dohlaeh

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #2 by Dohlaeh
Alles klar, VIELEN DANK... anbei der Screenshot sowie mein Kunena-Konfigurationsbericht... ;-)

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Enabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Enabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 8M

This message contains confidential information

Joomla default template details : rhuk_milkyway | author: Andy Miller | version: 1.0.2 | creationdate: 11/20/06

Kunena version detailled: Installed version: 1.6.1 | Build: 3858 | Version name: Timu | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Installed (Version : 1.2.1) | Jomsocial: Disabled or not installed | UddeIm: Installed (Version : 2.0)

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Disabled | JFirePHP: Disabled or not installed | Kunena Discuss: Disabled or not installed | Kunena Search: Disabled or not installed | My Kunena Forum Menu: Disabled or not installed | My Kunena Forum Posts: Disabled or not installed

Modules: Kunena Latest: Enabled (Version : 1.6.0-RC2) | Kunena Stats: Disabled or not installed | Kunena Login: Disabled or not installed

Attachments:

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago - 9 years 10 months ago #3 by rich
Hallo Dohlaeh,

habe mal geguckt, anscheinend wird folgender Farbcode von "scinner" überschrieben.

#Kunena a:link,
#Kunena a:visited,
#Kunena a:active {color: #5388B4;}
#Kunena a:focus {outline: none;}
#Kunena a:hover {color: #FF0000;}

Du könntest jetzt bei
#Kunena a:active {color: #5388B4;}
ein !important dazu schreiben, #Kunena a:active {color: #5388B4 !important;} aber dann wird der Link vom Balken ebenfalls mit dieser Farbe überschrieben.

Das einfachste ist, wenn du diesen Farbcode grundsätzlich änderst und zwar in "...template/default/initialize.php" Zeile 86, Code:
$forumLink = $this->params->get('forumLinkcolor', $skinner ? '' : '#5388B4'
Hat den Nachteil, dass du wahrscheinlich nach einem Update dort den Farbcode wieder anpassen musst.
Last edit: 9 years 10 months ago by rich.
The following user(s) said Thank You: Dohlaeh

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #4 by Dohlaeh
Vielen Dank, jetzt passt alles (abgesehen von den babyblauen Buttons)... ;-)

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago - 9 years 10 months ago #5 by FFLNO
Das Thema trifft in etwa mein Problem, deshalb will ich es gleich hier anbringen und nicht noch ein Thema aufmachen:

Ich hab mir vom Template Example eine Kopie gemacht und die CSS meiner Kopie (kunena-forum-min.css) farblich soweit an meine Webseite angepasst. Soweit so gut, hat alles funktioniert bis zum Update von 1.6.0 auf 1.6.1.

Danach waren leider wieder die blauen Farben da, obwohl die CSS noch die ursprünglich von mit geänderten Farbcodes ausweist. Firebug teilt mit, dass hierfür jetzt ein Eintrag in der index.php verantwortlich ist, in Zeile 26, was vorher nicht so war. (Screen 1)



Soweit auch alles klar, wenn ich den in Firebug deaktiviere, hab ich meine alten Farben wieder und auch der Hover-Effekt funktioniert wieder. (Screen 2)





Wenn ich in Firebug das entsprechende Skript aufrufe, ist da auch wie folgt dargestellt: (siehe Screen 3).





Jetzt hab ich mir die index.php angesehen:

components/kunena/index.php
components/kunena/templates/index.php
components/kunena/templates/defaul/index.php

aber leider steht da jeweils nur:

1. <?php
2. /*
3. this is a dummy file and intentionally left blank
4. do not remove from ditribution package
5. /*
*/
6. ?>

Im Example-Template gibts keine Index.php und in meiner Kopie logischerweise auch nicht. Wo finde ich den die Eintragungen (Kunena Custom CSS). Ich bin ratlos, wer kann mir helfen ? Danke schon mal im voraus.
Attachments:
Last edit: 9 years 10 months ago by FFLNO.

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #6 by rich

Vielen Dank, jetzt passt alles (abgesehen von den babyblauen Buttons)...

Diese babyblauen Buttons solltest du weg bekommen, indem du in der Kunen-Administration > Template-Manager dein Template auswählst und danach rechts bei "Hintergrund der Forum-Kopfzeile" den Farbcode änderst.

@ FFLNO,

das ist das selbe Problem. Lies oben meinen Beitrag und du hast die Lösung.

Als Info: Es handelt sich um einen Bug, der in der nächsten Version behoben sein wird.

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #7 by FFLNO
Jo, habs schon umgesetzt. Die Farbe haut jetzt hin, allerdings nach wie vor kein Hover. Kann erst mal leben damit, wenns beim nächsten Update ehe bereinigt wird. Danke !

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #8 by rich

allerdings nach wie vor kein Hover.

Setze bei dem Code "#Kunena a:hover..." ein "!important" dahinter (rot).

#Kunena a:link,
#Kunena a:visited,
#Kunena a:active {color: #5388B4;}
#Kunena a:focus {outline: none;}
#Kunena a:hover {color: #FF0000 !important;}

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #9 by FFLNO
Perfekt. Das selbe hab ich bei den verlorenen Hovers im oberen Menue gemacht, alles prima. Danke vielmals !! :laugh:

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.852 seconds