×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× Themen, die in diesen Bereich verschoben wurden, gelten allgemein als beendet. Falls es dazu noch zusätzliche Fragen gibt, können diese zwar noch gestellt werden, aber diese alten Themen sollten auf keinen Fall wieder auferstehen, um neue Probleme zu erörtern.
Eröffnet dazu bitte ein eigenes neues Thema.

Solved neues Thema kann nicht erstellt werden

More
6 years 10 months ago - 6 years 10 months ago #1 by roloe
Ich hatte das Forum in einer früheren Seite schon einmal am Laufen. Jetzt habe ich es auf einer neuen Site erstellt, und kann keine Themen erstellen. :dry:
- Auch als Supernutzer kann ich kein neues Thema erstellen
- Registerkarten sind nicht sichtbar
- nehme ich aus dem Menü den Punkt "neues Thema", so erscheint der Link, bewirkt aber nichts
- Kunena-Template: das vorgefertigte
- Joomla-Template: eigenes
(Screenshots im Anhang)

Vielen Dank für Eure Mühe. Falls notwendig, stelle ich weiter Infos zur Verfügung.
Ich bitte um Entschuldigung, falls ich ein identisches Thema nicht gefunden habe.
Ronald
Attachments:
Last edit: 6 years 10 months ago by roloe. Reason: Ergänzung

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago #2 by rich
Herzlich willkommen roloe!

Wenn du uns bitte einen Konfigurationsbericht erstellst, ist es wesentlich leichter, dir zu helfen.
www.kunena.org/forum/36-German/57592-bit...hr-eine-frage-stellt
Nach deinen Bildern zu urteilen, hast du deine Menülinks falsch angelegt, siehe hier:
www.kunena.org/docs/Men%C3%BCprobleme
The following user(s) said Thank You: roloe

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago #3 by roloe
Erst einmal vielen Dank für die schnelle Hilfe. Das Menü konnte ich auf diese Weise wieder herstellen, das Erstellen eines neuen Themas läuft trotzdem in das Leere. Hier mein Konfigurationsbericht:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 64M | Max file upload: 8M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : gym_v1 | author: test1gym | version: 1.0.0 | creationdate: 19 April 2011

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 2.0.4 | creationdate: 2013-01-18

Kunena version detailed: Kunena 2.0.4 | 2013-01-18 [ Pharmacopoeia ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago - 6 years 10 months ago #4 by rich
Du hast (lt. Konf-Bericht) noch immer zwei Menüpunkte, welche falsch angelegt sind. Es sind die Links „Neues Thema“ und „Wichtiges“.
Das Problem dabei ist, dass Kunenamenüs Probleme verursachen können, wenn sie in anderen Menüs verwendet werden.
Aber es ist trotzdem möglich, alles so zu verlinken, wie du es es wünscht. Nachdem es für manche Links nicht möglich ist, einen „Alias“ Menüeintrag zu erstellen, da dass gewünschte Ziel in der Auswahlliste nicht vorhanden ist, kannst du auch den Menütyp „Externe Url“ verwenden.

Dazu ruft man einfach mit dem Browser das gewünschte Ziel auf, kopiert danach die Url und gibt diese als Ziel an. Dabei ist es nicht nötig, die gesamte Url einzugeben, es reicht der relative Wert. z.B. der Link zum erstellen eines neuen Themas wird dir folgende Adresse angezeigt:
www.deineadresse.de/index.php/forum/newtopic
Dann gibst du das hier ein:
index.php/forum/newtopic
Ebenso kannst du es mit dem Link auf die Kategorie „Wichtig“ machen.

Wenn danach immer noch Fehler auftreten, versuche es bitte mal mit dem Joomla Standard Template Beez 20.
Last edit: 6 years 10 months ago by rich.

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago #5 by roloe
Die Register sind jetzt sichtbar, das Menü scheint intakt. Aber es bleibt noch das Problem, dass ich keine neuen Themen erstellen kann. Ganz egal, womit ich angemeldet bin. Das kann doch kein Template-Problem sein, oder?

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago #6 by rich

Das kann doch kein Template-Problem sein, oder?

Unmöglich ist es nicht. Hast du es schon getestet?

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago - 6 years 10 months ago #7 by roloe
OK, mit dem neuen Template spricht er mit mir:

Du hast keine Berechtigungen, um ein neues Thema zu starten!

Zugriffsebenen sind eingentlich OK, können noch Dateirechte des Servers im Hintergrund quer liegen?
Attachments:
Last edit: 6 years 10 months ago by roloe. Reason: Screenshot angehängt

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago #8 by rich
Das Bild zeigt nur die Berechtigung für die Hauptsektion. Daraus erkenne ich, dass diese nur eine bestimmte Gruppe sehen kann. Themen eröffnen kannst du nur in Kategorien, welcher dieser Sektion untergeordnet sind. Aber auch in den Kategorien müssen die Rechte erteilt werden. Dabei hast du sogar die Möglichkeit zu bestimmen, wer Themen eröffnen kann und wer „nur“ darauf antworten darf.



Attachments:

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago #9 by roloe
Wie du auch in meinem Screenshot gesehen hast, die von dir rot gekennzeichneten Einstellungen habe ich noch nie gesehen. Da ich das Template des Backend nicht geändert habe, kann es eigentlich nicht an meinem Frontend-Template liegen. Aber ich denke, langsam kommen wir der Sache näher.
Vielleicht habe ich keine Rechte, diese Einstellungen vornehmen zu können, und deshalb werden sie mir nicht angezeigt. Auch die letzten beiden oben liegenden Register sehe ich nicht.
Ich habe übrigens zwischenzeitlich Kunena vollständig deinstalliert und wieder neu installiert.

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago - 6 years 10 months ago #10 by rich

Wie du auch in meinem Screenshot gesehen hast, die von dir rot gekennzeichneten Einstellungen habe ich noch nie gesehen.

Das liegt höchstwahrscheinlich daran, dass es sich um eine Sektion (oberste Ebene) handelt. Da gibt es nicht diese Einstellung. Wenn dir die Rechte fehlen würden, dann könntest du auch in der Sektion nichts ändern.

Es mag vielleicht etwas verwirrend sein, da trotzdem „Kategorie 'Testforum' bearbeiten“ dabei steht. Das liegt daran, dass früher kein Unterschied zwischen Kategorie und Sektion (Bereich) gemacht wurde und deshalb kein eigener Sprachstring vorhanden ist.

Erstelle bitte eine neue Kategorie „Test zwei“ und als Elternteil wählst du „Testforum“. Dann solltest du alle Einstellungen finden, die du vermisst.

Hier ist es recht einfach beschrieben, wie man Kategorien organisiert.
www.kunena.org/docs/Tutorial_f%C3%BCr_Kunena_Starter
Last edit: 6 years 10 months ago by rich.
The following user(s) said Thank You: roloe

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.158 seconds