×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Please note: The Kunena project team takes NO responsibility for maintaining nor supporting anything in this category.

Question Can't Get Kunena to display Font-Awsome Glyphs

More
4 years 3 months ago #1 by webdevtim
Have added the Font-Awsome 'Fonts' folder to my template root. Added font-awesome.min.css to the templae/css folder. Added
@import url("font-awesome.min.css");
.fa:before {
  font-family: fontawesome;
}
.fa {
  font-family: Verdana, Arial, sans-serif;
}
to the template.css file.

added:
.icon-group:before {
	content: "\f0c0";
}
to the template.css file and alternatively added
.fa-user:before {
	color: #002a67;
}
to the template.css and in the one case added icon-group to the Category Icon: field and in the other case .fa-user to the Category Icon field. In both cases Kunena only display a place holder square for the icon, but in the Joomla Home menu a house is displayed next to the words home using the same procedure. Is there something else I need to do?

Please Log in or Create an account to join the conversation.

More
4 years 3 months ago #2 by 810
try
.fa {
font: normal normal normal 14px/1 FontAwesome;
}

Please Log in or Create an account to join the conversation.

More
4 years 3 months ago #3 by webdevtim
That worked after I made some other changes.

I added the following classes:
[class^="fa-icon-"],
[class*=" fa-icon-"] {
	position: relative;
}
[class^="fa-icon-"]:before,
[class*=" fa-icon-"]:before {
	color: #00264d;
	font-family: FontAwesome;
	font-style: normal;
	font-weight: normal;
	left: 0;
	text-decoration: inherit;
	position: absolute;
}
[class^="fa-icon-"].disabled,
[class*=" fa-icon-"].disabled {
	font-weight: normal;
}
 
 
.fa-icon-group:before {
	content: "\f0c0";
}

And this did it.

Thank you for your help.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.071 seconds