×
Blue Eagle 5 v1.6.2 has been Released for Kunena 5.2 (20 Jan 2021)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.6.2 which is now available for download. This version addresses most of the issues that were discovered in development.

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with

Solved Can not read attachments as moderator

More
1 month 20 hours ago #1 by halford
Hi Folks
We are running a Forum (5.2.2) where I'am moderator in the most categories/boards. But in some of these boards I can't 'read' attachments, and the COM_KUNENA_NO_ACCESS language token is shown instead of the attachment. I have tried to debug the code, but then I was lost in the many authorise calls. It seems that the read.attachment or post.topic.read.attachment permission is missing in some of the boards.

Does anybody have a hint for me, what can cause this behavior, respectively where I can adjust this permisson? I've seached the configuration, the manual, this forum, but nothing found so far.

Thanks in advance
Rob

Please Log in or Create an account to join the conversation.

More
1 month 12 hours ago #2 by rich
This error happens if users use the browser back and forwards button when they have already added an attachment. Kunena recognize this as abort and the image get no message ID and so it will not be displayed.

Please Log in or Create an account to join the conversation.

More
4 weeks 2 days ago #3 by halford
Yes, a few minutes ago I recognised that these attachments has no message-id in the kunena_attachment table. And if I insert the right message-id they are shown as it should.

Seems that this might be the problem, thanks.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.065 seconds