×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

Solved migration probs from J 1.5 to J 3

More
1 year 2 months ago #1 by martinsai
Hi Guys,
I need to transfer kunena including all content like messages, categories from a Joomla 1.5 (Kunena V 1.5.12) website to latest Joomla Version with Kunena 5.1.12.1

So far I have installed the component succesfully. I also could import/export the Joomla Users to the new Kunena forum.
I read in tutorials that I just have to export from old Kunena data tables and import them into new mysql.

1.Prob: I have migrated the categories and the messages for instance but in new Joomla/Kunena admin panel the categories are not displayed. I also renamed the table from xxx_fb_messages to xxx_kunena_messages. same with categories but they are not displayed.
what have I done wrong? I also pressed the repair button in Joomla backend > Extesnions > Data Base, but no success.

2. Prob: the old kunena version has different data tables names and structure. What is there to do so that kunena will run again on new version?

cheers and thnx a lot, martin

Please Log in or Create an account to join the conversation.

More
1 year 2 months ago #2 by rich
Your steps are all wrong.

I also could import/export the Joomla Users to the new Kunena forum.

1. You must import the Joomla users to the new Joomla, not to Kunena! The Joomla users must be the same!
2. Afterwards delete all Kunena tables in your new web page.
3. Import all old Kunena fb tables and change the prefixes of the fb tables to your new prefixes xxxx_fb_
4. Now you must go back to an old php 5 version, otherwise is step 5 not possible!
5. Install as intermedia step Kunena 4.0.12 (Kunena recognices the old tables and migrated this tables to the new structure)
github.com/Kunena/Kunena-Forum/releases/tag/4.0.12
6. Upgrade Kunena
7. Joomla 1.5 has another user management as Joomla 3.9. Therefore you must after the migration adjust all category permissions manually, otherwise users have no access and can't see the categories.
8. Check if all works
9. Now you can change again to the current php version
10. If you want, you can delete now all fb tables. They are not needed anymore after a successful migration.

Please Log in or Create an account to join the conversation.

More
1 year 2 months ago #3 by martinsai
Dear Rich,

thnx a lot!!!!!!!!!!! I did all steps and it worked fine! I was on the wrong path!
I just saw now that the default category view looks very different to the old default template. I purchased the Blue eagle 5! and it works, great!

Now 2 questions: how can I remove the tooltipps over the category title links?
if I want to create new topic, there are many parameters to be filled out like "Confirm the text to be exchanged" or " Image configuration....
(see image) how to remove all that?

cheers
martin
Attachments:

Please Log in or Create an account to join the conversation.

More
1 year 2 months ago #4 by rich
Which Joomla template use you and have you installed Blue Eagle correct? docs.kunena.org/en/manual/backend/templates/add-template
Maybe your Joomla template does not use bootstrap.css. If it so, then choose in the Blue Eagle template setting Load bootstrap css.

Please Log in or Create an account to join the conversation.

More
1 year 2 months ago #5 by martinsai
Rich you are just great!
both probs solved. Template was correctly installed, I loaded bootstrap and now both props are gone! thnx again!

cheers, martin

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.105 seconds