×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

Question Some topic subscriptions are lost after topic merge

More
4 years 5 months ago - 4 years 5 months ago #1 by Fox
Hi all,
I've just realized that after merging the topic "B" into the topic "A", the subscriptions to the topic "B" are deleted, instead of being converted into subscriptions to the topic "A".

That way, even if everyone chose to subscribe to his own topic, actually only the subscribers of topic "A" continues receiving email notifications after the merge.

Is that a bug or the intended behaviour?

- Demis Palma -
Last edit: 4 years 5 months ago by Fox.

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #2 by xillibit
Hello,

During merge the subscriptions aren't keeped, this isn't an intented behaviour it has been forgot. I will add as bug for now

I don't provide support by PM, because this can be useful for someone else.
The following user(s) said Thank You: Fox

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #3 by Fox
Thanks.
Do you think that this problem has been introduced with the version 4, or it is older?

- Demis Palma -

Please Log in or Create an account to join the conversation.

More
4 years 5 months ago #4 by xillibit
I never noticed this issue and the code has changed a bit in Kunena 4.0, so it could have been introduced in 4.0

Added on github : github.com/Kunena/Kunena-Forum/issues/3861

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
4 years 1 month ago - 4 years 1 month ago #5 by Fox
The problem is still present in Kunena 5.0.0.

- Demis Palma -
Last edit: 4 years 1 month ago by Fox.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.085 seconds