×
K5.1.1 is released (10 Jun 2018)

The Kunena team is pleased to announce Kunena 5.1.1 [K 5.1.1].
Please read the blog post for information:

Question Recently changed server and lost forums

More
2 years 2 months ago - 2 years 2 months ago #1 by Sleddheadd
I've searched and searched on here for a similar topic but can not find one.
I recently switched servers to HostGator and during the migration, I have lost my kunena forum. If you are on my home page midwest sledders.com and click the forums tab, you will witness the internal server error 500. Host Gator has told me a few different things. first one was that if you type midwest sledders.com/forum the forum will appear with error messages. That Tech had told me that the current link being used is midwest sledder.com/forums.
how can I change this link? I just need to drop the s from forum.
I have searched the back end and not been able to find the location to get this done.
Today's tech had told me that it is not their server but a problem with the forum CMS and i need to contact CMS support to get the issue resolved.
I am running Joomla 3.5.0 and Kunena 4.0.10
can someone please help me get pointed in the right direction to get this fixed.
I apologize if this is a repost but I'm really at a loss here!
Thank you
Last edit: 2 years 2 months ago by Sleddheadd.

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #2 by 810
turn on kunena debug on the settings, that will show the real error on the page, so you can see where the issue is.

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #3 by Sleddheadd
Debug is turned on and the page is loaded with warnings
Warning: Missing argument 1 for KunenaLayout::getPath(), called in /home1/m4t3e7b5/public_html/libraries/kunena/view.php on line 660 and defined in libraries/kunena/layout/layout.php on line 140

Notice: Undefined variable: layout in libraries/kunena/layout/layout.php on line 143

Where can i start to get this fixed?

Host Gator says I need to contact forum support and it has nothing to do with their server or the migration.

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #4 by xillibit
Hello,

Do-you using Kunena blue eagle template ? Do-you have access to php errors log on the control panel of your hosting offer ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #5 by 810
try to install kunena again

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago - 2 years 2 months ago #6 by Sleddheadd

810 wrote: try to install kunena again

Would that require uninstalling first? We have had this forum going for about 4 years now and I'd hate to uninstall and have to rebuild.
Last edit: 2 years 2 months ago by Sleddheadd.
The following user(s) said Thank You: SaraAnistion

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #7 by 810
no, just install the packages again, i think you miss some files.

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #8 by Sleddheadd

xillibit wrote: Hello,

Do-you using Kunena blue eagle template ? Do-you have access to php errors log on the control panel of your hosting offer ?

I am using Blue Eagle, I do have access to error log on cPanel

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #9 by xillibit
is-there the stacktrace in the log, around the errors :

Warning: Missing argument 1 for KunenaLayout::getPath(), called in /home1/m4t3e7b5/public_html/libraries/kunena/view.php on line 660 and defined in libraries/kunena/layout/layout.php on line 140

Notice: Undefined variable: layout in libraries/kunena/layout/layout.php on line 143

?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.084 seconds