×
Kunena 5.1.3 Released (19 Aug 2018)

The Kunena team has announce the arrival of Kunena 5.1.3 [K 5.1.3] which is now available for download as a native Joomla extension for J! 3.8.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a maintenance release.

Question Still cannot post in Kunena 4.0.3 - configuration report included

More
3 years 1 week ago #1 by rob parker
I posted a question on this about 6 days ago, but there's been no answers, so I'm trying again. I've changed the access control for my categories as detailed below, but still get the same "You do not have permissions to start a new topic!" notice. I've included the forum's configuration report at the end of this post.

I'm wanting to use Kunena 4.0.3 on a Joomla 3.4 website, and I'm testing on a localhost installation. I have set up Section and Category items, and published them. Initially, they all had access control set to joomla:level, with Category Permissions set to:
Access: Public
User Groups Allowed To Post: Manager, Registered, Super Users
User Groups Allowed To Reply: Manager, Registered, Super Users

Since my first post, I've installed another site with Kunena, and had no problem posting to that site. I then set the same access control for my Section and Category items, thus:
Access Control Type: User Groups
Primary User Group: Public
Primary Includes Child Groups: Yes
User Groups Allowed To Post: Manager, Registered, Super Users
User Groups Allowed To Reply: Manager, Registered, Super Users

Forum Configuration - Security has Allow Guests to Post/Write set to No, and Registered Users Only set to No.

I have the following Joomla users set up, in these groups:
rob - Registered
rob-admin - Super User

When I installed K 4.0.3, forum user records were created for these users, and I can see them in the administrator User Manager, with the following Rank:
rob - New Member
rob_admin - Administrator

When I log in to the forum as either of these users, and attempt to create a New Topic, I receive a "You do not have permissions to start a new topic!" notice.

What am I missing here?

Rob

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 3000 seconds | Max execution memory: 128M | Max file upload: 16M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : Favourite | author: FavThemes | version: 3.2 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 4.0.3 | creationdate: 2015-06-29

Kunena version detailed: Kunena 4.0.3 | 2015-06-29 [ Possagno ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
3 years 1 week ago #2 by xillibit
Hello,

Is-it a clean install of Kunena 4.0.3 or an upgrade from a previous version ?

Can-you put here please a screenshot of your Kunena categories manager ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
3 years 1 week ago #3 by rob parker
It's a clean install, not an upgrade.

Here's my Category Manager ...

Attachments:

Please Log in or Create an account to join the conversation.

More
3 years 1 week ago #4 by 810
do you get the error, on the new topic tab, or by clicking new topic button, on the category view.

Please Log in or Create an account to join the conversation.

More
3 years 1 week ago #5 by rob parker
I get the error from the New Topic tab.

In the category view, there is no New Topic button; there is only the Subscribe button. Probably not surprising, since I'm not allowed to post.

Please Log in or Create an account to join the conversation.

More
3 years 1 week ago #6 by sozzled
I am sorry to hear that your original question was not answered for more than a week. I am also sorry that the developers have not been able to help you since you asked again for help a little over 25 hours ago.

Although I do not believe it is a good develop a website using a local host and you wrote earlier that you have read the various tutorials about how to install and create Kunena categories, I think I can help you.

I think I can help you fix your problem within a very short amount of time. The key to understanding the problem lies with the Kunena category permissions. When you you get the permissions right then you should not have problems creating new topics or replying to existing topics.

You are not alone with your problem; this is a very common problem for new users of Kunena. I am surprised that the members of the Kunena team who have replied to your question have not provided you with timely information. Perhaps the best place to start is to read Simple forum setup instructions . If this tutorial does not help you then I am prepared to work with you for as long as it takes to help you fix your problem.

Please Log in or Create an account to join the conversation.

More
3 years 1 week ago #7 by rob parker
Thanks for the offer to help me solve this. I've read - and re-read - the Simple forum setup instructions, and although I've worked out that the problem is with category permissions, I can't seem to get that right. My initial post in this thread gives details of what I've tried.

I'm out of time for anything more on this tonight, but I'll check again tomorrow and provide any more details you require. I'm also in Oz - Melbourne.

BTW, much appreciated your video on changing default Forum tab.

Please Log in or Create an account to join the conversation.

More
3 years 1 week ago #8 by sozzled

rob parker wrote: I'm also in Oz - Melbourne.

Even better; we can discuss your problems via telephone (or Skype) if you prefer. As you probably know, I provide a professional advisory service via my website; small charge (the cost of buying me a beer) but I think you'll agree it's worth it.

Please Log in or Create an account to join the conversation.

More
3 years 1 week ago #9 by rob parker
Sorry for delay in replying again - busy with other things yesterday, and about to be out for several hours now. Checked your website, and (finally - it took me a while to try the tiny "About" link in the footer) figured out how it works. I'll register there later today, and see how we go.

Please Log in or Create an account to join the conversation.

More
3 years 1 week ago #10 by sozzled
We can probably mark this particular topic as resolved, at least for the present.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.193 seconds