×

Notice

The forum is in read only mode.

×
We are going to change plans on our hosting. Little downtime until the change. (Yesterday)

The actual task of upgrading the server to the new base of operations will occur, starting around this evening until some hours. From this time the website will be unavailable and will remain inaccessible. And the topics are in read only modus, so you still can read your messages.

Thank you
Kunena Team

Solved Possible to downgrade from version 4 back to version 3.X

More
3 years 3 months ago - 3 years 3 months ago #1 by makotosun
I had been testing Kunena 4 on a test site and all seemed well. Now on my site install with 4 I have a compatibility issue I had overlooked. Is it possible to simply install the latest version 3.x over the 4 installation and migrate backwards?

Thanks in advance.
Last edit: 3 years 3 months ago by 810.
More
3 years 3 months ago #2 by Josh
Not that I know of. You could still continue to use the blue eagle template. Is it more than a display issue?
More
3 years 3 months ago #3 by makotosun
It is mainly not compatible with Tapatalk which a lot of my members are using. I completely forgot to test it - everything else is working fine - even aftermarket templates. My mistake so no finger pointing. :)
More
3 years 3 months ago #4 by Josh
Eventually you will probably want to upgrade to K4 anyways. So what I suggest is talking to the folks of Tapatalk and telling them that Kunena made a major upgrade.

And of course in the mean while if anyone knows how to downgrade, please voice up for those who are interested in this.
More
3 years 3 months ago #5 by 810
Normal downgrade isn't possible, but you can remove the k4.0.0 on the kunena_version table in your database.
More
3 years 3 months ago #6 by makotosun

810 wrote: Normal downgrade isn't possible, but you can remove the k4.0.0 on the kunena_version table in your database.


So if I make that change, the site will revert to the older version?

I will tyy that on my test server. Thanks!

I do want the upgrade, but Tapatalk is not there yet, and my users like having it.
More
3 years 3 months ago #7 by 810
you need to remove that row. Then you need to install k3.0.8 again.
The following user(s) said Thank You: Jacquesvw
More
3 years 3 months ago #8 by makotosun

810 wrote: Normal downgrade isn't possible, but you can remove the k4.0.0 on the kunena_version table in your database.

you need to remove that row. Then you need to install k3.0.8 again.



Thanks so much for the guidance. The above instructions worked perfectly and I am back to 3.0.8 until Tapatalk gets their plug in updated. A true lifesaver and I learned a bit more about under the hood!

Thanks again.
More
3 years 3 months ago #9 by Jacquesvw
I also installed Kunena 4 before checking that Tapatalk is compatible and can confirm that 810's advice worked and I could downgrade back to 3.0.8

Thanks 810
  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.087 seconds