×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× Topics must relate to a currently supported version of Kunena. If you are unsure what is the current supported version of Kunena, please go to the download page.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question Rendering Error in layout BBCode/twitter

More
3 months 1 week ago - 3 months 1 week ago #1 by Smirnov
Hello,
When I insert a tweet into a message on the forum using Twitter API, in the letter it looks like this:

Rendering Error in layout BBCode/twitter: Failed to start the session because headers have already been sent by "" at line 0.. Please enable debug mode for more information.



How to solve this problem, please tell me?
Thanks for your reply.
Attachments:
Last edit: 3 months 1 week ago by Smirnov.

Please Log in or Create an account to join the conversation.

More
3 months 5 days ago #2 by xillibit
Hello,

The issue is located in subscriptions mail, i think removing the twitter display in mail will solve the issue

I don't provide support by PM, because this can be useful for someone else.
The following user(s) said Thank You: Smirnov

Please Log in or Create an account to join the conversation.

More
3 months 5 days ago #3 by Smirnov

xillibit wrote: Hello,

The issue is located in subscriptions mail, i think removing the twitter display in mail will solve the issue


Hi.
May I hope that this will be solved in the next release kunena?
Thanks.

Please Log in or Create an account to join the conversation.

More
3 months 5 days ago #4 by xillibit
Yes, i will try to make a fix for Kunena 5.1.17

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
2 months 4 weeks ago - 2 months 4 weeks ago #5 by Smirnov
Great. Tweets via Twitter API is an excellent feature of Kunena forum. I am glad that this is implemented.

Invalid consumer key/secret in configuration

Unfortunately, obtaining access keys for Twitter API is difficult now.
If necessary, Xillibit, I can provide you with the keys for this work.
I’ve been working with Twitter API for a long time, it’s interesting for me ...
Last edit: 2 months 4 weeks ago by Smirnov.

Please Log in or Create an account to join the conversation.

More
2 months 4 weeks ago #6 by xillibit
Hello,

I have added a fix fo it in 5.1.17 developpement version : github.com/Kunena/Kunena-Forum/commit/4a...d89ec09695ac4fa4afe0

I haven't re-used twitter integration recently, you have created a Twitter developer account ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
2 months 4 weeks ago #7 by Smirnov
Hi,

xillibit wrote: I haven't re-used twitter integration recently, you have created a Twitter developer account ?


I've tried.
But I didn’t succeed.
The API Twitter moderator asked me why I need API access keys. I replied that I was experimenting with API. He asked me to show my code. I sent him a link to my github .
Immediately after that, I was denied access to API. :laugh:
I use old keys that I received a few years ago. They do not change.

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago - 2 months 3 weeks ago #8 by xillibit
Hello,

In my twitter developper account, i've created a new app in order to have access keys :



I think you can still use this way

I don't provide support by PM, because this can be useful for someone else.
Attachments:
Last edit: 2 months 3 weeks ago by xillibit.

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago - 2 months 3 weeks ago #9 by Smirnov

xillibit wrote: Hello,
In my twitter developper account, i've created a new app in order to have access keys :


Great.


// Display nothing in subscription mails
		if (!empty($bbcode->context))
		{
			return '';
		}

Why remove a twitter display from subscription mails? Why can't this be fixed? Thank you.
Last edit: 2 months 3 weeks ago by Smirnov.

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #10 by xillibit
I've done a quick fix, i need to look deeper if it can fixed

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.541 seconds