×
Kunena 5.2 Beta 1 Released (Today)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Topics must relate to a currently supported version of Kunena. If you are unsure what is the current supported version of Kunena, please go to the download page.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question Editor Buttons When Clicked Not Displaying Modal

More
1 year 4 months ago - 1 year 4 months ago #1 by cgwarder
In the BBCode Editor, when I click on the editor buttons such as the link button, that will open a modal, the modal will not open. Therefore, nothing happens and there is no error message in browser's web developer console. Is there any setting or plugin that I need to enable?

I tried adding the modal CSS - did not do anything. In the console, I am not getting the jquery error where there could be more than one jquery.

I switched to the WYSIWYG editor, the link button works. To change the editor, I went to the Kunena component->Template->Crypsis->BBCode tab->first field, editor - switch from BBCode to WYSIWYG. It says that if you switch to WYSIWYG, the BBCode plugins won't work. I don't use most integration plugins. Besides that, I am not sure what I would lose by using the WYSIWYG editor.

Here is my environment:
Joomla 3.9.3, PHP 7.3.2, Kunena 5.1.10.1, Crypsis template, Joomla template- JoomShaper Empire 1.7

My computer is on my company's intranet therefore I cannot provide you a URL for testing.
Last edit: 1 year 4 months ago by cgwarder. Reason: Found new info - Editor choice - BBCode or WYSIWYG

Please Log in or Create an account to join the conversation.

More
1 year 4 months ago #2 by rich
It's hard if you can not see the page. It can have many causes, e.g. a script conflict with your Joomla template or an extensions plugin. Also a css conflict is possible.
Try to test it with the Joomla default template Protostar.
Test also whether the modal in principle works with Kunena. Go in the backend to Kunena -> Templates -> Crypsis and choose the setting Type Quickreply = Modal, then try in the frontend an answer with the Quick Reply button. It should open a Modal.

I don't use most integration plugins. Besides that, I am not sure what I would lose by using the WYSIWYG editor.

I think, they are options which in an intranet are not important. Examples: Ebay, Tweet, Instagram and so on... but you can to enter this codes also manually, if you click in the Wysywig editor on the symbol BBCodes.
Smileys work if you enter the combinations of charakters manually.
Only polls are not possible without BBCode etitor.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.097 seconds