×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× Topics must relate to a currently supported version of Kunena. If you are unsure what is the current supported version of Kunena, please go to the download page.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question Editor Buttons When Clicked Not Displaying Modal

More
7 months 1 week ago - 7 months 1 week ago #1 by cgwarder
In the BBCode Editor, when I click on the editor buttons such as the link button, that will open a modal, the modal will not open. Therefore, nothing happens and there is no error message in browser's web developer console. Is there any setting or plugin that I need to enable?

I tried adding the modal CSS - did not do anything. In the console, I am not getting the jquery error where there could be more than one jquery.

I switched to the WYSIWYG editor, the link button works. To change the editor, I went to the Kunena component->Template->Crypsis->BBCode tab->first field, editor - switch from BBCode to WYSIWYG. It says that if you switch to WYSIWYG, the BBCode plugins won't work. I don't use most integration plugins. Besides that, I am not sure what I would lose by using the WYSIWYG editor.

Here is my environment:
Joomla 3.9.3, PHP 7.3.2, Kunena 5.1.10.1, Crypsis template, Joomla template- JoomShaper Empire 1.7

My computer is on my company's intranet therefore I cannot provide you a URL for testing.
Last edit: 7 months 1 week ago by cgwarder. Reason: Found new info - Editor choice - BBCode or WYSIWYG

Please Log in or Create an account to join the conversation.

More
7 months 1 week ago #2 by rich
It's hard if you can not see the page. It can have many causes, e.g. a script conflict with your Joomla template or an extensions plugin. Also a css conflict is possible.
Try to test it with the Joomla default template Protostar.
Test also whether the modal in principle works with Kunena. Go in the backend to Kunena -> Templates -> Crypsis and choose the setting Type Quickreply = Modal, then try in the frontend an answer with the Quick Reply button. It should open a Modal.

I don't use most integration plugins. Besides that, I am not sure what I would lose by using the WYSIWYG editor.

I think, they are options which in an intranet are not important. Examples: Ebay, Tweet, Instagram and so on... but you can to enter this codes also manually, if you click in the Wysywig editor on the symbol BBCodes.
Smileys work if you enter the combinations of charakters manually.
Only polls are not possible without BBCode etitor.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.111 seconds