×
Kunena 5.1.13 Released (21 Jul 2019)

The Kunena team has announce the arrival of Kunena 5.1.13 [K 5.1.13] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× Topics must relate to a currently supported version of Kunena. If you are unsure what is the current supported version of Kunena, please go to the download page.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question "index.php" appears in Kunena urls

More
4 months 3 weeks ago #1 by Oscar2
Hi all

I am seeing a lot of issues on my Google webmaster on duplicate URL's.

On frontend a url would look like this:
https://www.[URL].it/forum/aiutatemi/490-recupero-secco

But apparantly this URL also works and is not redirected:
https://www.[URL].it/index.php/forum/aiutatemi/490-recupero-secco

I am seeing all these urls with index.php in it on google webmaster, which is sending me warnings about a lot of duplicate urls being found.

Is this a setting I am missing? All urls on my site do not show this index.php?

Regards
Oscar


This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 300 seconds | Max execution memory: 128M | Max file upload: 128M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : bonsai | author: Spyros Petrakis | version: 1.1.2 | creationdate: 12/07/2017

Kunena default template details : Blue Eagle5 | author: Kunena Team | version: 1.5.2 | creationdate: 2018-12-11

Kunena template params:

Warning: Spoiler! [ Click to expand ]

Kunena version detailed: Kunena 5.1.8 | 2018-12-30 [ Janus ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: UddeIM 4.0

Third-party SEF components: None

Plugins: None

Modules: None

Please Log in or Create an account to join the conversation.

More
4 months 3 weeks ago #2 by rich
No idea if that cause the problem, but you have wrong routes in your menus. The menu item "Bonsai forum" in the kunena menus is aimless "view=home&defaultmenu=115"
The menu item with the ID 115 does not exists in your Kunena menu. Maybe therefore you've a redirect.
You have two menu items in the main menu which linked to the forum. But I can see only one of this menu item in the configuration report.
The menu item with the ID 123 is correct but I can't say if the second item is also correct.

Please read this docs:
docs.kunena.org/en/troubleshooting/menu-issues
docs.kunena.org/en/faq/kunena-menu

Please Log in or Create an account to join the conversation.

More
4 months 3 weeks ago - 4 months 3 weeks ago #3 by Slacker
Have you tried to disallow:
/index.php/ in robots.txt?
Last edit: 4 months 3 weeks ago by Slacker.

Please Log in or Create an account to join the conversation.

More
4 months 3 weeks ago - 4 months 3 weeks ago #4 by Oscar2
Hi guys!
Menu seems alright. I noticed the "index.php" links are only added in the breadcrumbs. If I disable the breadcrumbs in the template settings (paid Blue Eagle5) there are no links with index.php anymore.
So is it a template error? How can I fix it?

And blocking it in the robots.txt file seems a bit aggressive, is it not hurting any other page on my site?
Last edit: 4 months 3 weeks ago by Oscar2.

Please Log in or Create an account to join the conversation.

More
4 months 3 weeks ago #5 by rich

Menu seems alright. I noticed the "index.php" links are only added in the breadcrumbs. If I disable the breadcrumbs in the template settings (paid Blue Eagle5) there are no links with index.php anymore.

I think, it has nothing to do with Blue Eagle. You mean the menus seem alright? I say No! Have you not noticed if you click on "Indice", that this tab is not highlighted?

Btw: If you mean, it is a problem with Blue Eagle, you must create a own topic in the category for Blue Eagle. www.kunena.org/forum/blue-eagle-5
Problems with Blue Eagle are invariably discussed only in this category.

Please Log in or Create an account to join the conversation.

More
4 months 3 weeks ago - 4 months 3 weeks ago #6 by Slacker
The robots.txt is only instructions to Google Bot and other bots, how to search your site. The result of robots.txt only affects search results. There are certain things on the site that should be hidden for robots like files to hide from hackers.
Last edit: 4 months 3 weeks ago by Slacker.

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago #7 by Oscar2
Ah I changed the 'index' link in the menu because I want the main page to be /forum (and not /forum/index). Basically I dont want the /index page at all. Is that possible, without making problems like I do now? :)

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.111 seconds