×
Kunena 5.1.14 Released - Security release (13 Aug 2019)

The Kunena team is proud to announce the arrival of Kunena 5.1.14 [K5.1.14] which is now available for download as a native Joomla extension for Joomla 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.14. This update fixed 1 security issue.

× Topics must relate to a currently supported version of Kunena. If you are unsure what is the current supported version of Kunena, please go to the download page.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question Problem with entering of a link in BBCode Editor. (https - prefix - Problem)

More
6 months 4 weeks ago - 6 months 4 weeks ago #1 by lemur
Hi,

I have already been answered in the forum, that by entering a link in modal window the text of Link is not inserted correctly and it is a known Bug, which could not be fixed yet.
This is bad.

But there is an even more unpleasant problem.

When you enter an URL, the editor automatically prefixes it with "https://". (My Site use https).

As a result, in the case when you need no prefix at all or try to enter "http", the link becomes incorrect and does not work.
(Even in this posting I can't enter
h ttp ://  (without spaces)
!! It is immediately replaced by Submit to https://)

How to get rid of it?

Thanks.

This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 32M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : beez3_j39 | author: Angie Radtke | version: 3.1.0 | creationdate: 25 November 2009

Kunena default template details : Blue Eagle5 | author: Kunena Team | version: 1.5.2 | creationdate: 2018-12-11

Kunena template params:

Warning: Spoiler! [ Click to expand ]

Kunena version detailed: Kunena 5.1.9 | 2019-02-15 [ Kerberos ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: CommunityBuilder 2.4.0+build.2019.02.07.19.49.51.c86068090

Third-party SEF components: None

Plugins: Content - Kunena Discuss 5.1.1

Modules: Kunena Latest 5.1.1

Last edit: 6 months 4 weeks ago by lemur.

Please Log in or Create an account to join the conversation.

More
6 months 3 weeks ago #2 by rich

When you enter an URL, the editor automatically prefixes it with "https://".

I'm sorry, but I can't reproduce this issue.

Please Log in or Create an account to join the conversation.

More
6 months 6 days ago - 6 months 6 days ago #3 by lemur
I enter a link with http (not https).
F.e.,
httpXXX://r3.geschichte-chronologie.de
).
Three XXX in the examples before": "is just a place holder to avoid conversion. Under tested these 3 XXX need to leak.
[url=httpXXX://r3.geschichte-chronologie.de]httpXXX://r3.geschichte-chronologie.de[/url]

On Submit of the post this URL is converted to an address with https.

https://r3.geschichte-chronologie.de

This also happens in this forum.
Last edit: 6 months 6 days ago by lemur.

Please Log in or Create an account to join the conversation.

More
6 months 1 day ago #4 by rich
Excuse my late response. I've added it in our bug list.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.108 seconds