×
K5.1.1 is released (10 Jun 2018)

The Kunena team is pleased to announce Kunena 5.1.1 [K 5.1.1].
Please read the blog post for information:

× Topics must relate to a currently supported version of Kunena. If you are unsure what is the current supported version of Kunena, please go to the download page.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Solved (solved) Search not working in Kunena 5.0.12

More
5 months 2 weeks ago - 5 months 2 weeks ago #1 by pintobuck
Using Joomla 3.8.2, PHP 7.0.98, Kunena 5.0.12. JoomSEF

Problem: Kunena Search did not work. It kept saying that the search term could not be found, even when when I used a very common term that is all over my forum.

Solution: I found the solution in an archived post by Sozzled for Kunena 4.0. entitled " New Topic and Search Not Working ". Quoting Sozzled:

The problem is caused by the way that you have implemented SEF URLs and the way that your website re-routes the destination of the Search (and, possibly, New Topic) menu item(s).

That turned out to be the solution for me in Kunena 5.0.12. I'm using JoomSEF to create search engine friendly URLS. I deleted all the JoomSEF URLs containing "forum/search". Then, Kunena Search started working again. (Note that "forum/search" was specific to my site, and your site may use a different term in your Kunena Search URL.)
Last edit: 5 months 2 weeks ago by pintobuck.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.068 seconds