×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Topics must relate to a currently supported version of Kunena. If you are unsure what is the current supported version of Kunena, please go to the download page.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question emailed link of subscribed topic and Community Builder

More
3 years 1 month ago #1 by lappleget
Hi,
I have Community Builder installed with the latest (5.0.10 Kunena) everything is the latest version of

So this problem is discussed here www.kunena.org/forum/168-K-17-Support/70...in-page?limitstart=0

but that if for Kunena version 1.6

so when the person click the link in the email it takes them to the CB registration page. Where when they log in it does not take them back to the forum.

I think this is probably all now to do with settings. - access levels etc but I am at a loss.

Thank you for any insight

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 60M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : mpva_flex_1 | author: jh! design | version: 3.0.0 | creationdate: December 24, 2014

Kunena default template details : Blue Eagle5 | author: Kunena Team | version: 1.0.3 | creationdate: 2017-02-04

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 5.0.10 | 2017-06-30 [ Junco ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 2.1.3 | UddeIM 3.9

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 5.0.3 | Kunena Stats 5.0.3

Please Log in or Create an account to join the conversation.

More
3 years 1 month ago #2 by rich
The problem in your case, that the forum is only allowed for registered users. Therefore you get a redirect to the register (login) page. But the CB login has only 2 options where you going after login. Either you let the field "Login Redirection URL" empty, then you have no redirect, or you enter a login URL, then you going always to this site.

Solution
1. Remove the redirect to the login page
2. Copy the CB Login module
3. Place the copied Login module on all Kunena Pages
4. Let the field Login Redirection URL empty
5. Make this module only visible for guests (then it's invisible after login) Allowing Guest-Only Access to Menu Items and Modules

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.143 seconds