×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Topics must relate to a currently supported version of Kunena. If you are unsure what is the current supported version of Kunena, please go to the download page.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question Kunena on a multilingual page

More
3 years 11 months ago - 3 years 11 months ago #1 by Igor111
== Topic separated by rich. It has nothing to do with this question. www.kunena.org/forum/k5-0-support-archiv...why-is-it-empty-here ==

Thanks, it was so!
So I made the main menu item type "Menu item alias", and find Kunena menu item named "Forum" as that Alias.
Then I open Menus --> Kunena menu --> Forum and find "Default Menu Item * ", then choose there not Index, or Recent topics, but Forum.
So did I do everything right?

Also my aliaces (urls) have changed to latin (they where on russian UTF-8) before updates on new versions of kunena.
And my kunena menu on english part of site (I have 2 languages - ru and en) is on ru. How can I fix it?
Detailed:


RU version:
1. When I push Forum button on my site
2. It shows a-r-c-h.net/ru/forum URL
3. Where Kunena menu is on ru
4. There is some trouble with line break (in english version is ok)
5. And there is some trouble with ">" separator betwen first two points ( problem is present in en and ru versions )


EN version"
1. When I push Forum button here
2. It shows a-r-c-h.net/en/forum/index URL (in ru version was a-r-c-h.net/en/forum )
3. And Kunena menu is on Ru too, should be on En.

So, what to do to fix it?
Attachments:
Last edit: 3 years 11 months ago by rich. Reason: Topic separated

Please Log in or Create an account to join the conversation.

More
3 years 11 months ago - 2 years 1 month ago #2 by rich
Replied by rich on topic Kunena on a multilingual page

Then I open Menus --> Kunena menu --> Forum and find "Default Menu Item * ", then choose there not Index, or Recent topics, but Forum.
So did I do everything right?

No, should be Index or Recent Topics. With this option you to select the default “entry” page.

And my kunena menu on english part of site (I have 2 languages - ru and en) is on ru. How can I fix it?

You need a copy of complete Kunena menu for the second language. Is the same as with the other menus on your page. You will need for each language own menus with own names and assigned content ( see my test page ).







Last edit: 2 years 1 month ago by rich.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 1.433 seconds