×
Kunena 5.2.4 and Blue eagle 1.6.4 released (04 Apr 2021)

The Kunena team has announce the arrival of Kunena 5.2.4 [K 5.2.4] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.4

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with, this template isn't designed to works with Bootstrap 3 and Bootstrap 4.

× Les sujets sont déplacés dans ce domaine ne sont fermés parce qu'ils se rapportent à des versions non prises en charge de Kunena.

Question Image pour Indicateur de nouveaux messages

More
11 years 6 months ago #1 by lucarne
Bonjour,

Derrière ce titre à rallonge se cache une question concernant une modification que je souhaite faire sur mon forum.

L'idée est de remplacer le "Nouveau" par une petite image. J'ai donc essayé via le panneau d'admin de remplacer le champ texte par une image. J'ai donc inséré <img src="mon image"> dans le champ texte et lorsque je fais la modif, sur mon forum il voit bien qu'il doit afficher une image mais ne l'affiche pas. J'ai donc cherché dans tous les sens et je me suis aperçu, en retournant sur le panneau d'admin, que mon <img src="mon image"> a été remplacé mon chemin par <img src=\ ce qui, je pense explique cela.

Si je ne suis pas assez clair, voici une petite image.


Au gauche : le code que j'insère. Au centre la conséquence sur le fofo et à droite, le code tel qu'il l'a enregistré.

Dernière question : si jamais j'arrive à insérer l'image, quelqu'un peut-il me rappeler quel fichier je dois modifier pour enlever le chiffre apparaissant juste avant "Nouveau".

Merci pour votre aide en tout cas.

Please Log in or Create an account to join the conversation.

More
11 years 6 months ago #2 by xillibit
Bonjour,

pour effectuer ces modifications vous devez ouvrir le fichier components/com_kunena/template/default_ex/flat.php et à la modifier la ligne 261, voila ce que cela donnerai pour afficher une image à la place du nouveau :
echo CKunenaLink::GetThreadPageLink($fbConfig, 'view', $leaf->catid, $leaf->id, $unreadPage, $fbConfig->messages_per_page, '<sup><span class="newchar">&nbsp;' . "<img src=\"https://localhost/joomla_1.5.12_kunena_1.5.6/components/com_kunena/template/default_ex/images/english/emoticons/default.gif\" />" . '</span></sup>', $last_read[$leaf->id]->lastread);

L'url https://localhost/joomla_1.5.12_kunena_1.5.6/components/com_kunena/template/default_ex/images/english/emoticons/default.gif doit être changée par l'url de votre image.

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
11 years 5 months ago #3 by lucarne
bonjour,

désolé de répondre si tardivement (quelques soucis extérieurs à régler).

J'ai essayé ce bout de code et malheureusement ca n'a pas fonctionné. J'ai droit à une unexpected / in line 261....j'avoue que ca me dépasse quelque peu.

Please Log in or Create an account to join the conversation.

More
11 years 5 months ago - 11 years 5 months ago #4 by xillibit
Le problème vient du fait que la balise code met des espaces ou elle ne devrait pas. Je vous donne le fichier complet avec la modification d'effectuée, n'oubliez pas de modifier l'url de l'image à la ligne 261 https://localhost/joomla_1.5.12_kunena_1.5.6/components/com_kunena/template/default_ex/images/english/emoticons/default.gif

File Attachment:

File Name: flat.zip
File Size:5 KB

I don't provide support by PM, because this can be useful for someone else.
Attachments:
Last edit: 11 years 5 months ago by xillibit.

Please Log in or Create an account to join the conversation.

More
11 years 5 months ago #5 by lucarne
merci ca marche nickel !!

Par contre, y'aurait-il un autre fichier ou il faut insérer ce code car si cela marche sur l'affichage d'un sous forum, sur la page principale il y a toujours 1 Nouveau qui s'affiche (j'sais pas si ce que je dis est assez clair).

Please Log in or Create an account to join the conversation.

More
11 years 5 months ago #6 by xillibit
Essaie avec ce fichier, la modification a été faite à la ligne 378 :
echo '<sup><span class="newchar">&nbsp;' . "<img src=\"https://localhost/joomla_1.5.11_kunena_1.5.5/components/com_kunena/template/default_ex/images/english/emoticons/default.gif\" />" . "</span></sup>";

File Attachment:

File Name: listcat-20091104.zip
File Size:6 KB

I don't provide support by PM, because this can be useful for someone else.
Attachments:

Please Log in or Create an account to join the conversation.

More
11 years 5 months ago #7 by lucarne
merci beaucoup, le résultat et parfait ;)

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.062 seconds