×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Les sujets sont déplacés dans ce domaine ne sont fermés parce qu'ils se rapportent à des versions non prises en charge de Kunena.

Question K1.7 Probleme d'abonnements + traitement de masses des sujets + erreur sql

More
9 years 3 weeks ago - 9 years 3 weeks ago #1 by badabugs
Bonjour,

Je passe par la section Fr, je suis pas très doué en anglais ;)

depuis la maj vers Kunena 1.7, les abonnements ne fonctionnent plus... j'ai essayé tous les paramètres, je ne reçois aucun mail alors que les abonnements existent toujours ... Si je créais un sujet, l'abonnement est bien généré mais toujours pas de mail.

D'autre part, lorsque je supprime ou essaye des actions sur plusieurs sujets à la fois (comme suppresion ou désabonnements), j'obtiens une page blanche avec un zero en haut à gauche... Je suis obligé de supprimer les sujets un par un ...

Ensuite de façon aléatoire, j'ai le message suivant qui s'affiche tout en bas du forum (en répondant ou créant un sujet) :

500 - JDatabaseMySQL::query: 1062 - Duplicate entry 'eef13b68464b9210b12ed5523e233f27' for key 1 SQL=INSERT INTO `j16_session` (`session_id`, `data`, `time`) VALUES ('eef13b68464b9210b12ed5523e233f27', '__default|a:9:{s:15:\"session.counter\";i:56;s:19:\"session.timer.start\";i:1314790826;s:18:\"session.timer.last\";i:1314791469;s:17:\"session.timer.now\";i:1314791470;s:22:\"session.client.browser\";s:74:\"Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.1) Gecko/20100101 Firefox/6.0.1\";s:8:\"registry\";O:9:\"JRegistry\":1:{s:7:\"\0*\0data\";O:8:\"stdClass\":1:{s:10:\"com_kunena\";O:8:\"stdClass\":2:{s:8:\"redirect\";N;s:10:\"postfields\";N;}}}s:4:\"user\";O:5:\"JUser\":23:{s:9:\"\0*\0isRoot\";b:1;s:2:\"id\";s:2:\"98\";s:4:\"name\";s:8:\"badabugs\";s:8:\"username\";s:8:\"badabugs\";s:5:\"email\";s:16:\"[email protected]\";s:8:\"password\";s:65:\"3396e5fffea9aXXXXXXX945fa7041:F43Jahy8MViiUpXXXXXXXXJEbg2XU\";s:14:\"password_clear\";s:0:\"\";s:8:\"usertype\";s:19:\"Super Administrator\";s:5:\"block\";s:1:\"0\";s:9:\"sendEmail\";s:1:\"0\";s:12:\"registerDate\";s:19:\"2009-04-10 16:49:54\";s:13:\"lastvisitDate\";s:19:\"2011-08-31 11:02:01\";s:10:\"activation\";s:0:\"\";s:6:\"params\";s:102:\"{\"admin_language\":\"fr-FR\",\"language\":\"fr-FR\",\"editor\":\"\",\"helpsite\":\"\",\"timezone\":\"\",\"admin_style\":\"\"}\";s:6:\"groups\";a:1:{s:11:\"Super Users\";s:1:\"8\";}s:5:\"guest\";i:0;s:10:\"\0*\0_params\";O:9:\"JRegistry\":1:{s:7:\"\0*\0data\";O:8:\"stdClass\":6:{s:14:\"admin_language\";s:5:\"fr-FR\";s:8:\"language\";s:5:\"fr-FR\";s:6:\"editor\";s:0:\"\";s:8:\"helpsite\";s:0:\"\";s:8:\"timezone\";s:0:\"\";s:11:\"admin_style\";s:0:\"\";}}s:14:\"\0*\0_authGroups\";a:2:{i:0;i:1;i:1;i:8;}s:14:\"\0*\0_authLevels\";a:4:{i:0;i:1;i:1;i:1;i:2;i:2;i:3;i:3;}s:15:\"\0*\0_authActions\";N;s:12:\"\0*\0_errorMsg\";N;s:10:\"\0*\0_errors\";a:0:{}s:3:\"aid\";i:0;}s:13:\"session.token\";s:32:\"6eb14c1b2e7a183192e13d4256e0736f\";s:16:\"com_mailto.links\";a:1:{s:40:\"32acc952c30bc4fbdf037d87321bc795293a05cc\";O:8:\"stdClass\":2:{s:4:\"link\";s:54:\" www.badakla.net/news/bf3-news/83-pas-de-...xpiry\";i:1314791349 ;}}}', 1314791471)



This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 120 seconds | Max execution memory: 128M | Max file upload: 64M

This message contains confidential information

Joomla default template details : rt_tachyon_j16 | author: RocketTheme, LLC | version: 1.6.2 | creationdate: April 21, 2011

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.0 | creationdate: 2011-08-29

Kunena version detailled: Installed version: 1.7.0 | Build: 5135 | Version name: Tale | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: Jomsocial 2.2.4

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled | Kunena Discuss 1.7.0 | My Kunena Forum Menu 1.7.0 | Kunena Groups 1.7.0

Modules: Kunena Latest 1.7.0

Last edit: 9 years 3 weeks ago by badabugs.

Please Log in or Create an account to join the conversation.

More
9 years 3 weeks ago #2 by badabugs
Les abonnements refonctionnent, le cache des sessions semble etre en cause, un ami recevait les mails alors que moi pas ... Et d'un coup, je me suis mis à les recevoir ...

J'imagine que le message d'erreur qui s'affichait de maniere aléatoire est lié lui aussi.

il ne reste que le traitement de masse des sujets et sa page blanche avec le zero en haut à gauche ...

Please Log in or Create an account to join the conversation.

More
9 years 3 weeks ago #3 by xillibit

badabugs wrote: D'autre part, lorsque je supprime ou essaye des actions sur plusieurs sujets à la fois (comme suppresion ou désabonnements), j'obtiens une page blanche avec un zero en haut à gauche... Je suis obligé de supprimer les sujets un par un ...

Tu peux activer le debug mode dans le panneau de configuration de Joomla! et Kunena pour voir ce qui se passe ? Tu peux aussi regarder dans ton log d'erreur de php/apache .

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
9 years 3 weeks ago - 9 years 3 weeks ago #4 by badabugs
Bonsoir et merci pour ton aide,

Où est-ce que je trouve le log d'erreur php/apache ?

J'ai un fichier error.php dans log mais rien à l'intérieur de croustillant, juste les connexions ... Quant au mode debug, une fois activé , j'ai eu tout de suite le message d'erreur indiqué ci-dessus :

500 - JDatabaseMySQL::query: 1062 - Duplicate entry 'eef13b68464b9210b12ed5523e233f27' for key 1 SQL=INSERT INTO `j16_session` (`session_id`, `data`, `time`) VALUES ('eef13b68464b9210b12ed5523e233f27', '__default|a:9:{s:15:\"session.counter\";i:56;s:19:\"session.timer.start\";i:1314790826;s:18:\"session.timer.last\";i:1314791469;s:17:\"session.timer.now\";i:1314791470;s:22:\"session.client.browser\";s:74:\"Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.1) Gecko/20100101 Firefox/6.0.1\";s:8:\"registry\";O:9:\"JRegistry\":1:{s:7:\"\0*\0data\";O:8:\"stdClass\":1:{s:10:\"com_kunena\";O:8:\"stdClass\":2:{s:8:\"redirect\";N;s:10:\"postfields\";N;}}}s:4:\"user\";O:5:\"JUser\":23:{s:9:\"\0*\0isRoot\";b:1;s:2:\"id\";s:2:\"98\";s:4:\"name\";s:8:\"badabugs\";s:8:\"username\";s:8:\"badabugs\";s:5:\"email\";s:16:\" [email protected]\";s:8:\"password\";s:65:\"3396e5fffea9aXXXXXXX945fa7041:F43Jahy8MViiUpXXXXXXXXJEbg2XU\";s:14:\"password_clear\";s:0:\"\";s:8:\"usertype\";s:19:\"Super Administrator\";s:5:\"block\";s:1:\"0\";s:9:\"sendEmail\";s:1:\"0\";s:12:\"registerDate\";s:19:\"2009-04-10 16:49:54\";s:13:\"lastvisitDate\";s:19:\"2011-08-31 11:02:01\";s:10:\"activation\";s:0:\"\";s:6:\"params\";s:102:\"{\"admin_language\":\"fr-FR\",\"language\":\"fr-FR\",\"editor\":\"\",\"helpsite\":\"\",\"timezone\":\"\",\"admin_style\":\"\"}\";s:6:\"groups\";a:1:{s:11:\"Super Users\";s:1:\"8\";}s:5:\"guest\";i:0;s:10:\"\0*\0_params\";O:9:\"JRegistry\":1:{s:7:\"\0*\0data\";O:8:\"stdClass\":6:{s:14:\"admin_language\";s:5:\"fr-FR\";s:8:\"language\";s:5:\"fr-FR\";s:6:\"editor\";s:0:\"\";s:8:\"helpsite\";s:0:\"\";s:8:\"timezone\";s:0:\"\";s:11:\"admin_style\";s:0:\"\";}}s:14:\"\0*\0_authGroups\";a:2:{i:0;i:1;i:1;i:8;}s:14:\"\0*\0_authLevels\";a:4:{i:0;i:1;i:1;i:1;i:2;i:2;i:3;i:3;}s:15:\"\0*\0_authActions\";N;s:12:\"\0*\0_errorMsg\";N;s:10:\"\0*\0_errors\";a:0:{}s:3:\"aid\";i:0;}s:13:\"session.token\";s:32:\"6eb14c1b2e7a183192e13d4256e0736f\";s:16:\"com_mailto.links\";a:1:{s:40:\"32acc952c30bc4fbdf037d87321bc795293a05cc\";O:8:\"stdClass\":2:{s:4:\"link\";s:54:\" www.badakla.net/news/bf3-news/83-pas-de-...";i:1314791349 ;}}}', 1314791471)


Bon je viens de tester avec le mod debug , resultat des courses rien d'afficher ... je selectionne tous mes posts à effacer, je selectionne supprimer definitivement , je clique sur aller et là j'atteris sur une page blanche avec un zero tout en haut à gauche rien d'autre. Par contre, j'ai noté qu'en retournant sur la page initiale en modifiant s la barre d'adresse, les postes sont bien supprimés...
Last edit: 9 years 3 weeks ago by badabugs.

Please Log in or Create an account to join the conversation.

More
9 years 3 weeks ago #5 by badabugs
bon le probleme de page de blanche est resolu à son tour :

J'ai upgradé ma version de php et ça fonctionne. (j'etais sous 5.2.16 et maintenant 5.3.8)

;)

Plus qu'un soucis avec kdiscuss à résoudre ...

Merci pour ton aide.

@ bientot

Please Log in or Create an account to join the conversation.

More
9 years 3 weeks ago #6 by xillibit
C'est quoi ton souci avec kdicuss ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
9 years 3 weeks ago #7 by badabugs
le probleme est traité dans la section KD.

Quand j'active l'activity stream sur joomla, et que je poste, j'ai une erreur 500 et quand je vais sur le forum, il y a 120 sujets créé dans le forum (sans la réponse que j'ai faite). En changeant la version de php, j'en ai plus de 900 maintenant ... :whistle:

Bref, le seul moyen que ça fonctionne, c'est de désactiver l'activity stream. Pour le moment ça me va, mais je garde un oeil sur le forum ;)

J'espere que vous trouverez la solution.

Apparemment un mec , a le soucis aussi, le truc etrange , c'est que ça lui fait pas en local, juste sur le site en production. De mon coté, j'ai pas essayé en local ... à voir.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.104 seconds