×
Kunena 5.1.16 Released (18 Mar 2020)

The Kunena team has announce the arrival of Kunena 5.1.16 [K 5.1.16] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved Pagination is wrong for registered users when there are deleted messages in a topic

More
7 years 4 months ago - 7 years 4 months ago #1 by cipt2001
I believe I have a problem that is related to Global Moderators Can See Deleted Topics and possibly to Deleting "n" posts breaks pagination control .

I am using Kunena 2.0.3 (but the issue was also with 2.0.2) on Joomla 2.5.8. I have the "Show Deleted Messages" set to "Administrators only", this might be important.

As an Admin I see all the messages and the pagination is OK (in this case I have 10 pages including deleted messages).




As a Moderator I don't see the deleted messages and I see only 9 pages (this is OK).




But as a normal user I see an empty page 10, because I am not able to see the deleted messages but I believe they are still counted somehow.




Did anybody saw this problem? Am I doing something wrong?
Attachments:
Last edit: 7 years 4 months ago by cipt2001.

Please Log in or Create an account to join the conversation.

More
7 years 4 months ago #2 by skybax
Try and go to Kunena Forum >> Forum Tools >> Recount Statistics and see if this helps.

Please Log in or Create an account to join the conversation.

More
7 years 4 months ago #3 by cipt2001
Yes, that fixed the problem, thank you! The question is now if this is needed every time after you delete messages from topics or is it just a one time thing?

Please Log in or Create an account to join the conversation.

More
7 years 4 months ago - 7 years 4 months ago #4 by skybax

cipt2001 wrote: Yes, that fixed the problem, thank you! The question is now if this is needed every time after you delete messages from topics or is it just a one time thing?


No that was a bug in 2.0.2 and was fix in 2.0.3 and the Recount was needed to get it back to date.
Last edit: 7 years 4 months ago by skybax.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 1.119 seconds