×
Kunena 5.2.2 released (13 Jan 2021)

The Kunena team has announce the arrival of Kunena 5.2.2 [K 5.2.2] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.2

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Merged Broken link in the subscription e-mail from Forum and wrong #id

More
8 years 5 months ago - 8 years 5 months ago #1 by MarioMari
Hi!
In the subscription, I get a link to the new message with wrong one symbol:

URL : {full url}/topicname/140
It is always displayed first post in the topic. Wrong.

Should have the end to display the right message in the browser must be:
URL : {full url}/topicname#140

Can I fix it manually?
Regards!

Joomla 2.5.8, and 3.0 K.2.0.3, default Chrome
Last edit: 8 years 5 months ago by MarioMari.

Please Log in or Create an account to join the conversation.

More
8 years 5 months ago - 8 years 5 months ago #2 by GoremanX
When you click on the link, Kunena should automatically change /140 to ?start=15#140 (start= will be different depending on which page the post appears on). This works as expected on all the Kunena installations I have, Can you provide your configuration report? Maybe there's something there that will explain why this conversion isn't happening for you.

THE place to discuss photography!
www.friendlyphotozone.com
Last edit: 8 years 5 months ago by GoremanX.

Please Log in or Create an account to join the conversation.

More
8 years 5 months ago - 8 years 5 months ago #3 by MarioMari
You're right, but in practice it works differently.

Regards!

This message contains confidential information


This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 192M | Max file upload: 64M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : rt_camber | author: RocketTheme, LLC | version: 1.4 | creationdate: April 19, 2012

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 2.0.1 | creationdate: 2012-07-07

Kunena version detailed: Kunena 2.0.1 | 2012-07-07 [ Balozi ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None


Joomla 2.5.8, and 3.0 K.2.0.3, default Chrome
Last edit: 8 years 5 months ago by MarioMari.

Please Log in or Create an account to join the conversation.

More
8 years 5 months ago - 8 years 5 months ago #4 by MarioMari
And one more observation.

{ ATTENTION1
This problem is depends on which browser I visit the forum.}

The differences can be seen even without changing your browser. Just change the ID, eg client of this extension:
chrome.google.com/webstore/detail/djflho...khhcedjiklpkjnoahfmg

The url got mail from subscription Kunena forum:
URL 1. www.kunena.org/forum/77-General-Talk-abo...low-HTML-tags/130136

And here is the same link but with improved character "/" to "#".
Click and compare results.

URL 2. www.kunena.org/forum/77-General-Talk-abo...low-HTML-tags#130136


{ ATTENTION2
Action links change when the user logs on. When is offline links work exactly the opposite.
After logging in to this show a bad view now displays the good, and the one show you a good view of the log shows bad.


  • Logoff | logon
    Firefox
    First link - OK | OK
    Second link - Wrong | Wrong

    Chrome
    First link - OK | WRONG
    Second link - Wrong | OK

    Safari
    First link - OK | Wrong
    Second link - Wrong | OK


  • I think this is not the fault of my setup just the symbol in the url to the message.
    Please right click on the number of messages and copy the URL. See how it looks. This address works well.

    regards!

    Joomla 2.5.8, and 3.0 K.2.0.3, default Chrome
    Attachments:
    Last edit: 8 years 5 months ago by MarioMari.

    Please Log in or Create an account to join the conversation.

    More
    8 years 5 months ago - 8 years 5 months ago #5 by MarioMari
    I want to emphasize once again. In order to prevent confusion.

    All the time I write about the operation of Kunena forum. Not mine.
    My fault, in my installation are the same, you can try to take care of them when no longer be a fault on the Foum.

    In this forum, I have these settings:



    Apart from this problem with the link, I've got such attention to action.
    1. URL links behave differently when I'm offline.
    2. in long threads numbering is mistaken:












    3. When I create a new message, the link is that we get for subscribing to e-mail subject. This address, as I wrote as a result of the error displays.






    4. It is interesting that when you copy the link from there to the forum




    and This link works very well in any browser.
    How can I make to my forum sends this link to subscribe on the news?






    5. After logging in with the above settings profile "firts last post" changes the numbering of the first post, no longer exists and the rest of the successive posts renumbers.



    after login


    6. I do not know why using Chrome also change the key action "add file". My favorite and quick idea to include links to the file by dragging the mouse from the desktop file on the "Add file" - this will automatically add a link. These cases have in common is that now, in the browser where the link is functioning correctly described, this method also works to add a link. Yesterday in this button Chrome yet acted.
    I also confused and this is just a case of multiple overlapping circumstances.




    7. Chrome. When I am logged on.
    * Clicking on the icon theme to display the last entry - OK.
    * When the last post in the topic is my post, clicking on the icon to display the first entry?




    Best Regards!

    Joomla 2.5.8, and 3.0 K.2.0.3, default Chrome
    Last edit: 8 years 5 months ago by MarioMari.

    Please Log in or Create an account to join the conversation.

    More
    8 years 5 months ago #6 by MarioMari
    I described all observed situations.
    I admit that I feel a bit like the Matrix. Can anyone confirm this behavior to me, because, I do not know if I do not lose my senses ... ;}

    Joomla 2.5.8, and 3.0 K.2.0.3, default Chrome

    Please Log in or Create an account to join the conversation.

    More
    8 years 5 months ago - 8 years 5 months ago #7 by MarioMari
    Please give me information on where to change the character?

    Regards!

    Joomla 2.5.8, and 3.0 K.2.0.3, default Chrome
    Last edit: 8 years 5 months ago by MarioMari.

    Please Log in or Create an account to join the conversation.

    More
    8 years 5 months ago - 8 years 5 months ago #8 by MarioMari
    There is a chance for this problem?

    Joomla 2.5.8, and 3.0 K.2.0.3, default Chrome
    Last edit: 8 years 5 months ago by MarioMari.

    Please Log in or Create an account to join the conversation.

    More
    8 years 5 months ago - 8 years 5 months ago #9 by MarioMari
    I'm sorry, as I understand this lack of response? I wrote something offensive?

    Joomla 2.5.8, and 3.0 K.2.0.3, default Chrome
    Last edit: 8 years 5 months ago by MarioMari.

    Please Log in or Create an account to join the conversation.

    More
    8 years 5 months ago #10 by MarioMari
    In my site.
    The topic of multiple pages of posts after editing the post or add new replies to your post, after saving the post will reload the view to view the first post. — Is it good? It's better when you refresh the page to preview post last edited.

    Joomla 2.5.8, and 3.0 K.2.0.3, default Chrome

    Please Log in or Create an account to join the conversation.

    • Not Allowed: to create new topic.
    • Not Allowed: to reply.
    • Not Allowed: to edit your message.
    Time to create page: 3.678 seconds