×
Blue Eagle 5 v1.5.4 has been Released (13 Sep 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.4 which is now available for download. This version addresses most of the issues that were discovered in development.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved K Latest missing advanced options

More
8 years 1 month ago - 8 years 1 month ago #1 by Djie
The upgrade from K1.7 to K2.0.1 went smooth, but after uninstalling the K latest module and install the newest version of the module the advanced paramters section does not appear. In most modules there is a advanced options/paramaters available to set, for example, the cache setting for the module.

These options are not available under the basic options but should be available under an advanced paramaters sections. Or is this options cancelled in the new K latest module?

Last edit: 8 years 1 month ago by Djie.

Please Log in or Create an account to join the conversation.

More
8 years 1 month ago #2 by TKtemp

Or is this options cancelled in the new K latest module?


Yes, this options are cancelled in the new version.

Please Log in or Create an account to join the conversation.

More
8 years 1 month ago #3 by Djie

TKtemp wrote:

Or is this options cancelled in the new K latest module?


Yes, this options are cancelled in the new version.


How is it possible to (de)activate the caching option for this individual module if the advanced options are cancelled?

Please Log in or Create an account to join the conversation.

More
8 years 1 month ago #4 by sozzled
Perhaps the module caching is controlled via your site's global cache? This is an interesting situation that you describe. Perhaps one of the members of the development team may be able to explain what you need to do? :S

I would try to resolve by uninstalling Kunena Latest 2.0.1 and install it again. Alternatively, I would disable global caching. When you really think about it, caching a website where you're continually updating pages is counter-productive, anyway, isn't it?

Please Log in or Create an account to join the conversation.

More
8 years 1 month ago #5 by Djie

sozzled wrote: Perhaps the module caching is controlled via your site's global cache? This is an interesting situation that you describe. Perhaps one of the members of the development team may be able to explain what you need to do? :S

I would try to resolve by uninstalling Kunena Latest 2.0.1 and install it again. Alternatively, I would disable global caching. When you really think about it, caching a website where you're continually updating pages is counter-productive, anyway, isn't it?


The module is not controlled with the global cache setting from Joomla. The globals setting is set to 15minutes, the module refreshes its content every ~2hours. Will try a uninstall/install.

Never tested it but I think caching is valuable option to gain performance. Should try without it and see if requests/page loads will take longer. But the source of the problem isnt fixed with this bypass :)

Please Log in or Create an account to join the conversation.

More
8 years 1 month ago #6 by sozzled

Djie wrote: Never tested it but I think caching is valuable option to gain performance.

There are two kinds of caching. There's caching of content (which is what we're discussing here) and, if the content is continually changing - as it always will change in a web-based discussion forum context - content caching is worthless in my view. The other kind of caching is database query caching (when you save the results of a recent query and re-use those results elsewhere); this kind of caching is very useful in a web-based discussion forum context. K 2.0 implements database query caching.

Are you using any other caching (e.g. advanced PHP caching [ACP])? Something has to explain why there's a 2-hour lag between when a message is posted and when Kunena Latest "detects" it.

Please Log in or Create an account to join the conversation.

More
8 years 1 month ago #7 by TKtemp
Looks like that caching of this module is controlled by Kunena.
Have you tried to disable it in Kunena configuration? (General Tab)
Or change Cache Time to 1 minute?

Please Log in or Create an account to join the conversation.

More
8 years 1 month ago - 8 years 1 month ago #8 by Djie

TKtemp wrote: Looks like that caching of this module is controlled by Kunena.
Have you tried to disable it in Kunena configuration? (General Tab)
Or change Cache Time to 1 minute?


Didn't knew Kunena had this caching option :)
Caching in the Kunena General control panel was on and was set to 1minute, this caused the module to update every ~2hours. Maybe this has something to do with my server configuration??

I did turn off the caching option from the Kunena General setting and the problem is now fixed! The module isn't cached anymore. I experience a slight performance degree in Kunena server response time now that caching is turned off. om 0,8xx sec to 1.2xx sec to load the recent discussion thread.

Still the core of the problem is not found but I should look at my server/php configuration to figure out why the latest module is cached for 2hours instead of 1minute.....
Last edit: 8 years 1 month ago by Djie.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.124 seconds