×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× This category is for the plugin developed, endorsed, maintained and supported by the Kunena project team. The topics in this category only relate to the plugin developed for K 2.0.

[ If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question Kunena Discuss shows too much or not at all

More
6 years 11 months ago #1 by kankaanp
I'm doing a migration from 1.5 to 2.5 on site. Specifics can be found in this thread:
www.kunena.org/forum/K-2-0-Kunena-Discus...l-php-error-messages
Now I've a new problem. I've set the Kunena Discuss to display a link on the frontpage and blogs and messages on articles. If I set the quick-post form on I get it on frontpage, blogs and messages. If I set it off I don't get any sign of Kunena Discuss on any of the views. Only on some migrated articles that have the custom code in them do I get the desired and set effect. Any ideas why?

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago #2 by sozzled
Would it be possible for you to provide us with

(1) Your Kunena configuration report; and
(2) A screenshot of your Kunena Discuss plugin settings?

Background reading: see Kunena Discuss "quick and dirty" instructions for use

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago #3 by kankaanp
1) Here it is again (see link in the first post):
This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 60 seconds | Max execution memory: 192M | Max file upload: 32M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : zt_kru | author: ZooTemplate.com | version: 2.5.7 | creationdate: February 19, 2013

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.1 | creationdate: 2011-11-16

Kunena version detailed: Kunena 2.0.4 | 2013-01-18 [ Pharmacopoeia ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: Search - Kunena Search 2.0.4 | Content - Kunena Discuss 2.0.4

Modules: Kunena Latest 2.0.4


2) Attached

Attachments:

Please Log in or Create an account to join the conversation.

More
6 years 11 months ago #4 by kankaanp
Further information:

The site was migrated to a subfolder "uusi" and has now been deployed to site root again.

Kunena Discuss Debug on on frontpage:

[KunenaDiscuss debug: Constructor called in com_content ]
[KunenaDiscuss debug: onPrepareContent.Allow: Category 145 was listed in allow list and is using default Kunena category 5 ]
[KunenaDiscuss debug: onPrepareContent: we are in front page. ]
[KunenaDiscuss debug: onPrepareContent: Article 580 ]
[KunenaDiscuss debug: onPrepareContent: Searched for {kunena_discuss:#}: Custom Topic not found. ]
[KunenaDiscuss debug: showPlugin: No topic found ]
[KunenaDiscuss debug: showPlugin: Let's see what we can do.. ]
[KunenaDiscuss debug: showTopic: No messages to render ]
[KunenaDiscuss debug: onAfterDisplayContent: Returning content for article 580 ]
[KunenaDiscuss debug: onPrepareContent.Allow: Category 52 was listed in allow list and is using default Kunena category 5 ]
[KunenaDiscuss debug: onPrepareContent: we are in front page. ]
[KunenaDiscuss debug: onPrepareContent: Article 573 ]
[KunenaDiscuss debug: onPrepareContent: Searched for {kunena_discuss:#}: Custom Topic not found. ]
[KunenaDiscuss debug: showPlugin: No topic found ]
[KunenaDiscuss debug: showPlugin: Let's see what we can do.. ]
[KunenaDiscuss debug: showTopic: No messages to render ]
[KunenaDiscuss debug: onAfterDisplayContent: Returning content for article 573 ]


Kunena Discuss Debug on a blog view:

[KunenaDiscuss debug: Constructor called in com_content ]
[KunenaDiscuss debug: onPrepareContent.Allow: Category 52 was listed in allow list and is using default Kunena category 5 ]
[KunenaDiscuss debug: onPrepareContent: we are in blog page. ]
[KunenaDiscuss debug: onPrepareContent: Article 573 ]
[KunenaDiscuss debug: onPrepareContent: Searched for {kunena_discuss:#}: Custom Topic not found. ]
[KunenaDiscuss debug: showPlugin: No topic found ]
[KunenaDiscuss debug: showPlugin: Let's see what we can do.. ]
[KunenaDiscuss debug: showTopic: No messages to render ]
[KunenaDiscuss debug: onAfterDisplayContent: Returning content for article 573 ]
[KunenaDiscuss debug: onPrepareContent: Article not published ]
[KunenaDiscuss debug: onPrepareContent.Allow: Category 112 was listed in allow list and is using default Kunena category 5 ]
[KunenaDiscuss debug: onPrepareContent: we are in blog page. ]
[KunenaDiscuss debug: onPrepareContent: Article 555 ]
[KunenaDiscuss debug: onPrepareContent: Searched for {kunena_discuss:#}: Custom Topic not found. ]
[KunenaDiscuss debug: showPlugin: No topic found ]
[KunenaDiscuss debug: showPlugin: Let's see what we can do.. ]
[KunenaDiscuss debug: showTopic: No messages to render ]
[KunenaDiscuss debug: onAfterDisplayContent: Returning content for article 555 ]
[KunenaDiscuss debug: onPrepareContent.Allow: Category 112 was listed in allow list and is using default Kunena category 5 ]
[KunenaDiscuss debug: onPrepareContent: we are in blog page. ]
[KunenaDiscuss debug: onPrepareContent: Article 554 ]
[KunenaDiscuss debug: onPrepareContent: Searched for {kunena_discuss:#}: Custom Topic not found. ]
[KunenaDiscuss debug: showPlugin: No topic found ]
[KunenaDiscuss debug: showPlugin: Let's see what we can do.. ]
[KunenaDiscuss debug: showTopic: No messages to render ]
[KunenaDiscuss debug: onAfterDisplayContent: Returning content for article 554 ]
[KunenaDiscuss debug: onPrepareContent: Article not published ]
[KunenaDiscuss debug: onPrepareContent: Article not published ]
[KunenaDiscuss debug: onPrepareContent: Article not published ]
[KunenaDiscuss debug: onPrepareContent: Article not published ]
[KunenaDiscuss debug: onPrepareContent: Article not published ]
[KunenaDiscuss debug: onPrepareContent: Article not published ]

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.202 seconds