×
Kunena 5.1 Released (13 May 2018)

The Kunena team is pleased to announce Kunena 5.1.0 [K 5.1.0].
Please read the blog post for information: www.kunena.org/blog/192-kunena-5-1-released

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Question Cannot create discussion in Forum Category: You do not have permission

More
5 years 10 months ago - 5 years 8 months ago #1 by trechriron
I am getting an error when trying to create topic as user in forum for article.

Debug:
[KunenaDiscuss debug: Constructor called in com_content ]
[KunenaDiscuss debug: onPrepareContent.Allow: Category 13 is in the category map using Kunena category 2 ]
[KunenaDiscuss debug: onPrepareContent: we are in article/ page. ]
[KunenaDiscuss debug: onPrepareContent: Article 6 ]
[KunenaDiscuss debug: onPrepareContent: Searched for {kunena_discuss:#}: Custom Topic not found. ]
[KunenaDiscuss debug: showPlugin: No topic found ]
[KunenaDiscuss debug: showPlugin: Let's see what we can do.. ]
[KunenaDiscuss debug: showPlugin: Category 2 said You do not have permissions to access this page. ]
[KunenaDiscuss debug: onAfterDisplayContent: Returning content for article 6 ]

Plugin Setup:




Kunena Setup:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 45 seconds | Max execution memory: 96M | Max file upload: 24M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : rt_tachyon | author: RocketTheme, LLC | version: 1.6.7 | creationdate: April 19, 2012

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 2.0.1 | creationdate: 2012-07-07

Kunena version detailed: Kunena 2.0.1 | 2012-07-07 [ Balozi ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: Jomsocial 2.6.2

Third-party SEF components: None

Plugins: Content - Kunena Discuss 2.0.1 | JomSocial - My Kunena Forum Menu 2.0.1 | JomSocial - My Kunena Forum Posts 2.0.1 | JomSocial - Kunena Groups 2.0.1

Modules: Kunena Latest 2.0.1 | Kunena Stats 2.0.1 | Kunena Login 2.0.1 | Kunena Search 2.0.1

Last edit: 5 years 8 months ago by sozzled. Reason: "un-spoiler" configuration report

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #2 by trechriron
Anyone have any ideas why the Discussion plug in is not working? Your help would be appreciated!

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #3 by Jiminimonka
Please post your configuration report as this will assist with finding out the cause of the problem.

Please read the FAQ.
Only one question per topic.
Search before you ask a question.

Please Log in or Create an account to join the conversation.

More
5 years 9 months ago #4 by trechriron
They are in the first post! :-D Under the spoilers.

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago - 5 years 8 months ago #5 by Ratman
I have exactly the same problem. I re-installed the plugin, double-checked configuration, double-checked if the "kunena_discuss:#" is correct, but nothing helps. Debug Info from the plugin keeps saying, that I don´t have permission. But I can access the post and the category

Edit: The discuss plugin only works if I enter a "default category" in the plugin parameters. But that is not what I want. I only want custom topics, no automatically created topics, no category mapping.
Last edit: 5 years 8 months ago by Ratman.

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago - 5 years 8 months ago #6 by sozzled
I do not know if the Kunena Discuss plugin works without defining a default category. I haven't tested it that way. I only know what I have written in Kunena Discuss "quick and dirty" instructions for use .

Have you checked the Permissions tab in the category/categories that you "do not have permission" to create a topic?
Last edit: 5 years 8 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #7 by Ratman

sozzled wrote: I do not know if the Kunena Discuss plugin works without defining a default category. I haven't tested it that way....

.
Well, it did work with older versions of the plugin, but I´m not quite sure what version did start do misbehave.

sozzled wrote: Have you checked the Permissions tab in the category/categories that you "do not have permission" to create a topic?

Yep, I did. Guests are allowed to read, Registered Users are allowed to post and reply. And I´m SuperAdmin :)

And if it would be a permission problem: Why does it work when I set a default category?. As I said before: I did not touch the categories and the permissions for a long time, and it worked with an older version of the plugin.

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago - 5 years 8 months ago #8 by sozzled
Ratman: Please read What information should I include when I ask for help (including how to post my configuration report)?

trechriron: It was not immediately obvious to me, either, that you had posted your configuration report. Please upgrade to latest versions of Kunena software
Last edit: 5 years 8 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #9 by Ratman

sozzled wrote: Ratman: Please read What information should I include when I ask for help (including how to post my configuration report)?


Yes, of course:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Enabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Enabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 60 seconds | Max execution memory: 128M | Max file upload: 2000M

Kunena menu details:

Warning: Spoiler! [ Click to expand ]

Joomla default template details : nld_047_1.5 | author: Kub | version: 1.0 | creationdate: 11/05/09

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 2.0.2 | creationdate: 2012-09-02

Kunena version detailed: Kunena 2.0.2 | 2012-09-02 [ Botschafter ]
| Kunena detailed configuration:

Warning: Spoiler! [ Click to expand ]
| Kunena integration settings:
Warning: Spoiler! [ Click to expand ]
| Joomla! detailed language files installed:
Warning: Spoiler! [ Click to expand ]

Third-party components: CommunityBuilder 1.8.1 | UddeIM 2.8

Third-party SEF components: None

Plugins: Content - Kunena Discuss 2.0.2

Modules: Kunena Latest 2.0.2 | Kunena Stats 2.0.2 | Kunena Search 2.0.2

Please Log in or Create an account to join the conversation.

More
5 years 8 months ago #10 by sozzled
Please read the important information regarding the use of J! 1.5 legacy mode . Joomla does not support the use of the System - Legacy plugin and Kunena is not tested on systems that have this plugin enabled. We do not answer questions about problems that people have with unsupported versions of Joomla ("legacy mode" is unsupported).

Please also try using the standard Kunena menu if you have problems.

You need to choose who has access to your forum: you have defined (in your Kunena plugins) both Community Builder access will be used as well as Joomla access. I suggest you try using Joomla access and set "CB access" to no.

You have also set your forum to use both CB avatars and Kunena avatars. Choose one or the other. The same for CB login and Joomla login: one or the other, not both.

I hope that helps.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.138 seconds