×
Kunena 5.2.6 released and Blue eagle 1.6.6 released (25 Jul 2021)

The Kunena team has announce the arrival of Kunena 5.2.6 [K 5.2.6] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.6

Question Server 500 Errors after upgrading to 2.0.4

More
8 years 2 months ago #1 by JLW
I just upgraded Kunena to 2.0.4 on a Joomla 1.5.26 site (in preparation for migrating to Joomla 2.5.13). My "Kunena Config Report" file is below.

The Kunena Component now throws "Server 500 Errors" which I think are its own misinterpretation of what's going on, which might be related to seeking tables that are not there.

You can see this happening if you go to Accordionist.org and navigate to the discussion forums.

I'm not sure but I think the previous Kunena version might have been 1.5.7. I backed up the database beforehand, so I could figure that out if needed.

Can anyone advise what to do? Thanks for your attention.

Here's the config report:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Enabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 64M | Max file upload: 64M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : accordionist | author: rhuk | version: 2.01 | creationdate: 11/02/04

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.1 | creationdate: 2011-11-16

Kunena version detailed: Kunena 2.0.4 | 2013-01-18 [ Pharmacopoeia ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 1.9 | UddeIM 2.7

Third-party SEF components: None

Plugins: Search - Kunena Search 2.0.4 | Content - Kunena Discuss 2.0.4

Modules: Kunena Latest 2.0.4 | Kunena Stats 2.0.4 | Kunena Login 2.0.4 | Kunena Search 2.0.4

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #2 by JLW
This is getting weirder. The first few times the error said it was related to a search by cblogin module for parameters expected in a non-existent 'extensions' table. But it only happens on the Kunena pages even thjough the module is published on every page.

BUT NOW...

The error message has changed, and I can't see why. But now it says:
Fatal Error: Uncaught exception 'Exception' with message 'DateTime::__construct() [datetime.--construct]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead' in /home/accordio/public_html/administrator/components/com_kunena/libraries/date.php:22 Stack trace: #0 /home/accordio/public_html/administrator/components/com_kunena/libraries/date.php(22): DateTime->__construct('2013-07-31T02:0...') #1 /home/accordio/public_html/administrator/components/com_kunena/libraries/date.php(105): KunenaDate->diff('now', true) #2 /home/accordio/public_html/administrator/components/com_kunena/libraries/date.php(153): KunenaDate->toTimeAgo(1375254155) #3 /home/accordio/public_html/components/com_kunena/template/blue_eagle/ in components/com_kunena/libraries/date.php on line 22
 
The error was detected in the Kunena Component.

Does anybody know why the old error went away and how to fix this new one?

Thanks for your attention.

Please Log in or Create an account to join the conversation.

More
8 years 2 months ago #3 by sozzled
You have the Joomla - Legacy plugin enabled! This is why you are having problems.

See Legacy mode in the Wiki.

Joomla never supported "legacy mode". Kunena is not tested on J! 1.5.x systems running with the Joomla - Legacy plugin enabled. You need to disable this plugin.

You should also use the Blue Eagle template designed for K 2.0.4, not the one designed for K 1.7.2.
The following user(s) said Thank You: JLW

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.198 seconds