×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved Install problem kunena on joomla 2.5.9

More
7 years 7 months ago #1 by LeonZ
I have migrated severall joomla 1.5 sites to the latest Joomla 2.5 versions without a problem. Now busy with a website running Kunena and get headaches upgrading Kunena.

So to level the error I tried to install Kunena on a clean Joomla 2.5.9 website. I have no warnings, it's running apache with fastcgi module.

All system requirements are there but when trying to install I get the following error in the log and after several days of searching for a solution and rebuilding the test site I am kind of desperate.
The error is:
mod_fcgid: stderr: PHP Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /var/www/vhosts/mywebsite.nl/httpdocs/administrator/components/com_kunena/install/model.php  on line 1551, referer: https://mywebsite.nl/administrator/index.php?option=com_installer
The line differs depending on which version of Kunena I try to install
com_kunena_v2.0.4_2013-01-18

Can someone point me in the right direction again ?
The topic has been locked.
More
7 years 6 months ago #2 by xillibit
Hello,

The file seems to be corrupted. How do you proceed to install ? By giving package, by putting url ?

I don't provide support by PM, because this can be useful for someone else.
The topic has been locked.
More
7 years 6 months ago - 7 years 6 months ago #3 by LeonZ
I tried every possibility. Even install by URL give me the error. Driving me nuts really.

I just performed an upgrade on the live site with jupgrade, turned everything off and tried to install Kunena by URL immediately. Same error in log and ending in white screen.

Checking the database there are kunena entries in the menu and in the extensions. Furthermore no kunena tables.

In the Joomla admin, I notice the Kunena menu but upon clicking getting the famous white screen. Error stays on line 1551 in model.php

After this tried installing as an example acymailing latest version and without errors.
Last edit: 7 years 6 months ago by LeonZ.
The topic has been locked.
More
7 years 6 months ago #4 by LeonZ
and another try cleaned database cleaned directory, didn't bother upgrading joomla to 2.5.9 son on joomla 2.5.6

max_execution_time = 120
memory_limit = 64M
safe_mode = off
upload_max_filesize = 8M
GD, DOM, JSON support installed

Database Version 5.0.95
Database Collation utf8_general_ci
PHP Version 5.3.8
Web Server Apache
WebServer to PHP Interface cgi-fcgi
Joomla! Version Joomla! 2.5.6 Stable [ Ember ] 19-June-2012 14:00 GMT
The topic has been locked.
More
7 years 6 months ago #5 by LeonZ
Sorry, another try, debug joomla turned on. Kunena latest version downloaded, cleaned everything again, put by directory.

Debug notification:

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /var/www/vhosts/mysite.nl/httpdocs/jupgrade/administrator/components/com_kunena/install/model.php on line 1551
Call Stack
# Time Memory Function Location
1 0.0003 675168 {main}( ) ../index.php:0
2 0.0783 7657344 JAdministrator->dispatch( ) ../index.php:46
3 0.0829 8188648 JComponentHelper::renderComponent( ) ../application.php:153
4 0.0892 8198320 JComponentHelper::executeComponent( ) ../helper.php:351
5 0.0896 8251872 require_once( '/var/www/vhosts/mysite.nl/httpdocs/jupgrade/administrator/components/com_kunena/admin.kunena.php' ) ../helper.php:383
6 0.0979 9497736 KunenaControllerInstall->__construct( ) ../admin.kunena.php:33
The topic has been locked.
More
7 years 6 months ago #6 by LeonZ
I really don't want to bump my topic, but really after four weeks ????
Can some expert really read this topic and tell me what is wrong, and don't tell me it's just a corrupt file because it means nobody uses Kunena cause I download it from this site, I install by URL from this site etc. etc. with new downloads etc.

TIA
Leon
The topic has been locked.
More
7 years 5 months ago #7 by LeonZ
OK, again had a clean rebuild Joomla 2.5 and downloaded again a fresh install but nevertheless I got the same error again. Whilest downloading I noticed a Kunena 3.0 version and downloaded that also.

Cleaned the install again and tried to install the 3.0 version of Kunena and yippie, it installed.

Is it possible to import my old topics etc. in this version ??? Time will tell and fingers crossed.
The topic has been locked.
More
7 years 5 months ago - 7 years 5 months ago #8 by xillibit
The best way should be to keep tables with all your data and install Kunena 3.0.

I don't provide support by PM, because this can be useful for someone else.
Last edit: 7 years 5 months ago by xillibit.
The topic has been locked.
  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.083 seconds