×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved URLs Problem. Upgrading kunena1.7.2 to 2.0.1

More
8 years 3 months ago - 8 years 3 months ago #1 by skizo
Hello. I just update kunena 1.7.2 to 2.0.1 in my joomla test site, versión 2.5.6, and now the forum doesnt work. I have many problems, one is because of friend urls of joomla. If it is on, the urls forum are as that:

mysite.com/foro/Smart%20Search/Joomla!%20Update.html?view=category&catid=2.

It is wrong. However if i remove in joomla the friends urls, it work well.

Thanks.
Last edit: 8 years 3 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #2 by sozzled
It's difficult to give you an exact answer (without knowing more about your website - see FAQs menu item above), but I think you have a problem in the way that you've setup your Kunena menu. As a general guide, you should read Search Engine Optimisation (SEO) in the Wiki.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #3 by skizo
Hello, this is my test site:
www.zonawiki.com/foros.html

The structure of categories is ok, but to click in them, the urls is missing.
When it is kunene 1.7.2, all ok.

thanks!

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #4 by sozzled
Please use the information I gave you in my last reply. Thank you.

We cannot give you any further advice without knowing more about your website.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #5 by Matias
Do you have 3rd party SEF component? I'm asking mostly because you need to upgrade that component to a version that supports Kunena 2.0 as our internal urls have changed.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #6 by skizo
No, I dont use 3rd party SEF component. This site is very simple, only test purpose.

My problem is solved, all ok, more or less.

This was because after upgrading, I tried to use the main menu links had Kunena 1.7.2, because there were, but did not work either. The solution was to go to forun tools click on menu manager and order to create a new menu operating in the main menu. I think this is a bug, the update should remove all entries before, in menu creating, or at least indicate that there is somewhere to delete it manually.

Thanks and regards.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #7 by Matias
Yes, I do agree it being a bug. But in all tested forums the menu items are updated as they should and migration is working very well for them.

So the next step is to find out what is causing this issue and try to reproduce it. It could be language related issue or something that is caused on how the old menu was structured.

If you have some time, it would help a lot to get simple instructions on how to see this bug. :)

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.228 seconds