×
Kunena 5.1.14 Released - Security release (13 Aug 2019)

The Kunena team is proud to announce the arrival of Kunena 5.1.14 [K5.1.14] which is now available for download as a native Joomla extension for Joomla 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.14. This update fixed 1 security issue.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved Disable "new topic" button for users

More
7 years 7 months ago #1 by sgabo
Hello Kunena masters,
I think it will be really good, if someone don't want 1000+ topics on the forum, only 10-20.
Now I can't disable this button in the Administrator menu, and I must delete always the new topics. When I close the general topics, than nobody can write into them.
Best wishes:
Gabor

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #2 by rgblogs
Hello

If you want users not to create new topics in any category, you can lock that category.

I have no signature :)

Please Log in or Create an account to join the conversation.

More
6 years 9 months ago #3 by sgabo
This is my very old topic, but I find the solution: in the kunena css file I can change the display option of new topic button to none. So nobody can open a new topic because the button is hide. :)

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #4 by sozzled
There is a much easier way. In K 2.0.3 you can change the permissions on each category where you do not want people to start new topics and, in that way, the "new topic" button will not appear. Refer to the following screenshot to see how to allow only Managers and Administrators to be able to create new topics in a category:

Attachments:
The following user(s) said Thank You: sgabo

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #5 by modernmagic
display:none is usually bad because the button and code are still loaded just not displayed. A malicious attacker could just remove the display none in the css in firebug and create a new topic.

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago - 6 years 8 months ago #6 by sgabo
Thank You! I opened this topic in time Kunena 1.xxxxx. In that time was very hard to disable this button. :) For me...

I can't find this menu what is on Your screenshot. I use Kunena 2.0.3 but in my hungarian menu isn't "Permissions". Of course I serch it in my language. :) I can turn it in to an advanced mode, or I need maybe updating again?
Last edit: 6 years 8 months ago by sgabo.

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #7 by sozzled
Use Kunena Category Manager. Select the category to edit and then click the Permissions tab.
The following user(s) said Thank You: sgabo

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #8 by sgabo
Thank You very much! Imade new topic display on and made the permissions to off. It works fine!!!

Can You say me maybe something to my other problem too? :cheer:

Merry Christmas!

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.096 seconds