×
Kunena 5.2.2 released (13 Jan 2021)

The Kunena team has announce the arrival of Kunena 5.2.2 [K 5.2.2] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.2

× The error code HTTP 500 Internal Server Error is a general-purpose message this indicates a general error in a web application. Please note that there is no general solution for this general error. You should first read HTTP 500 Internal Server Error before posting in this category.

K 2.0 support will cease on 31 August 2013 and this section of the forum will be closed and archived after that time and no further questions will be answered about this version.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Question Kunena 2.0.1 error 500 post/edit

More
8 years 6 months ago - 8 years 6 months ago #1 by Kneko
I upgraded to version 2.0 and 2.0.1 yesterday
When I edit or posting something new shows me the error 500 but after returning to the forum I see that the post is made despite the error.

This is the message showing the error console

Call stack
# Function Location
1 JSite->dispatch() JROOT/index.php:42
2 JError::raiseError() JROOT/includes/application.php:208
3 JError::raise() JROOT/libraries/joomla/error/error.php:251

Any ideas? thanks

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 50000 seconds | Max execution memory: 90M | Max file upload: 40M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : rt_diametric | author: RocketTheme, LLC | version: 1.0 | creationdate: April 16, 2012

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 2.0.1 | creationdate: 2012-07-07

Kunena version detailed: Kunena 2.0.1 | 2012-07-07 [ Balozi ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 2.0.1 | Kunena Stats 2.0.1 | Kunena Login 2.0.1 | Kunena Search 2.0.1

Last edit: 8 years 6 months ago by Kneko.

Please Log in or Create an account to join the conversation.

More
8 years 6 months ago #2 by xillibit
Hello,

Do you have enabled debug mode in Joomla! and Kunena configuration to see what's happen ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
8 years 6 months ago - 8 years 6 months ago #3 by Kneko

xillibit wrote: Hello,

Do you have enabled debug mode in Joomla! and Kunena configuration to see what's happen ?


Yes, and joomla! shows:


Call stack
# Function Location
1 JSite->dispatch() JROOT/index.php:42
2 JError::raiseError() JROOT/includes/application.php:208
3 JError::raise() JROOT/libraries/joomla/error/error.php:251

i have enable them but Kunena does not show anything.
Attachments:
Last edit: 8 years 6 months ago by Kneko.

Please Log in or Create an account to join the conversation.

More
8 years 6 months ago #4 by Matias
Have you installed any SEF components? To me it looks like that the redirection doesn't work from some reason -- error doesn't happen inside Kunena but during routing.

Please Log in or Create an account to join the conversation.

More
8 years 6 months ago - 8 years 6 months ago #5 by Kneko

Matias wrote: Have you installed any SEF components? To me it looks like that the redirection doesn't work from some reason -- error doesn't happen inside Kunena but during routing.


I didnt install any SEF component.

Yes, it seems redirection doesnt work... Kunena menu issue? I have no idea how to fix it.


Thank you for your help.

Edit: I trashed kunena menú and create a new one with forum tools> menu manager but it doesnt work either.
I disable friendly url option for search engine in joomla and Kunena.
Last edit: 8 years 6 months ago by Kneko.

Please Log in or Create an account to join the conversation.

More
8 years 6 months ago - 8 years 6 months ago #6 by Matias
After closer look into your configuration report I found something that might be causing the issue:

Kunena menu details:
ID Name Menutype Link Path
110Foromainmenuview=category&layout=listforo
111Foro (2)mainmenuview=category&layout=listforo-2
129ForummainmenuItemid=133kunena-2012-07-02
131Foromainmenuview=category&layout=list&catid=0forum

In main menu you can see 3 extra menu items: Foro, Foro (2) and Foro.

Please remove all of those (remember to empty trash) and publish the fourth menu item called Forum (id 129). You can also rename it to Foro if you want to.
Last edit: 8 years 6 months ago by Matias.

Please Log in or Create an account to join the conversation.

More
8 years 6 months ago - 8 years 6 months ago #7 by Kneko
I tried it (empty trash) and publish the Forum (id 129) but it doesnt work either, same error.

I remove it too and same error (500) appear again.

Here you can check current config report:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Disabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 50000 seconds | Max execution memory: 90M | Max file upload: 40M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : rt_diametric | author: RocketTheme, LLC | version: 1.0 | creationdate: April 16, 2012

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 2.0.1 | creationdate: 2012-07-07

Kunena version detailed: Kunena 2.0.1 | 2012-07-07 [ Balozi ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: Kunena Latest 2.0.1 | Kunena Stats 2.0.1 | Kunena Login 2.0.1 | Kunena Search 2.0.1


I tried to reinstall right now and the error is still here.


Thank you so much for your help and patience.
Last edit: 8 years 6 months ago by Kneko.

Please Log in or Create an account to join the conversation.

More
7 years 10 months ago #8 by hannes01
I have exactly the same error (Kunena 2.0.4).

Did you find the solution for this?

Thanks,
Hannes

Everything about fishing & tackle: forum, local and international shop

Please Log in or Create an account to join the conversation.

More
7 years 10 months ago #9 by sozzled
Please see I have the same problem ... and www.kunena.org/docs/HTTP_500_Internal_Server_Error HTTP 500 Internal Server Error .

If hannes01 is using K 2.0.4 then this is not the same problem that was mentioned 7 months ago (when K 2.0.1 was the version available at that time).

To avoid further confusion, this topic (and all topics in this category older than 1 month) will now be locked.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.732 seconds