×
Blue Eagle 5 v1.5.4 has been Released (13 Sep 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.4 which is now available for download. This version addresses most of the issues that were discovered in development.

× This is not a support forum for any of the products contained herein. For product support you should visit the developer's website.

The information given in this category is intended to guide users who want to use various third-party products with Kunena and, mostly, was written by Kunena users. The information here is not necessarily accurate, up-to-date nor is it intended to replace the support given by the developers of other Joomla extensions.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Merged Kunena with AceSEF

More
6 years 10 months ago #1 by lisamariecratty
I tried to do the update to 3.0.3 and it hung. I was finally able to get it to work by downloading the 3.0.3 zip file and installing it through the extension manager. I can now get into the backend Kunena panel and it appears to be fine, but when I try to load the forum on my website I now get a 500 Internal Server error.

Here is my config report:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Enabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 512M | Max file upload: 128M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : kallyas | author: Marius Hogas | version: 1.2 | creationdate: Unknown

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.0 | creationdate: 2011-08-29

Kunena version detailed: Kunena 3.0.3 | 2013-10-20 [ Bifrost ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: Jomsocial 2.8.3

Third-party SEF components: AceSEF 2.5.10.6

Plugins: JomSocial - My Kunena Forum Menu 2.0.3 | JomSocial - My Kunena Forum Posts 2.0.3 | JomSocial - Kunena Groups 2.0.3

Modules: None

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago - 6 years 10 months ago #2 by xillibit
Replied by xillibit on topic Kunena with AceSEF
Hello,

Can-you please enable debug mode in kunena and joomla configuration panel to see a more detailled error message ?

In the same time, i advise you to upgrade your joomla version to 2.5.14 and use blue eagle template in version 3.0

I don't provide support by PM, because this can be useful for someone else.
Last edit: 6 years 10 months ago by xillibit.

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago - 6 years 10 months ago #3 by sozzled
Replied by sozzled on topic Kunena with AceSEF
There are a few of your settings that may be causing problems here:

1) AceSEF 2.5.10.6 is incompatible with K 3.0 - (see Interoperability with other Joomla extensions ) - and has been incompatible with Kunena since K 2.0. Talk to the developers of AceSEF for their advice or disable (or uninstall) AceSEF

2) As xillibit wrote the Blue Eagle template designed for K 1.7.2 is not recommended for K 3.0.3. Use the new Blue Eagle template instead.

3) See To what extent does K 3.0 support Jomsocial

4) Change the settings for the forum integration plugins as shown in red font below:

Kunena - AlphaUserPoints Disabled
Kunena - Community Builder Disabled
Kunena - Gravatar Disabled
Kunena - JomSocial Enabled: access=0 login=1 activity=1 avatar=1 profile=1 private=1 activity_points_limit=0 activity_stream_limit=0
Kunena - Joomla Enabled: access=1 login=0
Kunena - Kunena Enabled: avatar=0 profile=0
Kunena - UddeIM Disabled

5) Simplify your Joomla menu. Try using the standard Kunena menu as discussed in Kunena Menu issues in the Wiki, first, and then see if this helps.

And, lastly, as xillibit wrote, enable debug mode to find out more about the details of the " HTTP 500 Internal Server Error " that you are getting.

I visited your forum - it was hard to find and the page loaded very slowly - but I could not work out how to reproduce a HTTP 500 Internal Server Error error. Perhaps you could tell us what you did to get this error?

And, yes, J! 2.5.11 was buggy and that version is not recommended by Joomla. Update to J! 2.5.14 at the very least.
Last edit: 6 years 10 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago #4 by lisamariecratty
Replied by lisamariecratty on topic Kunena with AceSEF
Thank you both so much for the help. Ok, I'm getting somewhere with this, but not quite there yet...

I upgraded to 2.5.14 and I changed to the 3.0 template. That didn't make any difference, but when I turned on the debugger I did get more info from the error. It was pointing to a line in com_AceSEF as was suggested. I disabled AceSEF and now I no longer get the 500 error but my forum now starts with many "Strict Standards" errors and goes to the kunena/index page.

Sozzled, I removed the main menu to my forum, that's why it's hard to find! Here's the link: www.mama-janes.com/forum

Thank you!!

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago #5 by lisamariecratty
Replied by lisamariecratty on topic Kunena with AceSEF
Here's a new config file:


This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Enabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 512M | Max file upload: 128M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : kallyas | author: Marius Hogas | version: 1.2 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 3.0.3 | creationdate: 2013-10-20

Kunena version detailed: Kunena 3.0.3 | 2013-10-20 [ Bifrost ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: Jomsocial 2.8.3

Third-party SEF components: AceSEF 2.5.10.6

Plugins: JomSocial - My Kunena Forum Menu 2.0.3 | JomSocial - My Kunena Forum Posts 2.0.3 | JomSocial - Kunena Groups 2.0.3

Modules: None

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago #6 by lisamariecratty
Replied by lisamariecratty on topic Kunena with AceSEF
I just fixed it!! Realized that I still had my debugger turned on. Is there any issue if I was getting a bunch of Strict Standards: Only variables should be assigned by reference in.... type references?

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago #7 by xillibit
Replied by xillibit on topic Kunena with AceSEF
Hello,

These kinds of errors aren't blocking, so you can live without acesef because it was the root of the issue.

I don't provide support by PM, because this can be useful for someone else.
The following user(s) said Thank You: lisamariecratty

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago - 6 years 10 months ago #8 by lisamariecratty
Replied by lisamariecratty on topic Kunena with AceSEF
Oh no!!! Now my login no longer functions:

mama-janes.com/log/

I re-enabled AceSEF and that is what controls my login. It works now that I have re-enabled it but when I do that I now get the old error on the forum:

Fatal Error was detected!

Fatal Error: Maximum execution time of 30 seconds exceeded in components/com_acesef/library/cache.php on line 261

The error was detected in the Acesef Component.
Last edit: 6 years 10 months ago by lisamariecratty. Reason: added more detail

Please Log in or Create an account to join the conversation.

More
6 years 10 months ago - 6 years 10 months ago #9 by sozzled
Replied by sozzled on topic Kunena with AceSEF
I agree with xillibit and, to restate what I wrote before,

sozzled wrote: AceSEF ... is incompatible with K 3.0 - (see Interoperability with other Joomla extensions ) - and has been incompatible with Kunena since K 2.0. Talk to the developers of AceSEF for their advice or disable (or uninstall) AceSEF

... to the best of my knowledge.

The solution may depend entirely what you consider to be more important to you: Kunena or AceSEF.

I am just stating the facts as I am aware of them. AceSEF "broke" Kunena from the time of K 2.0. We have no business relationship with the developers of AceSEF. We rely on information from members of this community to inform us if there have been developments with other Joomla extensions that allow for products like AceSEF to interoperate with Kunena. As far as I know - I do not personally use AceSEF - no-one has informed the community since K 2.0 that AceSEF has been proven to work with Kunena. If someone knows differently (or if the developers of AceSEF would care to comment) they may do so here. Until that happens I can only advise you based on the last information I was given about AceSEF and that information was that AceSEF does not work with Kunena.

We have had many discussions about 3rd-party SEF/SEO products that people have purchased and have tried - some of them successfully and many of them unsuccessfully - to use with Kunena. You can search this forum for some of those discussions or, if you are particularly interested on the body of opinion on such matters, I can point you to some of those topics.

Our advice is this: if you have problems using AceSEF with K 3.0.3, please refer your questions to the developers of AceSEF or disable or uninstall AceSEF and try that approach instead.
Last edit: 6 years 10 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
6 years 9 months ago #10 by poonoodi
Replied by poonoodi on topic Kunena with AceSEF
hi

i use acesaf in web site
but don't sef kunena links

i install acesef plugin for kunena (download from acesef site)
but don't work in my web site :(

please help

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.181 seconds