Kunena 6.3.2 released

The Kunena team has announce the arrival of Kunena 6.3.2 [K 6.3.2] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3
Note: Please go to the Kunena Dashboard after an upgrade so that the Kunena database tables are also updated.

Question Kunena 6.3.2 maintenance Release for Joomla! 4.4/5.0/5.1

More
1 month 1 day ago #1 by xillibit
Introduction:
The Kunena team is thrilled to announce the maintenance release...

Introduction:

The Kunena team is thrilled to announce the maintenance release of Kunena 6.3.2, a native Joomla extension for Joomla! 4.4, 5.0 and 5.1.

We've implemented native support for Joomla 5. This means you don't have to enable the new compatibility plugin "Behaviour - Backward Compatibility " on Joomla! 5.0 for it to work with Kunena.

Kunena 6.3 has been designed to work on Joomla! 4.4 and later, the requirements are the followings :
  • Php 7.4.1 to Php 8.3.x
  • MySQL 5.7.23 to MySQL 8.3.0
  • Bootstrap 5.1

The work done in Kunena 6.3 is the following:

  • Refactor the backend views to be compatible with Joomla! 5.0 (thanks to ruud)
  • Some bugfixes and refactor of code
  • Replace Twitter by X in all places where it was used and add bluesky social network
  • Replace some deprecated usage of methods Joomla! from in the code
  • Implementation of handle of mentions in a message when using CKeditor
  • Get list of users for autocomplete in search form

Download:

Download K6.3.2 stable here: https://github.com/Kunena/Kunena-Forum/releases/tag/6.3.2

This means that the Kunena 6.2 series is approching the end of life and will be discountinued, with the future release of K6.3 in stable there won't be new versions of K6.2 after that.

Donations

Any donations are needed for future support.


I don't provide support by PM, because this can be useful for someone else.
The following user(s) said Thank You: ssnobben, Leen, Gindi

Please Log in or Create an account to join the conversation.

More
1 month 23 hours ago #2 by Gindi
In the database in table xxx_kunena_users, row 30, between skype and facebook is still twitter.

Gindi
 
The following user(s) said Thank You: ssnobben

Please Log in or Create an account to join the conversation.

More
1 month 12 hours ago #3 by xillibit
Hello,

That's is something is changed on update to x_social from K6.2.x to K6.3.x since K6.3.0 stable, when you had done the update to K6.2.x to K6.3.x did-you had opened the Kunena dashboard ? And some alert messages has been displayed on things which has been updated ?

I don't provide support by PM, because this can be useful for someone else.
The following user(s) said Thank You: ssnobben, Gindi

Please Log in or Create an account to join the conversation.

More
4 weeks 1 day ago #4 by Gindi
Thanks for the reply, the error is because my Kunena database has not been updated.
I found the entry in kunena.install.upgrade.xml and updated the database table.

gindi
 
The following user(s) said Thank You: ssnobben

Please Log in or Create an account to join the conversation.

More
4 weeks 1 day ago #5 by mrivner
Yes, this update has the same problem as previous updates.  The database entries for social media found in Table Kunena_Users are not being updated.  I had this same issue with bsky_app which needed to be manually added to this table for Kunena saves to work with a previous upgrade.  I am using MariaDB version 10.6.16 on Ubuntu 22.04.

For users having this issue, x_social should be substituted for twitter.  bsky_app needed to be added to the table as another column,.between reddit and ok

Michael
The following user(s) said Thank You: ssnobben

Please Log in or Create an account to join the conversation.

More
4 weeks 20 hours ago #6 by rich

Thanks for the reply, the error is because my Kunena database has not been updated.
I found the entry in kunena.install.upgrade.xml and updated the database table.

gindi

 
Confirmed. The fact is that the table update is not executed during an upgrade. It is of no use if you go to the dashboard afterwards. So you have to enter this command manually with phpMyAdmin in the database.

(Database = 10.5.25-MariaDB)
The following user(s) said Thank You: Gindi

Please Log in or Create an account to join the conversation.

  • Pinkeltje
  • Pinkeltje's Avatar
  • Away
  • Premium Member
  • Trying to find an answer before asking
More
4 weeks 18 hours ago #7 by Pinkeltje
Confirmed. Same here.

Please Log in or Create an account to join the conversation.

More
4 weeks 17 hours ago #8 by xillibit
You encounter the issue on Joomla! 4.4.5 or on Joomla! 5.1.1 ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

  • Pinkeltje
  • Pinkeltje's Avatar
  • Away
  • Premium Member
  • Trying to find an answer before asking
More
4 weeks 16 hours ago #9 by Pinkeltje

Please Log in or Create an account to join the conversation.

More
4 weeks 16 hours ago #10 by mrivner

Please Log in or Create an account to join the conversation.

Time to create page: 0.482 seconds