×
Kunena 5.1.14 Released - Security release (13 Aug 2019)

The Kunena team is proud to announce the arrival of Kunena 5.1.14 [K5.1.14] which is now available for download as a native Joomla extension for Joomla 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.14. This update fixed 1 security issue.

× Topics contains old discussions (generally more than one year ago or based on circumstances that subsequently changed) or topics resolved in other ways. Topics moved into this category are closed from further discussion.

Question When is somebody going to fix the Kunena menu mess?

More
7 years 6 months ago - 7 years 6 months ago #1 by miamiman
Yup, I did it again... I thought I could get fancy and make some changes to the horizontal Kunena menu on one of my sites.

And you guessed it! Yup... my menus starting disappearing again. Sometimes they're there, and sometimes, well, if you're a Kunena user, you know what I mean. Poof, magic.

I'm sure I'll get it working, but boy... what a relief if knowing that installing/modifying Kunena wouldn't be such a MENU MESS, everytime.

Anyway, my request to the wonderful kunena community... please fix this menu disappearing act.
Last edit: 7 years 6 months ago by sozzled. Reason: Change topic icon

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago - 7 years 6 months ago #2 by sozzled
I understand what you've written and, as I've commented several times since Kunena went to using the Joomla menuing system, the Joomla menuing system is perhaps one of the most difficult parts of Joomla to understand and properly manage. We are aware of the difficulties that people have experienced in using the Joomla menuing system and that is why we wrote Customised menus for the Wiki ... to try to make it as easy as possible for those people who want to do "their own thing".

As you can see by looking at the many topics we've had in response to difficulties that people have had with the Joomla menuing system (for example, How do I restore my Kunena menu? and [Merged topic] "This webpage has a redirect loop" ) people do have problems and we do sympathise.

Part of the difficulty, in developing a Joomla extension like Kunena, with a single kit that installs on J! 1.5 and J! 2.5, is that there were changes brought about when Joomla 1.6 (and 1.7 and later 2.5) came into being. The menu system in J! 1.6 is not conceptually different to the approach used in J! 1.5 - I mean, the differences are superficially minor - but they're different nontheless.

So, while it would be ideal to have one installation kit that works 100% of the time whether you're using J! 1.5 or a later version, it hasn't been easy from a developer's perspective. It hasn't been easy to sift through all the differences inherent between J! 1.5 and J! 1.6 (or J! 1.7 or J! 2.5) and, for practicality's sake, some compromises had to be made. However, if people are well-versed in how the Joomla menuing system works, these difficulty's are not that hard to work through. It all comes down to a question of what you know and what you want that may be different to what comes "out-of-the-box" with K 1.7.

I'm happy to say, though, that many of these problems will gradually disappear over time for the following reasons an you should be encouraged by the following facts:
  • K 1.7.x is at end-of-life;
  • J! 1.5 is nearing end-of-life;
  • K 2.0 should make the menu creation/management process easier; and
  • going forward, K 3.0 will not support J! 1.5 and, therefore, the J! 1.5 vs. later versions of Joomla issues will become a thing of the past.
So, in short, yes, the Kunena development team has a keen interest in putting to bed the menu mess that has dogged K 1.6/1.7 over the past year-and-a-half. :)
Last edit: 7 years 6 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago - 7 years 6 months ago #3 by miamiman
Thanks Sozzled... with age, we all get better, don't we?

And yes, one hour later, I f-kng figured it out! :lol: :lol:

While I had deleted/trashed and recreated all the kunena menus, I had not deleted the module per:

@quila wrote: ... delete all existing menu to kunena (Forum in Main Menu, Kunena Menu and all modules with kunena menu) and clear Menu Trash, then go to Kunena Control Panel and click to "Create Menu" icon.


Blessed are the forum posters.
Last edit: 7 years 6 months ago by miamiman.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #4 by sozzled

miamiman wrote: Blessed are the forum posters ...

... and the people who write the Wiki documentation ... ;)

Glad you figured it out.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.098 seconds