×
Kunena 5.2.4 and Blue eagle 1.6.4 released (04 Apr 2021)

The Kunena team has announce the arrival of Kunena 5.2.4 [K 5.2.4] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.4

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with, this template isn't designed to works with Bootstrap 3 and Bootstrap 4.

Question Geburtstags Modul - Rendering Error

More
1 month 2 days ago - 4 weeks 1 day ago #1 by RSFBochum
- Der Entwickler wurde über diesen Beitrag informiert. Nähere Infos warum gibt es auf der Supportseite des Entwicklers. -

Es geht um das " SchuWeb Birthday Module ". Rufe ich auf meiner Webseite das Kunena Forum auf, erhalte ich seit neustem einen "Content-Encoding Fehler". Die Seite bzw. das Forum lädt also gar nicht erst.

Nach etwas Recherche habe ich die "GZip Komprimierung" in der Joomla Konfiguration ausgeschaltet, den Debug Modus ein und "Fehler berichten" auf Maximum gestellt. Das Forum lädt dann, jedoch an der Modulposition des Geburtstags Moduls erhalte ich folgende Fehlermeldung:

Rendering Error in layout Widget/Module: Call to undefined method KunenaUser::getName() in /..(gekürzt)../rsf-bochum/modules/mod_sw_kbirthday/helper/default.php on line 23
Layout was rendered in /..(gekürzt)../rsf-bochum/components/com_kunena/template/blue_eagle5/layouts/category/index/default.php on line 55


Daraufhin habe ich das Blue Eagle Template auf die aktuelle Version 1.6.3 aktualisiert, was jedoch keine Besserung bewirkt hat. Deaktiviere ich das Geburtstags Plugin, funktioniert alles normal. Es geht um www.rsf-bochum.de

Über eine Lösungsidee würde ich mich sehr freuen. Danke

This message contains confidential information

Database collation check: ✔ The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 50000 seconds | Max execution memory: -1 | Max file upload: 64M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : jp-gusto | author: JoomlaPlates | version: 1.0.006 | creationdate: October 2016

Kunena default template details : Blue Eagle5 | author: Kunena Team | version: 1.6.3 | creationdate: 2021-03-10

Kunena template params:

Warning: Spoiler!

Kunena version detailed: Kunena 5.2.3 | 2021-03-07 [ Jason ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: None

Modules: None

Last edit: 4 weeks 1 day ago by rich. Reason: Konfigurationsreport richtig eingefügt

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #2 by svanschu
Hi RSFBochum,

das tut mir Leid, dass du da Probleme hast.

Welche Version hast vom SW KBirdthay?

Besteht das Problem seit dem Update auf Kunena 5.2?

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago - 1 month 2 days ago #3 by RSFBochum
Hallo Sven,
Das Problem besteht seit ein paar Tagen, davor lief es seit Jahren problemlos. Eventuell seit dem Update von Kunena auf 5.2.3. Am 5.3. habe ich noch einen Post geschrieben, wobei mir keine Probleme aufgefallen waren. Am 7.3. kam das Update raus laut Changelog.

Das Modul hatte ich auch gelöscht und neu installiert. In der Erweiterungsverwaltung steht bei Version jedoch "sw.build.version" und bei Datum "sw.build.date".

Grüße
Lorenz
Last edit: 1 month 2 days ago by RSFBochum.

Please Log in or Create an account to join the conversation.

More
1 week 6 days ago #4 by Eifelblitz
Hallo hier im Forum,

ich kann das nur bestätigen, seit dem letzten Update gibt es Probleme mit dem Geburtstagsmodul, ich habe es abgeschaltet und das Forum läuft wieder.
Warte auf ein Update.

LG
Michael

Please Log in or Create an account to join the conversation.

More
1 week 6 days ago #5 by svanschu
Hi @RSFBochum, Hi @Eifelblitz,

danke für die Infos. Ich schieb das gleich ganz hoch auf meiner Liste.

Please Log in or Create an account to join the conversation.

More
1 week 5 days ago #6 by svanschu
Hallo,
es sieht so aus, als ob eine nicht ganz durchdachte Änderung in Kunena 5.3.2 Schuld an dem Fehler sei. Die Methode getName wurde entfernt und die Ersatzmethode liefert kein Ergebnis zurück. Siehe: github.com/Kunena/Kunena-Forum/issues/7947
Zur Zeit sieht es so aus, als würde die Methode in der nächsten Kunena Version wieder vorhanden sein.

Kurzfristige Workarounds sind auf die Kunena 5.3.1 zurück zu gehen oder das Module deaktiviert lassen, bis K 5.3.3 herauskommt.

Könnte die Exception abfangen, aber dann hättet ihr ein Modul ohne Namen. Dass würde euch jetzt auch nicht viel bringen.

Please Log in or Create an account to join the conversation.

More
1 week 4 days ago #7 by svanschu
Es ist bestätigt. Die fehlende Methode wird mit Kunena 5.2.4 wieder zurück kommen und dann wird das Modul und ein paar andere Erweiterungen wieder so funktionieren wie vorher.

Please Log in or Create an account to join the conversation.

More
1 week 4 days ago #8 by RSFBochum
Hallo svanschu,
danke, dass Du Dich um eine Problemfindung und -lösung gekümmert hast. Dann warte ich einfach das Kunena Update ab.
Grüße
Lorenz

Please Log in or Create an account to join the conversation.

More
1 week 4 days ago #9 by svanschu
Hi, die V 5.2.4 ist soeben im Updater erschienen. Jetzt geht wieder alles.

Wenn euch das Modul gefällt, freue ich mich auf neue Follower auf Twitter twitter.com/SchuWebExt und eine gute Bewertung im JED extensions.joomla.org/extension/sw-kbirthday-for-kunena/

Danke :)

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.283 seconds