×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Solved Labels werden nicht korrekt angezeigt

More
2 weeks 10 hours ago #1 by Meister Jeremias
Hallo,

Unter Moderation wird mir das Default-Etikett korrekt angezeigt, bei den Beiträgen erhalte ich aber stattdessen ein Question-Etikett.

Kann es sein, dass die labels.xml generell falsch eingestellt/codiert ist? Ich habe noch nichts daran geändert und erhalte diesen Code:

<labels type="qa" width="48" height="48">
<label id="0" name="COM_KUNENA_LABELS_QUESTION" b2="question-sign" b3="question-sign" fa="question-circle" labeltype="primary"/>
<label id="1" name="COM_KUNENA_LABELS_IMPORTANT" b2="notification-circle" b3="exclamation-sign" fa="exclamation-circle" labeltype="primary"/>
<label id="2" name="COM_KUNENA_LABELS_QUESTION" b2="question-sign" b3="question-sign" fa="question-circle" labeltype="primary"/>
<label id="3" name="COM_KUNENA_LABELS_IDEA" b2="lamp" b3="lamp" fa="lightbulb" labeltype="primary"/>
<label id="4" name="COM_KUNENA_LABELS_LOVED" b2="heart" b3="heart" fa="heart" labeltype="danger label-important"/>
<!-- <label id="5" name="Bug" b2="file" b3="file" fa="file" labeltype="primary"/> -->
<!-- <label id="6" name="Bug" b2="file" b3="file" fa="file" labeltype="primary"/> -->
<!-- <label id="7" name="Bug" b2="file" b3="file" fa="file" labeltype="primary"/> -->
<label id="8" name="COM_KUNENA_LABELS_SOLVED" b2="ok" b3="ok" fa="check" labeltype="success"/>
<label id="9" name="COM_KUNENA_LABELS_MERGED" b2="contract" b3="resize-small" fa="compress" labeltype="info"/>
<label id="10" name="COM_KUNENA_LABELS_DELETED" b2="remove" b3="remove" fa="times" labeltype="primary"/>
<label id="11" name="COM_KUNENA_LABELS_STICKY" b2="pin" b3="pushpin" fa="map-pin" labeltype="info"/>
<label id="12" name="COM_KUNENA_LABELS_LOCKED" b2="lock" b3="file" fa="lock" labeltype="info"/>
<label id="13" name="COM_KUNENA_LABELS_MOVED" b2="contract" b3="contract" fa="compress" labeltype="info"/>
</labels>


Müsste da nicht in der ersten Zeile "DEFAULT" stehen anstatt "QUESTION"? Ansonsten gäbe/gibt es für Question doch zwei Einträgen?!

Ich habe "question" mal durch "default" ersetzt, dann wird mir das Etikett aber völlig "zerschossen".

Was muss ich tun, damit das Default-Etikett anständig angezeigt wird?

Please Log in or Create an account to join the conversation.

More
2 weeks 8 hours ago #2 by rich
== Beitrag verschoben ==
Bitte erstelle bei Problemen dein eigenes Thema und grabe nicht uralte Themen aus.

Anhand von Crypsis und Bootstrap 2 Symbolen ein einfaches Beispiel wie du es am besten lösen kannst (so bleibt es auch nach Kunena Aktualisierung vorhanden).

Kopiere die die labels.xml und füge diese in den Template Konfigurationsordner ein. Pfad ist: /components/com_kunena/template/crypsis/config/labels.xml

Die kopierte xml kannst du danach anpassen. Beispiel:

<?xml version="1.0" ?>
<!DOCTYPE kunena-topiclabels>
<kunena-topiclabels>
<name>Labels</name>
<version>5.1.16-DEV</version>
<creationDate>2020-01-09</creationDate>
<author>Kunena Team</author>
<authorEmail>This email address is being protected from spambots. You need JavaScript enabled to view it.</authorEmail>
<authorUrl> www.kunena.org </authorUrl>
<copyright> www.kunena.org </copyright>
<license>GNU/GPL</license>
<description>Default Labels for Kunena</description>

<labels type="qa" width="48" height="48">
<label id="0" name="eigener Text" b2="file" b3="question-sign" fa="question-circle" labeltype="primary"/>
<label id="1" name="COM_KUNENA_LABELS_IMPORTANT" b2="notification-circle" b3="exclamation-sign" fa="exclamation-circle" labeltype="primary"/>
<label id="2" name="COM_KUNENA_LABELS_QUESTION" b2="question-sign" b3="question-sign" fa="question-circle" labeltype="primary"/>
<label id="3" name="COM_KUNENA_LABELS_IDEA" b2="lamp" b3="lamp" fa="lightbulb" labeltype="primary"/>
<label id="4" name="COM_KUNENA_LABELS_LOVED" b2="heart" b3="heart" fa="heart" labeltype="danger label-important"/>
<!-- <label id="5" name="Bug" b2="file" b3="file" fa="file" labeltype="primary"/> -->
<!-- <label id="6" name="Bug" b2="file" b3="file" fa="file" labeltype="primary"/> -->
<!-- <label id="7" name="Bug" b2="file" b3="file" fa="file" labeltype="primary"/> -->
<label id="8" name="COM_KUNENA_LABELS_SOLVED" b2="ok" b3="ok" fa="check" labeltype="success"/>
<label id="9" name="COM_KUNENA_LABELS_MERGED" b2="contract" b3="resize-small" fa="compress" labeltype="info"/>
<label id="10" name="COM_KUNENA_LABELS_DELETED" b2="remove" b3="remove" fa="times" labeltype="primary"/>
<label id="11" name="COM_KUNENA_LABELS_STICKY" b2="pin" b3="pushpin" fa="map-pin" labeltype="info"/>
<label id="12" name="COM_KUNENA_LABELS_LOCKED" b2="lock" b3="file" fa="lock" labeltype="info"/>
<label id="13" name="COM_KUNENA_LABELS_MOVED" b2="contract" b3="contract" fa="compress" labeltype="info"/>
</labels>
</kunena-topiclabels>


Anstatt den zugehörigen Text hart kodiert reinzuschreiben, kannst du auch einen eigenen Sprachcode erstellen, z.B. COM_KUNENA_LABELS_OWN_TEXT und danach ein „Sprachoverride“ machen.

docs.kunena.org/en/languages/language-overrides
www.kunena.org/forum/36-German/150779-ei...els-erstellen#198447

Please Log in or Create an account to join the conversation.

More
2 weeks 8 hours ago #3 by Meister Jeremias
Danke für die schnelle Antwort, werde ich nachher mal ausprobieren.

Und entschuldige bitte die Umstände mit dem alten Beitrag. Ich dachte das gehört dahin.

Please Log in or Create an account to join the conversation.

More
1 week 6 days ago #4 by Meister Jeremias
Das ändern des Namens und des Symbol hat funktioniert, die gewünschten Farbänderungen werden aber leider noch nicht übernommen.

Ich habe versucht die Farbänderung wie hier beschrieben mit, span.label.label-eigener in der custom.less, umzusetzen: www.kunena.org/forum/36-German/150779-eigene-labels-erstellen Die Farbänderungen werden aber leider nicht im Frontend übernommen.

Wenn ich in der labels.xml bei labeltype danger, primary, warning ... etc, eingebe, ändert er zwar die Farben, das scheinen aber die Farben von Kunena und nicht die von meinem Template zu sein.

Please Log in or Create an account to join the conversation.

More
1 week 6 days ago #5 by rich
Ich habe es jetzt nochmal getestet und wenn du alles richtig gemacht hast, sollte es funktionieren. Möglicherweise spielt dir der Cache einen Streich. Leere den Joomla und auch Browser-Cache nach der Änderung.

Das habe ich in der xml verändert:

<label id="0" name="Eigener Text" b2="file" b3="question-sign" fa="question-circle" labeltype="Meister-Jeremias"/>

Hier der css Code dazu:
span.label.label-Meister-Jeremias {
    background-color: orange;
    color: black;
}
und das ist das Ergebnis:

Attachments:

Please Log in or Create an account to join the conversation.

More
1 week 6 days ago #6 by Meister Jeremias
Ach ich Dussel... der Cache war es.

Entschuldige die Umstände und danke für die prompte Hilfe.

Es funktioniert jetzt wie gewünscht.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.370 seconds