×
Kunena 5.2 RC3 Released (29 Nov 2020)

The Kunena team is thrilled to announce the third public release candidate of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 RC3 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

Solved Probleme mit User-Definition

More
3 years 10 months ago #1 by okeo
Hallo,

ich habe eine z.Zt. offline gestellte Installation, die ich gerade von Joomla 2.5.x und entsprechend altem Kunena migriert habe und mir nun Probleme macht:
Für das Update von Joomla habe ich vorher Kunena deinstalliert und dann nach erfolgtem Joomla-Update das Kunena-Paket neu installiert (v 5.0.4). Die Installation holperte etwas und ich musste die Kunena-Pakete erst noch einmal deinstallieren und sie dann statt im IE, im Firefox wieder installieren. Dann ging es, sah aber sch... aus. Erst als ich im "Template: crypsis" -> "Grundeinstellungen" -> "Bootstrap css laden" auf "AN" geschaltet habe, war die Optik o.k.
Nun steht aber nach dem Einloggen:
"keine Beiträge erstellbar: sie sind gebannt."
In der Benutzerübesicht haben tatsächlich alle den "Bann-Status" angehakt.
Wenn ich den ändern möchte, kommt die Meldung, dass man dazu Moderator sein muss. Und auch hier: ja, tatsächlich hat keiner in der Liste den Moderator-Status gesetzt, Auch die bisherigen Moderatoren und Super/User nicht. Wähle ich einen Benutzer in der Liste aus und klicke [Moderator(en) zuweisen] kommt zwar der Dialog "Moderatoren zuteilen - Ausgewählte Benutzer als Moderatoren für folgende Kategorien zuweisen" Aber leider ohne eine Liste der Kategorien darunter. Kein Wunder> Wir haben auch gar keine Kategorien definiert (ob mal welche da waren und nun nur nicht mehr, weiß ich nicht) - wenn ich den Hauptmenüpunkt "Kategorien" wähle, kommt eine leere Liste. Wenn ich dort jetzt "Neue Kategorie" klicke, geht das nicht: es kommt eine leere Seite (die Menüleiste oben ist noch da, darunter ein wenige Punkte hoher etwas hellerer blauer Streifen und dann ein grauer Streifen (ca. doppelt so hoch wie die Menüleiste). Der Hauptteil des Screens ist weiß. Nur ganz unten kommt noch die graue Joomla-Leiste ("Vorschau | 0 Besucher | 1 Admin | 0 Messages | Abmelden")
So kann ich keine Kategorien definieren und damit keinen Moderator machen und damit keinen Benutzer "ent-bannen". <seufz>

Um selbst aus dem Teufelskreis auszubrechen, habe ich mich in der Datenbank mal zum Moderator gemacht (update ovn8y_kunena_users set moderator='1' where userid='123';). Das taucht in der Benutzerliste auch als Haken bei meinem Eintrag auf, führt aber nicht dazu, dass ich das "Gebannt" bei irgendeinem Eintrag ändern kann. Es kommt immer noch die Meldung "Fehler - Du musst Moderator sein, um diese Aktion durchzuführen."

Leider habe ich weder hier im Forum noch im Web einen Hinweis gefunden, so dass ich mich über jede Idee freue, wie ich dieses Elend beseitige. Es wäre der letzte Schritt des Updates und das würde ich gerne mal abschließen ;-)

Ich habe jetzt bewusst keine einzelne Frage gestellt, sondern das Gesamtelend geschildert. Vielleicht kann ja schon damit einer von euch mir helfen ...

PS: Das Update auf die 5.0.5 hat übrigens gut geklappt, aber an dem Problem nichts geändert.

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #2 by rich
Replied by rich on topic Probleme mit User-Definition
Mit deiner Installation scheint einiges nicht zu stimmen. Wie hast du die Seite migriert? Sind da eventuell auch Erweiterungen dabei, welche nicht für Joomla 3.6 geschrieben wurden?

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago - 3 years 10 months ago #3 by okeo
Replied by okeo on topic Probleme mit User-Definition
Hallo,

die Joomla-Migration war erst auf 3.4, dann auf die 3.6 (Joomla_3.6.4-Stable-Update_Package). Das ging erst, als ich alle Kunena*-Erweiterungen gelöscht hatte.
Dann habe ich Kunena neu installiert.

Mit den anderen und ggf. veralteten Erweiterungen habe ich das Problem, dass ich die Installation so wie sie ist übernommen habe und nicht weiß, welche Erweiterungen mein Vorgänger damals (tm) installiert hat.
Wenn ich mir jetzt die Liste der Erweiterungen anschaue ("Erweiterungen: Verwalten") sehe ich neben 130 Einträgen von "Joomla! Project" und 17 von "Kunena Team", noch 28 Einträge anderer Autoren.
Ein paar von denen kann ich mir bekannten Funktionalitäten zuordnen, aber nicht alle.
Wie sollte ich da vorgehen? Kunena deinstallieren, alle fraglichen Erweiterungen deinstallieren und dann Kunena neu installieren?
Oder reicht es, die Erweiterungen nur zu deaktivieren?

~okeo
Last edit: 3 years 10 months ago by okeo. Reason: Frage "Oder reicht es, die Erweiterungen nur zu deaktivieren?" hinzugefügt

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #4 by rich
Replied by rich on topic Probleme mit User-Definition

Wenn ich mir jetzt die Liste der Erweiterungen anschaue ("Erweiterungen: Verwalten") sehe ich neben 130 Einträgen von "Joomla! Project" und 17 von "Kunena Team", noch 28 Einträge anderer Autoren.
Ein paar von denen kann ich mir bekannten Funktionalitäten zuordnen, aber nicht alle.
Wie sollte ich da vorgehen? Kunena deinstallieren, alle fraglichen Erweiterungen deinstallieren und dann Kunena neu installieren?
Oder reicht es, die Erweiterungen nur zu deaktivieren?

17 Einträge von Kunena samt Sprachpaket sind in Ordnung. Wenn du andere Erweiterungen über die Verwaltung deaktivierst, sollte es reichen. Aber Vorsicht, dass du nicht etwas deaktivierst, was Joomla benötigt.

Übr.: Benutzer entsperren kann auch ein Admin und das sowohl im Front- als auch im Backend. Wenn du im Backend zu Kunena gehst und dort die Benutzer auswählst, siehst du auf der rechten Seite, ob jemand gebannt ist.
Aber ich glaube, dass bei dir der Fehler woanders liegt, es werden dir ja auch keine Kategorien angezeigt.

Es wäre interessant zu wissen, ob Joomla ordnungsgemäß funktioniert, oder ob es da schon Fehler gibt. Gehe mal zu „Erweiterungen -> Verwalten -> Überprüfen“ und kontrolliere ob da etwas angezeigt wird, was noch installiert werden muss. Als nächstes klicke auf den Reiter „Datenbank“ und schau, ob da alles in Ordnung ist (wenn nicht, auf „Reparieren“ klicken). Danach leere auch noch den Cache.
Versuche dann, Kunena nochmal zu installieren.

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #5 by okeo
Replied by okeo on topic Probleme mit User-Definition
Hallo,
nach dem ich die Prüfschritte gemacht habe (ohne Befund) und mich durch die Plugins etc gewühlt und teilweise deaktviert habe - ohne Erfolg, hatte ich die Faxen dicke und habe alles gelöscht (files und DB) und nochmal alles neu aus dem Backup wiederhergestellt. Eigentlich um dann das Update nochmal sauber einzupielen.
Ich habe jetzt also eine Kunena 2.0.3 auf einem Joomla! 2.5.8 (aus dem Jahr 2012 - gut abgehangen) und wollte gerade loslegen, da stelle ich fest, dass ich im Kunena auch hier alle User auf "Gebannt" stehen habe und kein Anwender als Moderator definiert ist.
(Ich müsste den Thread-Titel also ändern auf "Probleme mit User-Definition VOR Update")

Das kann eigentlich nicht der Stand sein, der bis vor kurzem live lief (wir hatten mehrere Moderatoren!). Aber ich weiß nicht, was da passiert ist. Backup und Restore habe ich mit XCloner gemacht. Vielleicht ist da was schiefgegangen ... Aber warum gerade nur die Benutzerverwaltung??? Alles andere ist ja da.

Es lassen sich übrigens auch in dem alten Stand keine Moderatoren setzen und auch keine Kategorien definieren ... <seufz>

--> Kann mir irgendjemand weiterhelfen? Erinnert sich noch wer an die gute alte Zeit vor 5 Jahren?


Jede Hilfe willkommen!

~okeo

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #6 by rich
Replied by rich on topic Probleme mit User-Definition
Ich habe beim Titel „nach Update“ entfernt, somit passt jetzt beides, egal ob der Fehler vor oder nach dem Update aufgetreten ist.

Backup und Restore habe ich mit XCloner gemacht. Vielleicht ist da was schiefgegangen ... Aber warum gerade nur die Benutzerverwaltung??? Alles andere ist ja da.

XCloner kenne ich nicht, aber ich halte allgemein nichts von solchen Tools. Aber zurück zu deinem Problem:
Mich irritiert nach wie vor deine Aussage „Es lassen sich übrigens auch in dem alten Stand keine Moderatoren setzen und auch keine Kategorien definieren
Die Liste der Kategorien hat nichts mit den Benutzern zu tun. Kannst du bitte ein Bildschirmfoto erstellen, damit ich weiß, was du meinst.
Überprüfe bitte auch in der Datenbank die Tabelle *_kunena_users. Theoretisch könnten durch einen fehlerhaften Datenbankwert alle Benutzer (auch Mods und Admins) gebannt sein. Im Bild ist es z.B. ein gesperrter Moderator. Mit dem Wert „NULL“ entsperrst du diesen wieder.
Attachments:

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #7 by okeo
Replied by okeo on topic Probleme mit User-Definition

rich wrote: Überprüfe bitte auch in der Datenbank die Tabelle *_kunena_users. Theoretisch könnten durch einen fehlerhaften Datenbankwert alle Benutzer (auch Mods und Admins) gebannt sein. Im Bild ist es z.B. ein gesperrter Moderator. Mit dem Wert „NULL“ entsperrst du diesen wieder.


Das war der entscheidende Tipp!
Ich hatte mich vorher nicht an die Spalte "gebannt" getraut und wusste auch nicht, welchen Wert ich statt der "00:00..." eintragen sollte.
Ein update auf NULL wirkte jetzt wunder: danach verhielt sich Kunena wie bekannt. Moderatoren ließen sich setzen/zuordnen. Auch die Kategorien waren wieder da.
Das Update von Joomla und Kunena auf den aktuellen Stand lief dann auch sauber durch.
Alles bestens!

Danke für die Hilfe, rich!

~okeo

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.441 seconds