×
Kunena 5.2 Beta 1 Released (Yesterday)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

Question Template Probleme nach update auf 5.0.3 von 4.x

More
3 years 10 months ago #1 by Swen
Moin zusammen,

bin scheinbar hier auch einer der geplagten mit vielen Template Problemen... Ich habe diverse Probleme mit dem Template und hoffe hier auf hilfe.

Leider habe ich aktuell kein Thema dazu gefunden und bootstrap ist auch aktiviert, dies hat ja die lage schon verbessert. Scheinbar beißt sich bei mir das Template von der Webseite mit dem von Kunena und wird wohl auch zum Teil überschrieben. Bilder sagen mehr als tausend Worte.

1. Problem sind die Buttons. Unsere Webseiten Buttons passen natürlich nicht mehr ins Konzept. Wie bekomme ich da die Kunena Buttons wieder?
2. Profilseite passt leider vorne und hinten nichts mehr. Auch wird ein Quote einfach über den Frame hinaus angezeigt. Wie schaffe ich da abhilfe?
3. Status anzeige funktioniert nicht. Ich kann auf meinem Profilbild klicken, aber es passiert nichts.

Siehe Attachments.

Vielen lieben Dank!
Attachments:

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #2 by rich
Den Bildern nach zu urteilen, handelt es sich um ein privates Forum. Ohne das Forum direkt zu sehen, ist es kaum möglich zu helfen.

Auch wird ein Quote einfach über den Frame hinaus angezeigt. Wie schaffe ich da abhilfe?

Geht die Quote auch über das Textfeld in Beiträgen hinaus? Wenn ja, versuche diesen Code in der custom.less ( siehe Bild ).:


.kmsgtext-quote {
    max-width: 50%;
}

Wenn es nur im Profil ist, kannst du auch diesen Code probieren (die richtige Prozentzahl musst du jeweils selbst ausfinden).

.layout#kunena blockquote {
    max-width: 50%;
}

Status anzeige funktioniert nicht. Ich kann auf meinem Profilbild klicken, aber es passiert nichts.

Überprüfe in der „Administration -> Kunena -> Plugins -> Kunena - Kunena Integration -> Grundeinstellungen“ ob dort das Kunena-Profil deaktiviert ist.

Bei den anderen Probleme kann ich dir (wie oben schon erwähnt) leider nicht helfen. Aber die Buttons wie früher im Template Blue Eagle (falls du das meinst) gibt es in Crypsis nicht mehr.

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #3 by Swen
Ja, da hast du recht. Leider ist es privat. Aber ich kann ja html und css von den buttons posten. Die Buttons können ruhig vom Kunena Theme kommen. Aber so im mix sieht das halt doof aus.
<li>
<a class="btn btn-success art-button" name="create" title="Ein neues Thema erstellen" rel="nofollow" href="/forum/Allgemeines/topic/create">
<a class="btn art-button" name="markread" title="Alle Beiträge in dieser Kategorie als gelesen markieren." rel="nofollow" href="/forum/Allgemeines/task-markread?0df75faf5ea220657e924dc1c6ef403a=1">
<a class="btn art-button" name="unsubscribe" title="Dieses Kategorieabonnement wieder beenden" rel="nofollow" href="/forum/Allgemeines/task-unsubscribe?0df75faf5ea220657e924dc1c6ef403a=1">
</li>

So sehen die Buttons html aus und das ist der code:
a.art-button, a.art-button:link, a.art-button:link:link, body a.art-button:link, a.art-button:visited, body a.art-button:visited, input.art-button, button.art-button {
    box-sizing: content-box;
    color: #000000;
    cursor: pointer;
    display: inline-block;
    font-family: Verdana,Geneva,Arial,Helvetica,sans-serif;
    font-size: 12px;
    font-style: normal;
    font-weight: normal;
    line-height: 14px;
    margin: 0 5px 0 0 !important;
    overflow: visible;
    position: relative;
    text-align: center;
    text-decoration: none;
    text-indent: 0;
    vertical-align: middle;
    white-space: nowrap;
}

Das Quote Problem werde ich mir anschauen. Danke für den Tipp.

Das User Profil ist klick bar, es werden die CSS Tags getoggelt, aber das Menü ist nicht sichtbar.

Mal eine andere Frage:

Kann ich auch Kunena getrennt von Joomla öffnen? Quasi um die ganze Theme Formatierung aus dem Weg zu gehen. Aktuell ist es ja embedded und führt ja dadurch auch zu Problemen.

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #4 by rich
Ich beantworte mal die zweite Frage zuerst. Kunena benötigt Joomla damit es geöffnet werden kann. Du kannst allerdings die meisten Erweiterungen welche Probleme machen, auf den Forenseiten deaktivieren.

Mit deinen Codes kann ich leider überhaupt nichts anfangen. Eventuell hast du ein Mitglied in deinem Forum, welcher css Erfahrung hat. Mit etwas Hilfe sollte es kein Problem sein, die gewünschten Anpassungen vorzunehmen.

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #5 by Swen
Das meiste an Erweiterungen, ist ja eigentlich das Template der Hauptseite. Genau das schießt ja quer in Kunena rein.
Ich habe CSS Erfahrung, hilft mir aber nicht, wenn ich 8h Code lesen muss.

Den Betreffenden Code habe ich hier gepostet. Deshalb sehen die Buttons genau so aus.

Wie kann ich also das CSS von Kunena siegen lassen oder muss ich mir hierfür ein eigenes HTML DOM mit CSS basteln?!

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago - 3 years 10 months ago #6 by rich

Das meiste an Erweiterungen, ist ja eigentlich das Template der Hauptseite. Genau das schießt ja quer in Kunena rein.

Ach so, das meintest du. Versuche es mal mit dem Template Protostar nur für Kunena. Dazu gehst du in der Administration zu den Menüs und ordnest jedem Menüpunkt, der etwas mit dem Forum zu tun hat, das Template Protostar zu. Dann könntest du auch „Bootstrap css laden“ wieder deaktivieren.

Attachments:
Last edit: 3 years 10 months ago by rich.

Please Log in or Create an account to join the conversation.

More
3 years 10 months ago #7 by Swen
Na das ist doch mal schön. Das funktioniert.

Vielen Dank dafür!

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.774 seconds