×
Kunena 5.2.6 released and Blue eagle 1.6.6 released (25 Jul 2021)

The Kunena team has announce the arrival of Kunena 5.2.6 [K 5.2.6] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.6

Solved [gelöst] Danke! Button in "Gefällt mir" umbennen!

More
7 years 3 months ago - 7 years 3 months ago #1 by Dirk Dittrich
Ich würde gern den Danke! Button in "Gefällt mir" haben.
Was habe ich zu tun um dies zu realisieren?

Ich nutze die neuste Kunena Version! Das Forum wird bei uns firmenintern genutzt. Der Danke! Button ist da eher nicht zutrefflich. Ein "Gefällt mir"stattdessen schon.

Kann mir jemand dabei einen Tipp geben? Einfach so umschreiben geht nicht. Hatte ich schon versucht. Man sieht zwar die Änderung dann, aber da werden die Klicks nicht im Profil gespeichert. Sie werden zwar unter dem Beitrag angezeigt, jedoch nicht zu den Beiträgen im jeweiligen Nutzerprofil geordnet.
Last edit: 7 years 3 months ago by Dirk Dittrich.

Please Log in or Create an account to join the conversation.

More
7 years 3 months ago - 7 years 3 months ago #2 by rich
Hier im zweiten Beitrag ist es genau beschrieben, wie es funktioniert. Bei dir sind folgende beide Codes, wonach du suchen musst und anschließend den Text ändern musst.
COM_KUNENA_BUTTON_MESSAGE_THANKYOU „Danke!“ zu „Gefällt mir!“
COM_KUNENA_THANKYOU „Folgende Benutzer bedankten sich“ zu „Folgenden Benutzern gefällt es“
Last edit: 7 years 3 months ago by rich.
The following user(s) said Thank You: Dirk Dittrich

Please Log in or Create an account to join the conversation.

More
7 years 3 months ago #3 by Dirk Dittrich
Ganz grosse Klasse rich!

So einfach hätte ich das nicht gedacht. Wirklich super Antwort!

Vielen vielen Dank! Oder auch Gefällt mir! :)

Please Log in or Create an account to join the conversation.

More
7 years 3 months ago - 7 years 3 months ago #4 by Dirk Dittrich
Hallo rich!

Mir ist etwas aufgefallen und ich habe mich nun schon seit 2 Stunden damit befasst. Habe alle Sprachdatein für Kunena vom Server geholt und angesehen. Kein Erfolg!

Im Backend ist es in der Suche nicht aufgeführt. Alle anderen Danke konnte ich erfolgreich umbenennen.

Kannst Du mir bitte sagen wo ich die Datei finde um das was man auf dem Screenshot sieht in Gefällt mir umzubenennen?



Danke im voraus!!!
Attachments:
Last edit: 7 years 3 months ago by Dirk Dittrich.

Please Log in or Create an account to join the conversation.

More
7 years 3 months ago - 7 years 3 months ago #5 by Dirk Dittrich
....und nun ist auch noch genau das passiert was ich nicht wollte. Durch irgendwas ist nun die Standardsprache englisch, obwohl im Backend Deutsch eingestellt ist. Ich weiss nicht wo ich noch suchen soll.

Ich sende den Bericht dazu. Ich hoffe das der Fehler der zu erkennen ist.
Ich habe den Link zur Seite gekürzt. Ich hoffe das darf man!

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 2M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : JSN_Dome_PRO | author: JoomlaShine.com | version: 2.3.2 | creationdate: Unknown

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.2 | creationdate: 2012-01-31

Kunena version detailed: Kunena 3.0.5 | 2014-03-09 [ Invecchiato ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: UddeIM 2.8

Third-party SEF components: None

Plugins: Search - Kunena Search 3.0.1 | Content - Kunena Discuss 3.0.1 | JomSocial - My Kunena Forum Menu 1.7.1

Modules: Kunena Latest 3.0.1 | Kunena Stats 3.0.1 | Kunena Login 3.0.1 | Kunena Search 3.0.1


Edit:
Konnte das Problem selber lösen. Habe deutsche Sprachdatei neu installiert.
Last edit: 7 years 3 months ago by Dirk Dittrich.

Please Log in or Create an account to join the conversation.

More
7 years 3 months ago #6 by rich

Ich habe den Link zur Seite gekürzt. Ich hoffe das darf man!

Wir können niemanden vorschreiben, welche Daten er für sich behalten will. Aber was unter „Confidential information“ im Konfigurationsbericht aufgelistet ist, hätten nur du und wir Moderatoren gesehen.

Es sind einige Dinge in deiner Konfiguration zu sehen, wodurch Fehler entstehen können.
Du verwendest das Kunena Template Blue Eagle 1.7.2. Solltest Blue Eagle 3.0.5 verwenden.

Gehe im Backend zu Kunena „Dashboard > Plugins“ und deaktiviere folgende Plugins:
Kunena - AlphaUserPoints Integration
Kunena - JomSocial Integration
Kunena - CommunityBuilder Integration
Es ist keine dieser Erweiterungen installiert.

Verwendest du Gravatars anstatt Avatars? Falls nicht, dann kannst du auch „Kunena - Gravatar Integration“ deaktivieren.

Weiters hast du auch das Plugin „JomSocial - My Kunena Forum Menu 1.7.1“ installiert (zu finden unter „Erweiterungen > Plugins“). Dieses kann komplett deinstalliert werden, es ist veraltet.

Vergiss bitte nicht, vor jeden Veränderungen (Installationen, Deinstallationen, usw..) vorher eine Sicherung (Backup) deiner Webseite anzulegen.
The following user(s) said Thank You: Dirk Dittrich

Please Log in or Create an account to join the conversation.

More
7 years 3 months ago - 7 years 3 months ago #7 by Dirk Dittrich
Grüss Dich!
Ich wusste nicht das nur ihr den kompletten Bericht lesen könnt. Ich wollte nur keine erhöhten Gäste verursachen. Ich habe mich nun für das von Dir empfohlenen Template entschieden und auch schon angepasst. Ich sende mal den Bericht nochmal mit. Diesmal komplett.

Die Frage aber zu meinen Eintrag von #4 hat sich dadurch aber nicht bereinigt. Was kann ich tun das auch dieses angepasst wird?

Danke rich!!!

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 2M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : JSN_Dome_PRO | author: JoomlaShine.com | version: 2.3.2 | creationdate: Unknown

Kunena default template details : Blue Eagle | author: Kunena Team | version: 3.0.5 | creationdate: 2014-03-09

Kunena version detailed: Kunena 3.0.5 | 2014-03-09 [ Invecchiato ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: UddeIM 2.8

Third-party SEF components: None

Plugins: Search - Kunena Search 3.0.1 | Content - Kunena Discuss 3.0.1 | JomSocial - My Kunena Forum Menu 1.7.1

Modules: Kunena Latest 3.0.1 | Kunena Stats 3.0.1 | Kunena Login 3.0.1 | Kunena Search 3.0.1

Last edit: 7 years 3 months ago by Dirk Dittrich.

Please Log in or Create an account to join the conversation.

More
7 years 3 months ago - 7 years 3 months ago #8 by rich

Die Frage aber zu meinen Eintrag von #4 hat sich dadurch aber nicht bereinigt. Was kann ich tun das auch dieses angepasst wird?

Ich dachte durch dein „Edit“, dass du das Problem erledigt hattest.

Die Codes für diese beiden, welche du geändert haben willst, befinden sich in einer .ini Datei für die Administration.
Gehe wie schon gehabt vor, aber nachdem du auf den Tab Overrides geklickt hast, wählst du rechts in dem Dropdownmenü die deutsche Sprache „German (DE CHAT) Administrator“ aus. Da findest du dann die richtigen Codes:
COM_KUNENA_LIB_STAT_TOP_THANKS
COM_KUNENA_STAT_THANKS_YOU_RECEIVED

Wichtig! nachdem du den Text geändert hast, musst du vor dem Speichern unter dem Textfeld bei „Für beide Bereiche“ ein Hakerl rein machen, da ansonsten diese Änderung nur für den Backendbereich gelten würde.
Last edit: 7 years 3 months ago by rich.
The following user(s) said Thank You: Dirk Dittrich

Please Log in or Create an account to join the conversation.

More
7 years 3 months ago #9 by Dirk Dittrich
Du bist ein Traum richi!!!!

Vielen vielen Dank für Deine Hilfe!!!

Please Log in or Create an account to join the conversation.

More
7 years 3 months ago - 7 years 3 months ago #10 by rich
Gern geschehen! :)

Ach ja, ich hatte vergessen zu erwähnen, dass durch das Auswählen „Für beide Bereiche“, zwei Overrides (Überschreibungen) erstellt werden. Eine für das Back- und eine für das Frontend.
In „German (DE-CHAT) - Administrator“ und in „German (DE-CHAT) - Site“. Falls du im Backend diese Änderung nicht benötigst, kannst du das Override in „German (DE-CHAT) - Administrator“ anschließend auch wieder löschen.
Last edit: 7 years 3 months ago by rich.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.338 seconds