×
Blue Eagle 5 v1.6.2 has been Released for Kunena 5.2 (20 Jan 2021)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.6.2 which is now available for download. This version addresses most of the issues that were discovered in development.

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with

Bug [beendet] Kunena Migration in Joomla 3.2.2

More
7 years 1 week ago #1 by Kletter Paule
Ich habe meine Joomla von 1.5 auf 3 umgestellt. Aktuelle Version Joomla 3.2.2
Kunena Version auf Joomla 1.5 ist 1.7.2
Kunena Version auf Joomla 3.2.2 ist 3.0.4
Leider werden die Inhalte nicht in die neue Joomla migriert.
Gibt es jemand mit Erfahrungswerten?
Die Migration ist folgender Maßen verlaufen.
1. neue Installation Joomla 3
2. Exportieren der Datenbanktabellen.
3. umbenennen des alten Präfix in den Neuen.
4. Importieren der Datenbanktabellen in die neue Joomla
5. Installieren der neuen Kunena 3.0.4 als Update.
6. Fehlschlag keine Daten wurden übernommen.
Was geht sind die Benutzer und deren Avatare, nein die Avatare sind zwar in Medien gespeichert aber werden von Kunena nicht verwendet.

Wäre toll wenn wir eine Lösung finden könnten, es wäre sehr Mühselig die 2500 Beiträge per Hand zu übertragen.....

Nach ersten Nachfragen habe ich folgende weitere Schritte unternommen:


Ich habe mit dem Tool Migratme die Kunena Tabellen migriert.
Wie ich sehen kann sind alle Userdaten und die Beiträge übernommen worden.
Allerdings nicht die Kategorien des Forum.
Nun habe ich die Kategorien per Hand neu eingerichtet und sie spiegelgleich mit den IDs der alten Seite versehen.
Doch die Inhalte werden im Forum nicht angezeigt.
Wenn ich nun eine Kategorie auswähle und mir anzeigen lassen möchte bekomme ich den Hinweis:
Zugriff verweigert
Du hast keine Berechtigung, um diese Seite zu betreten!

Irgendwie habe ich das Gefühl dem Forum muss erst noch gesagt werden wo es die Daten abholen soll um sie im Frontend anzuzeigen. Das sie da sind weiß ich. Wenn ich auf die Userliste gehe und einen einzelnen User anklicke, sehe ich die bereits verfassten Beiträge des User.
Die Avatare werden auch nicht dargestellt, sind aber vorhanden.

Klingt recht verworren aber ich bin guter Hoffnung ihr habt eine gute Lösung!
Vielen Dank im Vorraus!

Please Log in or Create an account to join the conversation.

More
7 years 1 week ago #2 by rich

Nun habe ich die Kategorien per Hand neu eingerichtet und sie spiegelgleich mit den IDs der alten Seite versehen.

Dieser Schritt dürfte falsch gewesen sein.
Wenn ich dich richtig verstanden habe, dann sind deine Benutzer aus Joomla 1.5 in Joomla 3.2 alle wieder vorhanden.

Bitte deinstalliere Kunena wieder und entferne danach alle Daten mit pref_kunena aus der Datenbank.
Importiere anschließend die Kunena Tabellen von der alten Kunena Installation in deine neue Joomla Installation (diesen Vorgang hattest du ja schon mal gemacht). Danach installiere Kunena erneut.

Jetzt hast du zwar wieder den Zustand, dass dir keine Kategorien angezeigt werden, aber das liegt daran, dass Joomla 3.x eine andere Benutzerverwaltung hat. Und jetzt beginnt die Handarbeit. Du musst in der Kunena Kategorieverwaltung die Rechte für jede Kategorie einzeln wieder neu vergeben. Wahrscheinlich sind alle auf „Nobody“ gesetzt, das bedeutet, dass niemand Zugriff darauf hat. Deshalb kannst du die Kategorien nicht sehen.
The following user(s) said Thank You: Kletter Paule

Please Log in or Create an account to join the conversation.

More
7 years 1 week ago #3 by Kletter Paule
Vielen Dank Problem gelöst!

Bis auf die Avatare sind alle Inhalte sichtbar.
Die Avatare liegen im Verzeichnis fbfiles/avatars.
Wie bekomme ich Kunena dazu, diese auch abzurufen?

Please Log in or Create an account to join the conversation.

More
7 years 1 week ago #4 by rich

Die Avatare liegen im Verzeichnis fbfiles/avatars.

Kunena 3.0 hat neue Pfade für Bilder und auch Avatars. Kontrolliere bitte mal die
Ordner in „/media/kunena/avatars“. Eventuell musst du sie erst dort hinein kopieren.

Please Log in or Create an account to join the conversation.

More
7 years 5 days ago #5 by Kletter Paule
Die neuen Ordner für die Avatare habe ich gefunden und die Avatare hinein kopiert. Allerdings werden Sie vom Forum nicht erkannt.
Wenn ich ein neues Avatar anlege dann wird dieses in den Ordner abgespeichert und alles ist ok. Mit den alten kopierten Avataren geht es nicht.
Der Pfad ist media/kunena/avatars/users

Please Log in or Create an account to join the conversation.

More
7 years 5 days ago #6 by rich
Ich habe dir jetzt mal den Pfad (hier von meinem Avatar) mit Firebug herauskopiert. Er sollte ungefähr so aussehen:
/media/kunena/avatars/resized/size144/users/avatar2198.png

Werden bei dir Platzhalter anstelle der Avatars angezeigt? Dann könntest du mit einem Rechtsklick darauf den richtigen Pfad herausfinden. Kopiere mal ein Avatar in den Ordner „size144“ und überprüfe, ob es angezeigt wird.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.082 seconds