×
Blue Eagle 5 v1.6.2 has been Released for Kunena 5.2 (20 Jan 2021)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.6.2 which is now available for download. This version addresses most of the issues that were discovered in development.

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with

Solved [gelöst] 500 Internal Server Error Fatal Error was detected! Fatal Error: Call to a member function get() on a non-object in components/com_content/router.php on line 27

More
7 years 5 months ago - 7 years 5 months ago #1 by Mamenchi

500 Internal Server Error
Fatal Error was detected!

Fatal Error: Call to a member function get() on a non-object in components/com_content/router.php on line 27

The error was detected in the Content Component.


Hallo allerseits

ich habe Kunena nun auf die neueste Version geupgradet

nun mein Problem: alles Funktioniert, aber nur die Forenlinks/index

Ich kann alte Poste lesen, auf sie Antworten, aber sobald ich auf Index oder ähnliches Klicke, kommt diese Fehlermeldung

Liegt es an dem Community Builder Plugin? Das habe ich auch auf den neuesten Stand gebracht.

Bevor ich meine HP auf den alten Stand zurücksetze, meine Frage:
Was läuft falsch bzw. was sollte ich deaktivieren? Vielleicht gibts ja auch eine einfache Lösung ^^ Danke schon mal


This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 50000 seconds | Max execution memory: 90M | Max file upload: 40M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : ALLROUNDER-j1.6 | author: Juergen Koller | version: RC4.1 | creationdate: Unknown

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.0 | creationdate: 2011-08-29

Kunena version detailed: Kunena 3.0.2 | 2013-08-18 [ Nocturne ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 1.9

Third-party SEF components: None

Plugins: Search - Kunena Search 3.0.1 | Content - Kunena Discuss 3.0.1 | JomSocial - Kunena Groups 1.6.4

Modules: Kunena Latest 3.0.1 | Kunena Stats 3.0.1 | Kunena Login 3.0.1 | Kunena Search 3.0.1

Last edit: 7 years 5 months ago by Mamenchi. Reason: gelöst

Please Log in or Create an account to join the conversation.

More
More
7 years 5 months ago - 7 years 5 months ago #3 by Mamenchi
vielen dank für den link

hat mir google vor 1 Std. nicht ausgeworfen

hatte aber datenbank reparieren schon vorher gemacht und jetzt nochmal

hat leider nix gebracht :(

also wenn ich auslogge, kann ich aufs forum zugreifen bzw. index und was weiss ich klicken

wenn ich eingeloggt bin, geht alles, also index und so oder auch der direkte foren link

www.unser-donauwoerth.de/Joomla/index.ph...in-deiner-stadt.html

wenn ich einlogge, kommt dieser o.g. Fehler :(
Last edit: 7 years 5 months ago by Mamenchi.

Please Log in or Create an account to join the conversation.

More
7 years 5 months ago - 7 years 5 months ago #4 by rich
485	unser Forum	1	view=category&catid=0&layout=list	unser-forum

Diesen Menüpunkt solltest du ändern, da er Fehler verursachen könnte. Siehe hier, was grundsätzlich zu beachten ist: www.kunena.org/docs/Men%C3%BCprobleme

Dann solltest du das veraltete Plugin „JomSocial - Kunena Groups 1.6.4“ deinstallieren,
weiters die folgenden drei Plugins deaktivieren, da diese Erweiterungen nicht installiert sind.
Kunena - AlphaUserPoints
Kunena - JomSocial
Kunena - UddeIM

Dann in der Administration unter „Kunena > Templates“ das Template Blue Eagle 2.0 Version-3.0.2 auswählen und danach teste bitte erneut.

Nachtrag:
Auch dein Joomla Template gehört aktualisiert für Joomla 2.5.
Last edit: 7 years 5 months ago by rich.
The following user(s) said Thank You: Mamenchi

Please Log in or Create an account to join the conversation.

More
7 years 5 months ago #5 by Mamenchi
deaktivieren=deinstalliert? weil einen deinstall button hab ich keinen gefunden, oder meint man damit löschen per FTP?

Template hab ich geändert

und die Plugins deaktiviert

Das mit dem Menüproblem kapiere ich leider nicht. habe wiederherstellen gedrückt und so aber wie ich den link ändere?

Zudem: was meinen die mit

Kunena-Menü komplett neu erstellen

Eine einfache Methode ist es, sämtliche Menüpunkte zu löschen und wieder neu zu erstellen.


wie lösche ich die Menüpunkte? meinen die

Menüs: Menüeinträge


vielen dank nochmal

funzt leider immer noch nicht :( auch wenn vorhin einmal der index funktioniert hat, war aber ein bug und hat nur 1x funktioniert :(

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 50000 seconds | Max execution memory: 90M | Max file upload: 40M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : ALLROUNDER-j1.6 | author: Juergen Koller | version: RC4.1 | creationdate: Unknown

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 3.0.2 | creationdate: 2013-08-18

Kunena version detailed: Kunena 3.0.2 | 2013-08-18 [ Nocturne ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 1.9

Third-party SEF components: None

Plugins: Search - Kunena Search 3.0.1 | Content - Kunena Discuss 3.0.1 | JomSocial - Kunena Groups 1.6.4

Modules: Kunena Latest 3.0.1 | Kunena Stats 3.0.1 | Kunena Login 3.0.1 | Kunena Search 3.0.1

Please Log in or Create an account to join the conversation.

More
7 years 5 months ago #6 by rich

deaktivieren=deinstalliert?

Es ist nicht das selbe, deaktivieren bedeutet lediglich deaktivieren (unveröffentlichen), aber nicht entfernen und deinstallieren bedeutet, es über die Joomla Verwaltung „Erweiterungen > Eweiterungen > Verwalten > Deinstallieren“ zu entfernen. deshalb hatte ich es auch so differenziert geschrieben.
Dieses Plugin musst du noch deinstallieren: JomSocial - Kunena Groups 1.6.4

Zudem: was meinen die mit
Kunena-Menü komplett neu erstellen

Du solltest auch nicht das Menü neu erstellen, sondern ich hatte geschrieben „Siehe hier, was grundsätzlich zu beachten ist: www.kunena.org/docs/Men%C3%BCprobleme“. Das ist der erste Absatz im Wiki und erklärt, wie du Links zu Kunena in anderen Menüs anlegen sollst. Das betrifft nur den einen Menüpunkt „User Forum“ im Topmenü.



Dein Joomla Template ist nicht auf dem neuesten Stand, du benutzt noch immer die veraltete RC Version. Äktualisiere bitte auch dieses Template und wenn der Fehler weiterhin besteht, dann teste mit dem Joomla Template Beez 20. Während einer Fehlersuche sollten grundsätzlich die Joomla und Kunena Standard-Templates verwendet werden.
Attachments:
The following user(s) said Thank You: Mamenchi

Please Log in or Create an account to join the conversation.

More
7 years 5 months ago - 7 years 5 months ago #7 by Mamenchi
ja template habe ich geupdated, der log ist nur vor update, aber hatte eh auf das Beez dingens umgestellt, problem ist nach wie vor da

ich werde dann noch deinstallieren und melde mich wieder

edit: ok mal weiter rummgespielt ^^

keine Besserung

es muss ja fast was mit meinen loginmodulen zu tun haben?

also hab CB Login
FB Login
Joomla Login
und Kunena Login

Normalerweise sollte das FB und CB Login alles andere überschreiben, hab die anderen plugins glaub ich sogar deaktiviert

seltsam ist halt, daß das Forum und alle Links so wie früher funktionieren, sobald ich nicht eingeloggt bin

Unzulässige Menüpunkte 1
/2011-07-01-13-17-22 (1: 484) index.php?Itemid=474 Unveröffentlicht


das ist die einzige Fehlermeldung im Backend speziell Kunena

und

Community - Kunena Groups Aktualisierung Plugin 2.0.4 community Site update.kunena.org/2.0/plg_community_kunenagroups.xml


die ich nicht updaten kann

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 50000 seconds | Max execution memory: 90M | Max file upload: 40M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : ALLROUNDER-j1.6 | author: Juergen Koller | version: 1.4 | creationdate: Unknown

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 3.0.2 | creationdate: 2013-08-18

Kunena version detailed: Kunena 3.0.2 | 2013-08-18 [ Nocturne ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 1.9

Third-party SEF components: None

Plugins: Search - Kunena Search 3.0.1 | Content - Kunena Discuss 3.0.1 | JomSocial - Kunena Groups 1.6.4

Modules: Kunena Latest 3.0.1 | Kunena Stats 3.0.1 | Kunena Login 3.0.1 | Kunena Search 3.0.1

Last edit: 7 years 5 months ago by Mamenchi.

Please Log in or Create an account to join the conversation.

More
7 years 5 months ago #8 by rich

Unzulässige Menüpunkte 1
/2011-07-01-13-17-22 (1: 484) index.php?Itemid=474 Unveröffentlicht

das ist die einzige Fehlermeldung im Backend speziell Kunena

Lösche bitte diesen Menüpunkt komplett, auch aus dem Papierkorb.

Community - Kunena Groups Aktualisierung Plugin 2.0.4 community Site update.kunena.org/2.0/plg_community_kunenagroups.xml

Dieses Plugin solltest du ja deinstallieren. Es ist immer noch vorhanden. Suche in der Joomla Verwaltung, wo du deinstallieren kannst, nach einem Plugin „Kunena Groups“ Version 1.6.4


Den Link im Topmenü „Unser Forum“ hast du ebenfalls noch nicht repariert. Gehe in der Administration in dieses Topmenü, klicke auf „Unser Forum“ und danach bei Menütyp auf „Auswählen“. Danach wählst du (wie auf dem Bild in meinem vorigen Beitrag) den Menüeintrag „Menüeintrag-Alias“.
The following user(s) said Thank You: Mamenchi

Please Log in or Create an account to join the conversation.

More
7 years 5 months ago #9 by Mamenchi
hmpf

also hatte das Plugin wirklich deinstalliert, aber die update meldung kam trotzdem

grad nochmal deinstalliert und jetzt ist das Plugin weg aber nichts liegt im Papierkorb, kommt die Meldung, erst Eintrag auswählen

habe das mit dem Alias auch geändert, jetzt kommt eine reine Joomla Fehlermeldung ohne Kunena Farbe und so

Fatal error: Call to a member function get() on a non-object in /homepages/21/d373220770/htdocs/Joomla/components/com_content/router.php on line 27

einziger Unterschied: nun kommt ein neuer User (also nicht registriert) nicht ins Forum sondern zur Registrationsmaske

This message contains confidential information

Database collation check: The collation of your table fields are correct

Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 50000 seconds | Max execution memory: 90M | Max file upload: 40M

Kunena menu details:

Warning: Spoiler!

Joomla default template details : ALLROUNDER-j1.6 | author: Juergen Koller | version: 1.4 | creationdate: Unknown

Kunena default template details : Blue Eagle 2.0 | author: Kunena Team | version: 3.0.2 | creationdate: 2013-08-18

Kunena version detailed: Kunena 3.0.2 | 2013-08-18 [ Nocturne ]
| Kunena detailed configuration:

Warning: Spoiler!
| Kunena integration settings:
Warning: Spoiler!
| Joomla! detailed language files installed:
Warning: Spoiler!

Third-party components: CommunityBuilder 1.9

Third-party SEF components: None

Plugins: Search - Kunena Search 3.0.1 | Content - Kunena Discuss 3.0.1

Modules: Kunena Latest 3.0.1 | Kunena Stats 3.0.1 | Kunena Login 3.0.1 | Kunena Search 3.0.1

Please Log in or Create an account to join the conversation.

More
7 years 5 months ago - 7 years 5 months ago #10 by Mamenchi
kann man hier garkeine PMs schicken?

hab dir mal nen testacc gemacht mit "gelöscht" daß die Fehlermeldung auch siehst

Soll ich mal Joomla upgraden auf 3.15 und wenn das auch alles nichts bringt ein Backup einspielen?

Die Seite ist ja jetzt nicht so wichtig, aber hätte schon gern eine Funktionierende :(

edit: habe nochmal die neue Fehlermeldung gegoogelt

Fatal error: Call to a member function get() on a non-object com_content/router.php on line 27

und ne neue Lösung gefunden

Lösung in dem Sinne, daß ich das Caching überprüft habe und deaktiviert, in einem Anflug von Größenwahn scheine ich dieses im Zuge dieses Updates auch aktiviert zu haben :(

Also Cache gelöscht und Caching deaktiviert: alles Läuft wieder wie es soll

Sorry war mir echt Entgangen, dachte Caching ist was tolles :(

Vielen vielen Dank für deine unermüdliche Hilfe!!!
Last edit: 7 years 5 months ago by Mamenchi.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.802 seconds