×
Kunena 5.1.14 Released - Security release (13 Aug 2019)

The Kunena team is proud to announce the arrival of Kunena 5.1.14 [K5.1.14] which is now available for download as a native Joomla extension for Joomla 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.14. This update fixed 1 security issue.

× This category contains miscellaneous, uncategorised third-party extensions (e.g. JomSocial, Community Builder, etc.) relating to older versions of Kunena that are no longer supported.

This category may also contain a few topics relating to K 1.6 that may have been moved here possibly by mistake.

The topics in this category are for historical interest only. Owing to the structural differences between K 1.6 and K 1.7, the ideas in these topics may not work with later versions and, for that reason, the topics are locked.

Question Forum name disappears or RSS link not working

More
9 years 3 days ago #1 by Philip Roy
I've updated two sites on the same server to Kunena 160 b3620 and at the same time, updated sh404SEF to sh404SEF 2-1-5-746. Mostly the sites are working as I would hope, but the main link on the entry page for RSS creates an error.

If you go to....

www.nzmac.com/forum/

The RSS link at the bottom of the page is....

www.nzmac.com/?func=rss

...which creates an error.

sh404SEF is currently taking control of rewriting the URLs for the forum and I've always had it like this. If I set sh404SEF to not use its plugin but to use the component or core rewriting, then the RSS link starts to work *BUT* the links to all the categories loose the word "forum", so a category link becomes www.nzmac.com/general-discussion.html instead of what it should be www.nzmac.com/forum/general-discussion/

Not sure if I have a Kunena problem or a sh404SEF problem?

Thanks in advance.

Cheers,

Phil

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 120 seconds | Max execution memory: 36M | Max file upload: 10M

Kunena version detailled: Installed version: 1.6.0 | Build: 3620 | Version name: Spika | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Disabled or not installed | Jomsocial: Installed (Version : 1.8.8) | UddeIm: Disabled or not installed

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Enabled | JFirePHP: Disabled or not installed | Kunena Discuss: Disabled or not installed | Kunena Search: Disabled or not installed | My Kunena Forum Menu: Disabled or not installed

Modules: Kunena Latest: Enabled (Version : 1.6.0-RC2) | Kunena Stats: Disabled or not installed | Kunena Login: Disabled or not installed

Please Log in or Create an account to join the conversation.

More
9 years 3 days ago #2 by xillibit
Hello,

Try to disable the sh404sef rewrite for kunena or use the default sef system integrated into Joomla!

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
9 years 3 days ago #3 by Philip Roy
I had a setting different on my test site, but now with the default Joomla SEF running things seem to be working better....although two things...

1. The rss feed for the forum is www.nzmac.com/rss.html
Why does it not have /forum/ in the middle? It looks like the link represents the RSS feed for the entire site the way it is being created.

2. After resorting to the Joomla SEF, the "Add topic" button in categories isn't working.....the one I highlight in the image. The "New topic" tab above works fine.





Phil
Attachments:

Please Log in or Create an account to join the conversation.

More
9 years 1 day ago #4 by Matias
OK, so there seems to be some issues with sh404SEF plugin for Kunena 1.6 (older plugin wont work).

I've seen missing forum before, with Joomla SEF. I have no idea what caused it, but I've not seen it lately.

Are all links missing /forum?

Please Log in or Create an account to join the conversation.

More
9 years 1 day ago #5 by Philip Roy
Hi there, there are two different situations I am experiencing...

Using core joomla SEF
* Rss works but doesn't have 'forum' in URL
* Categories and all posts missing 'forum' in URL
* New topic issue as discussed previously

Using sh404 SEF
* Rss does not work and doesn't include 'forum' in URL
* Categories and posts all contain 'forum' in URL


I've always preferred using sh404SEF and other than the RSS feed not working, I would still be using it.

Cheers,

Phil

Please Log in or Create an account to join the conversation.

More
9 years 1 day ago #6 by Matias
You need to contact author of sh404SEF and ask support from them. I would be glad to help them to fix their issues, but i have no idea who to contact and how.

Please Log in or Create an account to join the conversation.

More
9 years 1 day ago #7 by Philip Roy

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago #8 by gabbo
I have the same problem, actually my RSS Feed from kunena doesn´t works and the Thanks button neather... What can i do to solve it?

My site is: www.clubhipotecario.com.mx/foros-del-club-hipotecario/

Is important to say that if i disable the component SH404SEF Still the RSS doesn´t works and send me an error page with something like this

Error de lectura XML: declaración de texto o XML en un lugar distinto del principio de la entidad
Ubicación: www.clubhipotecario.com.mx/foros-del-club-hipotecario/rss.html
Número de línea 1, columna 2: <?xml version="1.0" encoding="UTF-8"?>
-^

Please Log in or Create an account to join the conversation.

More
8 years 11 months ago #9 by Philip Roy
Hi,

sh404sef version 2.1.7.761 has been released and solves the issues for me.

Cheers,

Phil

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.143 seconds