×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× This category contains miscellaneous, uncategorised third-party extensions (e.g. JomSocial, Community Builder, etc.) relating to older versions of Kunena that are no longer supported.

This category may also contain a few topics relating to K 1.6 that may have been moved here possibly by mistake.

The topics in this category are for historical interest only. Owing to the structural differences between K 1.6 and K 1.7, the ideas in these topics may not work with later versions and, for that reason, the topics are locked.

Question Can not logout from the forum!

More
9 years 10 months ago - 9 years 10 months ago #1 by alsvieira
Hello,

I am using CB 1.2.3 and CB login integrated with Kunena but when I try to logout from the kunena profilebox I can not. I always return to the forum and stay logged in!

Whe I click on the logout button it is "connected" to "index.php?option=com_kunena" . I think this is why it always return to the forum. I must change it, I think, for something like this "index.php?option=com_comprofiler&task=logout" or "index.php".

Can someone tell me were can I change the related links to logout button on profilebox or help me with other solution?

I am using RC2 and the default template.

Thanks

Best REgards
Last edit: 9 years 10 months ago by alsvieira.

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #2 by Hurr1c4n3
Have you set the right option in the backend of your site?



Go to the Kunena configuration and then the tab "Integration" and set it to CB.
Attachments:

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #3 by alsvieira
Hurr1c4n3, I already had the CB integration selected in the Kunena Configuration, but I can not logout via logout button on the kunena profile!

Any more sugestions/help please.

Best Regards

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #4 by Matias
Are you using default template? If not, that template needs a minor update.

Please Log in or Create an account to join the conversation.

More
9 years 9 months ago #5 by bunglehaze
I am having a similar problem with 1.6 and the default temnplate but Jomsocial based login integration. If I log in and out via jomsocial it is fine but when I have the login box up in kunena (or indeed any other login module) it seems kunena does not clear the page properly and looks like you are still logged in.

If you clear the browser cache the logn clears but obviously this is no use.

regards

leigh

Please Log in or Create an account to join the conversation.

More
9 years 9 months ago #6 by alsvieira

Matias wrote: Are you using default template? If not, that template needs a minor update.


Yes I am using the default template

Please Log in or Create an account to join the conversation.

More
9 years 9 months ago - 9 years 9 months ago #7 by viper_iii
I also have a similar error..

Site Template is older Chomotophore Template from Rockettheme... but is 1.5 native version.

When I logout of Kunena it get a blank page with just Kunena Login section without css...

Using Core SEF Urls. Seems that there are some sef issues...
Mine might be another plugin...

Uddiem at this point causing it I believe...

Yup....

Went to Cb_login modules...
changed to no integrations and no Private messaging installed.

logged out worked fine..

Re-enabled both and now working... figures... but did do an upgrade of Uddeim while I was logged in as well..

also have JFusion installed and disabled the plugins so not sure which one fixed the issue...


JFUSION... DISABLE PLUGINS and everything seems fine...
at least for me... argh... knew that one was causing problems!!!
Last edit: 9 years 9 months ago by viper_iii.

Please Log in or Create an account to join the conversation.

More
9 years 9 months ago #8 by sozzled
alsvieira: I suggest you ask for help from our good friends at Joomlapolis .

User registration, login, logout functions are not Kunena functions.

Please Log in or Create an account to join the conversation.

More
9 years 8 months ago - 9 years 8 months ago #9 by alsvieira
Thanks for the advice sozzled, I discover that the problem was from Sh404Sef. I set it up to no cache in comprofiler and everything is working. thanks for your help.

Take Care ;)
Last edit: 9 years 8 months ago by alsvieira.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.388 seconds