×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× This category contains miscellaneous, uncategorised third-party extensions (e.g. JomSocial, Community Builder, etc.) relating to older versions of Kunena that are no longer supported.

This category may also contain a few topics relating to K 1.6 that may have been moved here possibly by mistake.

The topics in this category are for historical interest only. Owing to the structural differences between K 1.6 and K 1.7, the ideas in these topics may not work with later versions and, for that reason, the topics are locked.

Question How to add forum directory before post in URLs

More
9 years 10 months ago #1 by FellowFishermen
I just upgraded sh404SEF and Kunena to the latest versions. My URLs are in this format:

www.site.com/post-title.html

instead of:

www.site.com/forum/post-title.html



What am I doing wrong? How do I make the Kunena URLs have the /forum/ directory?

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago - 9 years 10 months ago #2 by sozzled
FellowFishermen wrote:

How do I make the Kunena URLs have the /forum/ directory?

Get rid of sh404SEF ;) See also, Why would I need ANY third-party SEF plugin?
Last edit: 9 years 10 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #3 by FellowFishermen
Not an option, I have several custom components which depend on sh404SEF.

This can't be tough to do, is there a router file I can edit?

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago - 9 years 8 months ago #4 by Matias
1) Do not use Kunena 1.0.x plugin in sh404SEF
2) Make sure that Kunena is not your front page

Those are the most common mistakes. :)

Other than that I'm not sure what to do. do you have latest version of the SEF component?
Last edit: 9 years 8 months ago by Matias.

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #5 by FellowFishermen
Joomla 1.5.15, Kunena is not home page, latest release of sh404SEF. There are no Kunena plugins in the sef_ext folder of sh404SEF. I've even deleted the menu item and created a new one and deleted all of sh404SEF's URLs related to Kunena.

The site is JoomlaDigger.com if you want to see it in action.

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #6 by Matias
Those URLs are actually working. It reminds me from a Joomla SEF bug(?) where itemid gets lost. Can you see non-sef urls from sh404SEF? How does the forum url look like?

And btw: your urls should look like /support/, not /forum/..

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago - 9 years 10 months ago #7 by FellowFishermen
The sh404SEF URL for the main menu item is 'support.html' and its real URL is 'index.php?option=com_kunena&Itemid=332&lang=en'

You are correct about /support/ instead of /forum/, I was just trying to make it easier to understand.


EDIT:

I don't think it is an Itemid bug, the proper main menu item is always properly selected.
Last edit: 9 years 10 months ago by FellowFishermen.

Please Log in or Create an account to join the conversation.

More
9 years 9 months ago #8 by steel
i want my forum to be located on
www.znanost.com/forum
instead of
www.znanost.com/component/kunena/

but how do i do this without any plugins?

plese help, thank you.

Please Log in or Create an account to join the conversation.

More
9 years 9 months ago #9 by sozzled
@ steel: are you using any plugins, now?

Please Log in or Create an account to join the conversation.

More
9 years 9 months ago #10 by steel
i am not using any SEF plugins at the moment, just a joomla built-in SEF turned on in global configuration.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.090 seconds