Kunena 6.3.1 released

The Kunena team has announce the arrival of Kunena 6.3.1 [K 6.3.1] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3

This category contains miscellaneous, uncategorised third-party extensions (e.g. JomSocial, Community Builder, etc.) relating to older versions of Kunena that are no longer supported.

This category may also contain a few topics relating to K 1.6 that may have been moved here possibly by mistake.

The topics in this category are for historical interest only. Owing to the structural differences between K 1.6 and K 1.7, the ideas in these topics may not work with later versions and, for that reason, the topics are locked.

Question [file]CB tab for Kunena

More
15 years 3 months ago - 15 years 3 months ago #1 by carsten888
I needed a CB tab to work with Kunena. I had an old simpleboard-tab, which worked fine with Fireboard 1.0.4 Stable. I just installed Kunena and the plugin works fine except for the option 'threaded/flat'-view, which in the latest versions of Fireboard was integrated in those tabs above the forum header. I did not manage to rip that out.

I could not find it anywhere online, so could not post a link, so I attached the CB plugin in this post.

Note: this is for:
JOOMLA 1.0.15
community builder 1.1

It need language vars. Just paste the underneath vars in file:
components/com_comprofiler/plugin/language/default-language/default-language.php
Code:
DEFINE('_UE_KUNENA_TABTITLE', 'Forum Settings' ); DEFINE('_UE_KUNENA_ORDERING_OLDEST', 'Oldest post first' ); DEFINE('_UE_KUNENA_ORDERING_LATEST', 'Newest post first' ); DEFINE('_UE_KUNENA_ORDERING_TITLE', 'Message ordering' ); DEFINE('_UE_KUNENA_SIGNATURE', 'Your signature' ); DEFINE('_UE_KUNENA_VIEWTYPE_FLAT', 'View flat' ); DEFINE('_UE_KUNENA_VIEWTYPE_THREADED', 'View threaded' ); DEFINE('_UE_KUNENA_VIEWTYPE_TITLE', 'Preferred viewtype' ); DEFINE('_UE_KUNENA_TABDESC', 'General profile options' );
I hope this is helpfull to anyone. :)

File Attachment:

File Name: plug_cbsim...dtab.zip
File Size:7 KB
Attachments:
Last edit: 15 years 3 months ago by carsten888.

Please Log in or Create an account to join the conversation.

More
15 years 3 months ago #2 by Baze
Replied by Baze on topic Re:[file]CB tab for Kunena
i get this error when i try to install it:

The directory in which the plugin should install does not exist: probably the parent extension is not installed. Install parent extension first. Plugin parent directory missing: "/server here/components/com_comprofiler/plugin/user/plug_cbfireboard/joomlaboard/" and plugin directory specified by installer for installation "/server here/components/com_comprofiler/plugin/user/plug_cbfireboard/joomlaboard/simpleboardtab/"

Please Log in or Create an account to join the conversation.

More
15 years 3 months ago #3 by sozzled
Replied by sozzled on topic Re:[file]CB tab for Kunena
The "missing directory on installation" problem is a relatively simple one to fix. Assuming that you're trying to install the CB tab plugin for Kunena 1.0.8 , create the following directories

/components/com_comprofiler/plugin/user/plug_cbkunena/
/components/com_comprofiler/plugin/user/plug_cbkunena/joomlaboard

then install the plugin from the Community Builder plugin installation control panel.

Please Log in or Create an account to join the conversation.

More
15 years 3 months ago #4 by Baze
Replied by Baze on topic Re:[file]CB tab for Kunena
Thanks! it works now ;)

Please Log in or Create an account to join the conversation.

More
15 years 1 month ago - 15 years 1 month ago #5 by sozzled
I had, until recently, relied upon the CB forum tab referred to in this discussion. It works fine, even with a bit of fiddling during the installation, to provide users of Community Builder with a profile tab with information about their Kunena forum material. So far so good ... until recently when I tried to add new CB data fields and then all hell broke loose.

Attempting to add a new field resulted in a "500 Internal server error". The Joomlapolis website was totally inadequate in tracking down the source of this error - in fact, all previous discussions with "500 Internal server error" have been locked. We can only speculate on the reasons for that.

Not only was it not possible to add a new field, attempts to run the built-in Check Community Builder User Fields Database tool likewise resulted in the same "internal server error".

I've been able to track down the cause of this problem - but it took me several days:

Fatal error: Cannot redeclare class CBfield_forumstats in ..\components\com_comprofiler\plugin\user\plug_cbsimpleboardtab\cb.simpleboardtab.php on line 76.

The problem occurs merely because the cb.kunenatab plugin is installed ... irrespective of whether it is published! :ohmy: The solution is to either uninstall the standard cb.simpleboardtab (which can't be done because it's a core component of Community Builder! :( ) or ininstall the cb.kunenatab plugin. I went for the line of least resistance and removed the cb.kunenatab plugin and, hey presto, I could operate Community Builder again! :woohoo:

However, this doesn't solve the initial problem: how to add a forum tab on a CB profile that operates with Kunena. :S The best solution that I've found is the "Tony Woodhouse" method: see Kunena Integration with CB - Step by step guide.
Last edit: 15 years 1 month ago by sozzled.

Please Log in or Create an account to join the conversation.

More
15 years 1 month ago #6 by puffermedia
sozzled wrote:

The "missing directory on installation" problem is a relatively simple one to fix. Assuming that you're trying to install the CB tab plugin for Kunena 1.0.8 , create the following directories

/components/com_comprofiler/plugin/user/plug_cbkunena/
/components/com_comprofiler/plugin/user/plug_cbkunena/joomlaboard

then install the plugin from the Community Builder plugin installation control panel.


These were exactly the instructions I needed. Short and to the point and worked like a charm.

Thanks.

Please Log in or Create an account to join the conversation.

More
15 years 1 month ago #7 by sozzled
Replied by sozzled on topic Re:[file]CB tab for Kunena
@puffermedia: thanks, I'm pleased you solved your installation problems. Have you also read what I wrote in #9839 above: now that you've installed the new plugin, does the the Community Builder Check Community Builder User Fields Database tool still work?

Please Log in or Create an account to join the conversation.

More
15 years 1 month ago #8 by puffermedia
Grrr... I'm beginning to remember why CB sucks to administer. :angry:

Soz, yeah, I ran the CB tools and it completely destroyed the fireboard tab.

Oh well, back to square one.

Please Log in or Create an account to join the conversation.

More
13 years 4 months ago #9 by jorgegoi
Replied by jorgegoi on topic Re:[file]CB tab for Kunena
I have the same problem; anybody managed to fix this, please share your knowledge.
:whistle:

Please Log in or Create an account to join the conversation.

More
13 years 4 months ago - 13 years 4 months ago #10 by sozzled
Replied by sozzled on topic Re:[file]CB tab for Kunena

jorgegoi wrote: I have the same problem; anybody managed to fix this, please share your knowledge.
:whistle:

I think you should read I have the same problem ...

This topic involves problems with K 1.0.8, Joomla 1.0.15 and CB 1.1. None of these products is supported any more. Is that the same problem that you are having? :dry:

jorgegoi: When you write "I have the same problem", in the context of a discussion that took place 18 months ago, please try to be quite specific about the nature of your problem. Thank you.
Last edit: 13 years 4 months ago by sozzled.

Please Log in or Create an account to join the conversation.

Time to create page: 0.623 seconds