×
Kunena 5.1.5 Released - Security Release (14 Oct 2018)

The Kunena team has announce the arrival of Kunena 5.1.5 [K 5.1.5] which is now available for download as a native Joomla extension for J! 3.8.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1. This is a Security release.

× This is not a support forum for AlphaUserPoints or its related products. For AlphaUserPoints support you should visit AlphaPlug .

The information given in this category is intended to guide users who want to use AlphaUserPoints with Kunena and, mostly, was written by Kunena users. The information here is not necessarily accurate, up-to-date nor is it intended to replace the support given by the developers of AlphaUserPoints.

If you are having problems then, for your own benefit, it would save us all a lot of time if you would kindly post your configuration report when you ask for help from this forum. If you do not post your configuration report we will not ask you for it but you will probably not get your problem solved, either.

Important K 3.0.4: AlphaUserPoints integration plugin problems

More
4 years 9 months ago - 4 years 9 months ago #1 by bernard92000
The alphauserpoint (1.9.3) points are always equal to 0 (into the forum) since Kunena 3.0.4 (ok for Kunena 3.0.3).

For getUserMedals()’ event’. I checked and the function from the plugin is called but the return is always equal to null into the view.html.php file (see below).
Into the file /components/com_kunena/views/topic/view.html.php
line 568: $this->usermedals = $activityIntegration->getUserMedals ( $this->profile->userid );
This always return null.

Same for line 567: $this->userpoints = $activityIntegration->getUserPoints ( $this->profile->userid );
Last edit: 4 years 9 months ago by bernard92000.
The following user(s) said Thank You: xristo

Please Log in or Create an account to join the conversation.

More
4 years 9 months ago - 4 years 9 months ago #2 by Artaxerxes
Since Kunena 3.0.4 the links from Alpha User Points Modules to Kunena Forum-Profiles are not working too.

It's a 404 error: Kunena view 'fbprofile' not found

Please make a fix for this :)
Last edit: 4 years 9 months ago by Artaxerxes.
The following user(s) said Thank You: xristo

Please Log in or Create an account to join the conversation.

More
4 years 8 months ago #3 by xillibit
Hello,

You need to have an menu item pointing to AUP profile else when you click on user in kunena you will have a fatal error because it doesn't found the itemid.

I will investigate to found the issue with points equal to 0.

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
4 years 7 months ago - 4 years 7 months ago #4 by bernard92000
Hello,

note: for kunena 3.0.3 (& before) there is no need to have a menu item pointing to AUP profile to have the ‘Points: 0’(or another point count) displayed near the post.

For Kunena 3.0.4 and 3.0.5 it’s not working any more (no point count displayed under the avatar). Re-tested with the new Kunena 3.0.5 & J! 2.5.19 with and without menu item pointing to AUP profile => nothing displayed :-( .
Last edit: 4 years 7 months ago by bernard92000.

Please Log in or Create an account to join the conversation.

More
4 years 4 months ago #5 by xillibit
Hello,

There is an issue in Kunena, apply this change to make it working : github.com/Kunena/Kunena-Forum/pull/2508/files

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.137 seconds