×
Blue Eagle 5 v1.5.4 has been Released (13 Sep 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.4 which is now available for download. This version addresses most of the issues that were discovered in development.

Question [Gelöst] Migration Kunena 1.0 auf 1.5 (J1.0 auf 1.5)

More
10 years 11 months ago - 10 years 10 months ago #1 by Ishtar
Hi

Obwohl es für mich nach einer Frage klingt, die bestimmt irgendwo beantwortet wurde, konnte ich mit der SuFu nichts finden :( (oder ich steh auf dem Schlauch :huh: )

Ich bin dabei mein j1.0 auf j1.5 zu migrieren. Im Zuge dessen habe ich bereits mein FB auf das aktuellste Kunena 1.0.11 aktualisiert.
Wie migriere ich jetzt auf Kunena 1.5.6?
Unter den Docs habe ich nur "upgrading to latest Kunena 1.5 bzw. 1.0" gefunden.

Geht es ähnlich? Einfach altes Kunena 1.0 deinstallieren und auf j1.5 das neue Kunena 1.5 installieren?

LG
Ishtar

Greetings - Ishtar

_________________________
J 2.5.24
Kunena 3.0.5
CB 1.9.1
Last edit: 10 years 10 months ago by Ishtar.

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago - 10 years 11 months ago #2 by rich
Herzlich willkommen Ishtar!

Du verwendest jetzt Joomla 1.5.x und Kunena 1.0.11 im legacy Modus (nehme ich an).
Einfach nur Kunena 1.5.6 drüber installieren. Funktioniert tadellos.
Vorher Sicherung nicht vergessen.

Gruß, rich
Last edit: 10 years 11 months ago by rich.

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago #3 by Ishtar
Hi Rich

Danke für die Willkommensgrüße! :cheer:

Momentan benutze ich noch j1.0 und bereite einfach alles vor.

Deiner Antwort nach zu urteilen kann ich also einfach auf j1.5 Kunena 1.5 installieren.

Gut, somit ist die letzte Komponente auf Stand und ich kann morgen mit der Migration durchstarten B)

Vielen Dank und liebe Grüße
Ishtar

Greetings - Ishtar

_________________________
J 2.5.24
Kunena 3.0.5
CB 1.9.1

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago - 10 years 11 months ago #4 by rich
Nein, Kunena 1.5 ist nicht für Joomla 1.0.x gedacht.
Exportiere jetzt mal die Datenbank von Kunena 1.0.11 (alle was mit jos_fb beginnen) und speichere diese irgendwo.
Dann musst du zuerst Joomla 1.0 zu Joomla 1.5 migrieren, danach dort dein Kunena 1.0.11 im Legacy Modus installieren. Anschließend importierst du die gespeicherte Datenbank, damit das Forum wieder komplett hergestellt ist.
Und erst danach Kunena 1.5 drüber installieren.
Last edit: 10 years 11 months ago by rich.

Please Log in or Create an account to join the conversation.

More
10 years 11 months ago #5 by Ishtar
Ah - jetzt verstanden!
Vielen Dank fürs nochmal genauer erklären, das hätt ich ansonsten falsch gemacht!

LG
Ishtar

Greetings - Ishtar

_________________________
J 2.5.24
Kunena 3.0.5
CB 1.9.1

Please Log in or Create an account to join the conversation.

More
10 years 10 months ago #6 by Ishtar
Mhmm evt. mach ich doch etwas falsch:

1. phpmyadmin Datenbank j1.0 alle jos_fb exportiert über die myadmin funktion
2. phpmyadmin Datenbank j1.5 gzip datei importiert.

Ich kriege folgende Fehlermeldung:
SQL-Befehl:
 
-- -- Daten für Tabelle `jos_fb_categories` -- INSERT INTO `jos_fb_categories` (`id`, `parent`, `name`, `cat_emoticon`, `locked`, `alert_admin`, `moderated`, `moderators`, `pub_access`, `pub_recurse`, `admin_access`, `admin_recurse`, `ordering`, `future2`, `published`, `checked_out`, `checked_out_time`, `review`, `hits`, `description`, `headerdesc`, `class_sfx`, `id_last_msg`, `numTopics`, `numPosts`, `time_last_msg`) VALUES (503, 0, 'Rund um Sternenkreis', 0, 0, 0, 1, NULL, 0, 0, 0, 0, 10, 0, 1, 0, '0000-00-00 00:00:00', 0, 0, '', '', '', 8276, 90, 453, 1255859119), (504, 0, 'Heidnische Traditionen', 0, 0, 0, 1, NULL, 0, 0, 0, 0, 20, 0, 1, 0, '0000-00-00 00:00:00', 0, 0, '', '', '', 8109, 84, 888, 1245439180), (508, 0, 'Götter, Wesen, Ahnen', 0, 0, 0, 1, NULL, 0, 0, 0, 0, 30, 0, 1, 0, '0000-00-00 00:00:00', 0, 0, '', '', '', 7667, 37, 405, 1227530304), (506, 0, 'Heidnisches Leben', 0, 0, 0, 1, NULL, 0, 0, 0, 0, 40, 0, 1, 0, '0000-00-00 00:00:00', 0, 0, '', '', '', 8241, 120, 961,[...]
 
MySQL meldet: Dokumentation
#1062 - Doppelter Eintrag '1' für Schlüssel 1

Und jetzt?

Greetings - Ishtar

_________________________
J 2.5.24
Kunena 3.0.5
CB 1.9.1

Please Log in or Create an account to join the conversation.

More
10 years 10 months ago #7 by rich
Hallo Ishtar,

gehn wir das ganze noch mal von Anfang durch.

Du hattest das Forum von Fireboard zu Kunena 1.0.11 migriert und es ist fehlerfrei gelaufen.
Anschließend hattest du die Datenbank jos_fb gesichert und Joomla 1.0 zu Joomla 1.5 migriert.
Danach hattest du Kunena 1.0.11 im Legaci Modus installiert und auch dieses ist fehlerfrei gelaufen.
Dann hast du die Tabellen jos_fb geleert/gelöscht und deine gesicherte Datenbank mit myphpAdmin zurück kopiert.
Ist danach Kunena 1.0.11 fehlerfrei gelaufen? Ab wann sind Fehler aufgetreten?

Please Log in or Create an account to join the conversation.

More
10 years 10 months ago #8 by Ishtar
Hi Rich

Ich konnte den Fehler gestern beheben. Ich habe einfach alle FB-Tabellen einzeln exportiert und importiert (und nicht alle zusammen) und dann ging es (obwohl ich einige mehrmals importieren musste, teilweise mit gzip statt zip). Ich habe die Tabellen jos_fb vorher nicht geleert / gelöscht, evt. hat das Probleme verursacht.

Im nächsten Schritt ist aber auch wieder ein Problem aufgetreten :unsure:

Ich habe geprüft ob Kunena 1.0.11 im legacy modus funktioniert
Kunena 1.0.11 deinstalliert
Kunena 1.5.6 installiert

In blau erscheint * Installiere Komponente erfolgreich!
von Kunena kommt die Meldung: I N S T A L L : F A I L E D - Minimum Version Requirements not satisfied php version: 4.4.9-0.dotdeb.1 (Required >= 5.0.3)

Auf der Serverinfo meines Servers steht php 4 und 5
Beim Versuch im Backend auf Kunena zuzugreifen erhalte ich Parse error: syntax error, unexpected T_CLASS in .../www.sternenkreis.de/components/com_kunena/lib/kunena.config.class.php on line 65

Sollte ich mich jetzt mit meinem Hoster in Verbindung setzen? Oder muss ich jetzt doch mit Kunena 1.0.11 arbeiten?

Gruß
Ishtar

Greetings - Ishtar

_________________________
J 2.5.24
Kunena 3.0.5
CB 1.9.1

Please Log in or Create an account to join the conversation.

More
10 years 10 months ago #9 by rich
Hallo Ishtar,

schön, dass es jetzt einigermaßen geklappt hat. Wenn du die Tabelle vorher nicht geleert hattest, dann wird dies fast sicher den Fehler verursacht haben (deshalb auch die Fehlermeldung "doppelter Eintrag").

Wenn jetzt Kunena 1.0.11 im Legaci Modus ordentlich läuft, dann lasse es vorerst mal so.
Setze dich zuerst mit deinem Hoster in Verbindung und danach kannst du zu Kunena 1.5 umsteigen.
Die technischen Mindestanforderungen findest du hier.
Kunena 1.0.11 solte nur eine vorübergehende Lösung sein.

Kunena 1.5 sollte danach, wenn die Anforderungen stimmen, problemlos drüber installiert werden können, ohne dass du 1.0.11 vorher deinstallierst.

Gruß, rich

Please Log in or Create an account to join the conversation.

More
10 years 10 months ago #10 by Ishtar
Ok, vielen Dank

Ich habe meinem Hoster geschrieben, mal sehen, was er mir antwortet.

LG
Ishtar

Greetings - Ishtar

_________________________
J 2.5.24
Kunena 3.0.5
CB 1.9.1

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.133 seconds