Kunena 6.3.2 released

The Kunena team has announce the arrival of Kunena 6.3.2 [K 6.3.2] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3
Note: Please go to the Kunena Dashboard after an upgrade so that the Kunena database tables are also updated.

Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Question PHP DOM Extension: DOMDocument error

More
12 years 6 months ago #1 by Baze
Hi guys,

i'm trying to update 1.6.3 to 1.7.1 but as soon as the installation started i got:

REQUIREMENTS CHECK: FAILED - Minimum version requirements not satisfied
PHP version: 5.2.17 (Required >= 5.2.3)
MySQL version: 5.0.77-log (Required >= 4.1.19)
Joomla version: 1.5.25 (Required >= 1.5.20)
PHP DOM Extension: DOMDocument (Required)

i've google it but i can't sort it out, i'm running on CentOS, and already tried sudo yum install php-xml and restarting apache but it didn't work. I'm trying to locate the correct php.ini to see whether the installation is ok, but in /etc/php.ini there is no line mentioning extensions=dom.

any help is appreciated, also let me know if i can somehow revert the update process untill i sort this one out.

thanks,
Baze

Please Log in or Create an account to join the conversation.

More
12 years 6 months ago #2 by sozzled
Yes, you can revert to the previous installation. Just install the K 1.6.3 installation package over what you've currently got. Read K 1.6 and K 1.7 Upgrade Guide for further information. As you will see, sometimes it's worthwhile checking any specific technical requirements given in the "read me" documentation. As far as the message "PHP DOM Extension: DOMDocument (Required): is concerned, that's something you might need to follow-up with your webhosting service provider.

Please Log in or Create an account to join the conversation.

More
12 years 6 months ago #3 by Baze
Thanks for the reply Sozzled, meanwhile i've managed to install the Dom extension on the server and continued with the upgrade but now i get this error:

Prepare Installation ... OK
... FAILED Uncaught Exception: File './motori_dbweb/jos_kunena_announcement.MYD' not found (Errcode: 2) SQL=SHOW COLUMNS FROM `jos_kunena_announcement`

when i open the file locations on the server i see only theese:
jos_kunena_announcement.frm
jos_kunena_announcement.MYI

any idea what might be the problem?

Please Log in or Create an account to join the conversation.

More
12 years 6 months ago #4 by Baze
Edit: I've recreated the table using the sql from one of my backups and the setup continued, so far so good.

Please Log in or Create an account to join the conversation.

More
12 years 6 months ago #5 by sozzled
I really don't know too much about this except that it looks like you might have a problem with the database.

Where do those files reside (what is the folder path). Did you revert back to K 1.6.3 and then try to upgrade to K 1.7.1?

Please Log in or Create an account to join the conversation.

More
12 years 6 months ago #6 by Baze
the files are created by mysql server, they can be found in the server (usr/lib/mysql) folder and for some reason the file for the announcements was corrupted. After recreating the table the server created new file and the update continued. Now i'm on K1.7.1 and happy ;)

Please Log in or Create an account to join the conversation.

More
12 years 6 months ago #7 by sozzled
Excellent. Case closed. In future, try to keep your system up-to-date on a more regular basis instead of waiting nearly a year and everything becomes a last-minute dash. ;)
The following user(s) said Thank You: Baze

Please Log in or Create an account to join the conversation.

Time to create page: 0.447 seconds