×
Kunena 5.2.9 released and Kunena 6.0.0 (08 Jun 2022)

The Kunena team has announce the arrival of Kunena 5.2.9 [K 5.2.9] which is now available for download as a native Joomla extension for J! 3.10. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of previous version of K5.2.

The Kunena team has announce the arrival of Kunena 6.0.0 [K 6.0.0] which is now available for download as a native Joomla extension for J! 4.1.x. Only the module kunena latest and the discuss plugin which are still in beta are working in Joomla! 4.1 with Kunena 6.0.

× This category is for K 1.7 issues only.

Question Upgrading Issues

More
10 years 2 months ago - 10 years 2 months ago #1 by devilstormz
Upgrading Issues was created by devilstormz
Hey guys,

This is my current setup of the website:

- Joomla 1.5
-Community builder
-Kunena 1.7.0


I have been using Kunena since 1.5 and have had no issues upgrading it. Sadly however, I have encountered an issue when doing the upgrade from 1.7.0 to 1.7.2. After carrying out preliminary steps such as taking backups etc. I run the installer using the joomla install manager and get the following as shown in the image.

So, the first issue was obviously the version numbers but I read on the forums that it was due to the language packs and nothing more.



Secondly its telling me to downgrade ?? I have checked that 1.70 is installed according to the following screenshot.




So i decide to click downgrade to 1.7.0 and then end up with a blank page with the error message

-1- An error occured

A folder already exists.

So then i decided to uninstall kunena which went smoothly, I took a backup of the database and dropped all the tables containing jos_kunena.

Connected to FTP and checked that any folders existed relating to kunena but the unistaller seemed to have removed them all.

I checked the following locations

root/administrator/components/
root/components
root/media
root/modules
root/plugins

Once this was done, I went to re install it and the same error comes up!

So any help/ guidance would be greatly appreciated to resolve this issue. If all else fails could some one tell me how to manually unistall the forums because I thought I removed everything relating to it including entries in the database but apparently not.

Also note the frontend of the website is fully functional which is weird considering it says it has been taken down but backend doesnt work so cannot edit any of the config, categories.

Thanks in advance

Matt
Attachments:
Last edit: 10 years 2 months ago by devilstormz.

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago #2 by xillibit
Replied by xillibit on topic Re: Upgrading Issues
Hello,

Check directories permissions : root/administrator/components/
root/components
root/media

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago - 10 years 2 months ago #3 by devilstormz
Replied by devilstormz on topic Re: Upgrading Issues
They were 755 already but I tried with 777 instead but I still get the same error.

I just created 2 fresh installs one with joomla 1.5.2 and another with 2.5.2

There werent any issues installing the forum whatsoever with the same permissions etc...

So we can rule out any issues with hosting side of things.

Perhaps there is something to do with the database.

EDIT:

I managed to uninstall 1.7.0 and then was able to install kunena 1.6.4 and I was back into the backend. But trying to install 1.6.5 I get the same error so I tried 1.7.0 and it says it has installed but then brings me back to the first screenshot.

Could you just advise me how to manually remove so I can "fresh" install.
Last edit: 10 years 2 months ago by devilstormz.

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago #4 by sozzled
Replied by sozzled on topic Re: Upgrading Issues
There are ways of completely removing your forum, all the data, etc., if that is what you want to do. K 1.6 is not supported.

Is it possible to include a copy of your configuration report, please?

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago - 10 years 2 months ago #5 by devilstormz
Replied by devilstormz on topic Re: Upgrading Issues

Last PHP Error(s) Reported :: Forum Post Assistant (v1.2.0) : 14th April 2012 wrote: [14-Apr-2012 11:47:55] PHP Warning: Invalid argument supplied for foreach() in /home/tecclan1/public_html/administrator/components/com_comprofiler/plugin.class.php on line 442

Forum Post Assistant (v1.2.0) : 14th April 2012 wrote:

Basic Environment :: wrote: Joomla! Instance :: Joomla! 1.5.26-Stable (senu takaa ama busani) 27-March-2012
Joomla! Platform :: Nooku 0.7.0-alpha-2.-alpha ()
Joomla! Configured :: Yes | Writable (777) | Owner: tecclan1 (uid: 543/gid: 539) | Group: tecclan1 (gid: 539) | Valid For: 1.5
Configuration Options :: Offline: 0 | SEF: 0 | SEF Suffix: 0 | SEF ReWrite: 0 | .htaccess/web.config: Yes | GZip: 0 | Cache: 0 | FTP Layer: 0 | SSL: 0 | Error Reporting: -1 | Site Debug: 0 | Language Debug: 0 | Database Credentials Present: Yes

Host Configuration :: OS: Linux | OS Version: 2.6.18-308.1.1.el5xen | Technology: x86_64 | Web Server: Apache | Encoding: gzip,deflate,sdch | Doc Root: /home/tecclan1/public_html | System TMP Writable: Yes

PHP Configuration :: Version: 5.2.9 | PHP API: cgi | Session Path Writable: Unknown | Display Errors: 1 | Error Reporting: 6135 | Log Errors To: error_log | Last Known Error: 14th April 2012 06:47:55. | Register Globals: 1 | Magic Quotes: 1 | Safe Mode: 0 | Open Base: | Uploads: 1 | Max. Upload Size: 10M | Max. POST Size: 8M | Max. Input Time: 60 | Max. Execution Time: 30 | Memory Limit: 48M

MySQL Configuration :: Version: 5.1.61 (Client:5.1.61) | Host: --protected-- (--protected--) | Collation: utf8_general_ci (Character Set: utf8) | Database Size: 1.75 MiB | #of _FPA_TABLE: 113

Detailed Environment :: wrote: PHP Extensions :: zip (1.8.11) | libxml () | xsl (0.1) | xmlwriter (0.1) | xmlrpc (0.51) | dom (20031129) | xmlreader (0.1) | xml () | wddx () | tokenizer (0.1) | tidy (2.0) | session () | pcre () | SimpleXML (0.1) | sockets () | SPL (0.2) | standard (5.2.9) | Reflection (0.1) | pspell () | posix () | mysqli (0.1) | mysql (1.0) | mhash () | mcrypt () | mbstring () | json (1.2.1) | imap () | iconv () | hash (1.0) | gettext () | gd () | ftp () | filter (0.11.0) | dbase () | date (5.2.9) | curl () | ctype () | calendar () | bz2 () | bcmath () | zlib (1.1) | openssl () | cgi () | PDO (1.0.4dev) | pdo_sqlite (1.0.1) | SQLite (2.0-dev) | pdo_mysql (1.0.2) | ionCube Loader () | Zend Optimizer () | Zend Engine (2.2.0) |
Potential Missing Extensions :: suhosin |

Switch User Environment (Experimental) :: PHP CGI: Yes | Server SU: Yes | PHP SU: Yes | Custom SU (LiteSpeed/Cloud/Grid): No
Potential Ownership Issues: Maybe

Folder Permissions :: wrote: Core Folders :: images/ (755) | components/ (777) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (755) | logs/ (755) | tmp/ (755) | administrator/components/ (777) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) | sites/ (---) |

Elevated Permissions (First 10) :: None components/ (777) | components/com_jsecure/ (777) | components/com_mailto/ (777) | components/com_newsfeeds/ (777) | components/com_rokcandy/ (777) | components/com_rokcandybundle/ (777) | components/com_roknavmenubundle/ (777) | components/com_search/ (777) | components/com_weblinks/ (777) |

Database Information :: wrote: Database _FPA_STATS :: Uptime: 232810 | Threads: 1 | Questions: 8872266 | Slow queries: 31 | Opens: 374225 | Flush tables: 5 | Open tables: 1024 | Queries per second avg: 38.109 |

Extensions Discovered :: wrote: Components :: SITE :: Wrapper (1.5.0) | MailTo (1.5.0) | Gantry (3.1.13) | User (1.5.0) | Kunena Forum - English (1.7.0) | WF_FULLSCREEN_TITLE (2.0.12) | WF_XHTMLXTRAS_TITLE (2.0.12) | WF_SEARCHREPLACE_TITLE (2.0.12) | WF_BROWSER_TITLE (2.0.12) | WF_LAYER_TITLE (2.0.12) | WF_LINK_TITLE (2.0.12) | WF_AUTOSAVE_TITLE (2.0.12) | WF_STYLE_TITLE (2.0.12) | WF_CONTEXTMENU_TITLE (2.0.12) | WF_SPELLCHECKER_TITLE (2.0.12) | WF_PREVIEW_TITLE (2.0.12) | WF_DIRECTIONALITY_TITLE (2.0.12) | WF_PRINT_TITLE (2.0.12) | WF_VISUALCHARS_TITLE (2.0.12) | WF_SOURCE_TITLE (2.0.12) | WF_TABLE_TITLE (2.0.12) | WF_CLEANUP_TITLE (2.0.12) | WF_MEDIA_TITLE (2.0.12) | WF_TEXTCASE_TITLE (2.0.12) | WF_IMGMANAGER_TITLE (2.0.12) | WF_ARTICLE_TITLE (2.0.12) | WF_NONBREAKING_TITLE (2.0.12) | WF_INLINEPOPUPS_TITLE (2.0.12) | WF_PASTE_TITLE (2.0.12) | WF_MEDIAPLAYER_JCEPLAYER_TITLE (2.0.12) | WF_FILESYSTEM_JOOMLA_TITLE (2.0.12) | WF_AGGREGATOR_VIMEO_TITLE (2.0.12) | WF_AGGREGATOR_YOUTUBE_TITLE (2.0.12) | WF_LINKS_JOOMLALINKS_TITLE (2.0.12) | WF_POPUPS_JCEMEDIABOX_TITLE (2.0.12) | WF_POPUPS_WINDOW_TITLE (2.0.12) | CB Mambo Author Tab (1.2) | CB Captcha (1.2 RC 2) | Yanc Integration (1.2) | CB Mamblog Tab (1.2) | comprofiler (1.8) |
Components :: ADMIN :: Configuration Manager (1.5.0) | RokCandy Bundle (1.4) | Installation Manager (1.5.0) | jsecure (2.1.2) | Cache Manager (1.5.0) | Language Manager (1.5.0) | RokNavMenu Bundle (2.11) | Weblinks (1.5.0) | RokCandy (1.4) | Ninja (1.0.0) | Newsfeeds (1.5.0) | Menus Manager (1.5.0) | Search (1.5.0) | Module Manager (1.5.0) | Banners (1.5.0) | Gantry (3.1.13) | Frontpage (1.5.0) | com_kunena (1.7.2) | Kunena Forum - English (1.7.0) | Unknown (-) | Kunena language pack (@kunenaversio) | plg_system_kunena (-) | plg_system_kunena (1.7.0) | System - Kunena (1.7.0) | Kunena (1.7.0) | Messaging (1.5.0) | RokModule (1.2) | Plugin Manager (1.5.0) | Polls (1.5.0) | Editor - JCE (2.0.12) | Unknown (-) | JCE (2.0.12) | Control Panel (1.5.0) | Template Manager (1.5.0) | Free PayPal (1.5.13) | extensions (0.7) | Media Manager (1.5.0) | Trash (1.0.0) | Admintools (2.1.6) | Contact Items (1.0.0) | User Manager (1.5.0) | comprofiler (1.8) | Content Page (1.5.0) | Akeeba (3.4.3) | uddeim (2.4) | Mass Mail (1.5.0) |

Modules :: SITE :: RokMiniEvents (1.5) | AJAX Shoutbox (1.4) | RokTabs (1.19) | Search (1.0.0) | Login (1.5.0) | Latest News (1.5.0) | RokFeatureTable (1.1) | CB Login (1.7) | Statistics (1.5.0) | Banner (1.5.0) | CB Workflows (1.7) | RokStories (2.2) | Feed Display (1.5.0) | Menu (1.5.0) | Archived Content (1.5.0) | RokContentRotator (1.5) | Ninjaboard Quickpanel (1.1.0) | Random Image (1.5.0) | Kunena Latest (1.7.0) | Newsflash (1.5.0) | Footer (1.5.0) | RokNewsPager (1.8) | RokTwittie (2.3) | uddeIM Notifier (2.4) | uddeIM Notifier (2.4) | Wrapper (1.0.0) | Syndicate (1.5.0) | RokNavMenu (2.11) | Sections (1.5.0) | Custom HTML (1.5.0) | Breadcrumbs (1.5.0) | Related Items (1.0.0) | Most Read Content (1.5.0) | Who\'s Online (1.0.0) | Poll (1.5.0) |
Modules :: ADMIN :: Admin Submenu (1.0.0) | Login Form (1.0.0) | Admin Menu (1.0.0) | Quick Icons (1.0.0) | Latest News (1.0.0) | Title (1.0.0) | Items Stats (1.0.0) | Toolbar (1.0.0) | Unread Items (1.0.0) | Feed Display (1.5.0) | Logged in Users (1.0.0) | Footer (1.0.0) | User Status (1.5.0) | Akeeba Backup Notification Mod (3.4.3) | Custom HTML (1.5.0) | Online Users (1.0.0) | Admin Tools Joomla! Upgrade No (svn385) | Popular Items (1.0.0) |

Plugins :: SITE :: XML-RPC - Blogger API (1.0) | XML-RPC - Joomla API (1.0) | RokNavMenu - Boost (2.11) | RokNavMenu - Extended Link (2.11) | User - Example (1.0) | User - Joomla! (1.5) | Search - Categories (1.5) | Search - Content (1.5) | Search - Newsfeeds (1.5) | Search - Weblinks (1.5) | Search - Ninjaboard (1.0) | Search - Sections (1.5) | Search - Contacts (1.5) | Editor - TinyMCE 3 (3.2.6) | Editor - RokPad (1.7.2) | Editor - XStandard Lite for Jo (1.0) | Editor - JCE (2.0.12) | Authentication - GMail (1.5) | Authentication - LDAP (1.5) | Authentication - Example (1.5) | Authentication - Joomla (1.5) | Authentication - OpenID (1.5) | Button - Readmore (1.5) | Button - Image (1.0.0) | Button - RokCandy (1.4) | Button - Pagebreak (1.5) | Content - Email Cloaking (1.5) | Content - Load Modules (1.5) | Content - Code Highlighter (Ge (1.5) | Content - Example (1.0) | Content - Vote (1.5) | Content - RokBox (1.8) | Content - Page Navigation (1.5) | Content - Pagebreak (1.5) | System - Registration Validato (1.3.0) | System - Cache (1.5) | System - One Click Action (1.0) | System - jSecure Authenticatio (2.1.2) | System - Ninja Framework (1.5.0) | System - Mootools Upgrade (1.5) | System - Akeeba Backup Update (1.0) | System - RokCandy (1.4) | System - Debug (1.5) | System - Koowa (0.7.0) | System - Remember Me (1.5) | System - Kunena (1.7.0) | System - System Restore Points (3.3.4) | System - RokGantry Cache (1.0) | System - RokBox (2.6) | System - Log (1.5) | System - Legacy (1.5) | System - RokGZipper (1.12) | System - Admin Tools (2.1.6) | System - Backlinks (1.5) | System - SEF (1.5) | Akeeba Backup Lazy Scheduling (3.3) |

Templates Discovered :: wrote: Templates :: SITE :: JA_Purity (1.2.0) | rhuk_milkyway (1.0.2) | rt_nebulae_j15 (1.5.0) | beez (1.0.0) |
Templates :: ADMIN :: Khepri (1.0) |


Thanks for the reply sozzled and here is the report you requested.

I am aware that 777 chmod is unnecessary but I have changed it just to see if they were permission issues as mentioned previously.
Last edit: 10 years 2 months ago by devilstormz.

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago #6 by sozzled
Replied by sozzled on topic Re: Upgrading Issues
Thank you for that very interesting report generated by Forum Post Assistant .

First of all, never use CHMOD 777 on a Joomla site. Read Securing Kunena

The problem is not caused by wrong file permissions anyway. The problems are being caused by all that Rockettheme stuff that you have loaded on your site, especially that RokGZipper plugin that has been the source of many problems people have with Kunena.

I would be willing to bet any money you like that if you tried the approach in When all else fails, try this . Yours is a classic case of Which came first? The template or the forum?

Your task should be to install K 1.7.2 (don't mess around with K 1.7.0 which is not supported anyway) and to use the updated language pack for K 1.7.2 (available from the download page). To do that, you need to remove, one by one, each plugin that is interfering with successfully allowing you to upgrade Kunena. Start with all the Rockettheme plugins first and see how you go; if they weren't causing the problem, then work your way further until you find the culprit.

I like the output generated by Forum Post Assistant, by the way. It's missing one or two things that are included in the Kunena forum configuration report , but it certainly saves a lot of time asking you, "What else have you installed that might be interfering?"

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago #7 by devilstormz
Replied by devilstormz on topic Re: Upgrading Issues
Thanks for the prompt reply, I will try what you have suggested and get back to you so you are aware what went wrong which might be useful in case someone runs into a similar issue.

I would love to upgrade to the latest version too :)

I have to agree with you on some of the conflicts with rockettheme templates and kunena as I did experience with the Board code not appearing and was caused by rokbox plugin.

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago #8 by sozzled
Replied by sozzled on topic Re: Upgrading Issues

devilstormz wrote: I have to agree with you on some of the conflicts with rockettheme templates and kunena as I did experience with the Board code not appearing and was caused by rokbox plugin.

FYI RokCandy is a bigger cause of BBcode problems!

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.173 seconds