×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Question Error 500 Uploading Multiple Large Images

More
9 years 1 month ago - 9 years 1 month ago #1 by Tezzating
Hi guys, I've been trying to diagnose this problem for a while now. If a user uploads multiple large files (Eg. original sized digital camera shots), Kunena will upload/resize/post the FIRST one, but generate Error 500 and not return to the post.

You can upload multiple images just fine if they've been resized to smaller than the forums size limit (3000Kb file size, 1024x768).

Here's the diagnostics report:
This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 300 seconds | Max execution memory: 128M | Max file upload: 8M

Kunena version detailled: Installed version: 1.6.0 | Build: 3620 | Version name: Spika | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Disabled or not installed | Jomsocial: Disabled or not installed | UddeIm: Installed (Version : 2.0)

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Enabled | JFirePHP: Disabled or not installed | Kunena Discuss: Disabled or not installed | Kunena Search: Disabled or not installed | My Kunena Forum Menu: Disabled or not installed

Modules: Kunena Latest: Disabled or not installed | Kunena Stats: Disabled or not installed | Kunena Login: Disabled or not installed


I dont think this is specifically a Kunena issue but possibly something in my server/PHP config. Any suggestions ?
Last edit: 9 years 1 month ago by Tezzating.

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago #2 by sozzled
Thank you for your question. I don't have a specific answer but you may be on the right track as far as PHP being involved and the 8 Mb total file upload that you have in place on your website.

Although Kunena can handle image uploads, people often forget that Kunena is a web-based, text-oriented discussion forum product. In other words, Kunena's main utility is to allow people to discuss things. Images are important but they much better products that are available that allow people to share their images, catalogued and organised in ways that make them easier for others to access them and with improved security mechanisms to ensure that only those people who should view your images can view those images. Kunena doesn't really do those things as well as a lot of other products do.

So, if you're having problems uploading or distributing large-sized images, you might consider alternative software to handle these needs ... at least as a workaround. ;)

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago #3 by fxstein
Hi,

Just increase you max file upload. It's right now set to 8MB. So anything more than that will cause your apache server to abort. This is outside the control of Kunena. Try setting it to 32 or even 64MB if you want to allow multiple large files to be attached at once.

Hope this helps!

We love stars on the Joomla Extension Directory . :-)

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago #4 by Tezzating

fxstein wrote: Hi,

Just increase you max file upload. It's right now set to 8MB. So anything more than that will cause your apache server to abort. This is outside the control of Kunena. Try setting it to 32 or even 64MB if you want to allow multiple large files to be attached at once.

Hope this helps!


I'll try this today and let you guys know if it worked or not :)

Please Log in or Create an account to join the conversation.

More
9 years 1 month ago - 9 years 1 month ago #5 by Tezzating
I think this is related to the server itself, there's a 90 seconds time out occuring somewhere.
I'm using GoDaddy's Windows hosting (IIS7 & PHP5.x), but suspect the issue lays within the hostings IIS7 settings.

I think its just the size of the files is effecting it due to the upload times.
Last edit: 9 years 1 month ago by Tezzating.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.142 seconds